aspenBCMUnitAssignLearnSTG(2:23,182) - Unit 0 is not initialized for STG LEARNing mode!!! 13-05-20sgs.portLinkStateDown> Port 2:23 link down

  • 0
  • 1
  • Question
  • Updated 4 years ago
aspenBCMUnitAssignLearnSTG(2:23,182) - Unit 0 is not initialized for STG LEARNing mode!!! 13-05-2015 11:05:40 Port 2:23 link down

Can someone advise what this error actually means , connected to this port is a printer
Photo of Rod Robertson

Rod Robertson

  • 222 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Hi Rod,

Could you please share more details about the Switch model you are using and the SW version running on the switch?  

Is STP enabled on this VLAN or port? 
The error seems to be related to the STP learning not being initialized on the port/ASIC properly. 
Photo of Rod Robertson

Rod Robertson

  • 222 Points 100 badge 2x thumb
Hi  yes it an X250 and its running rapid spanning tree..( 15.2.2.7 code) 

configure stpd s1 ports mode dot1d 2:23configure stpd s1 ports cost auto 2:23
configure stpd s1 ports port-priority 128 2:23
configure stpd s1 ports link-type edge 2:23
configure stpd s1 ports edge-safeguard enable 2:23
configure stpd s1 ports bpdu-restrict enable 2:23
enable stpd s1 ports 2:23Slot-1 K2-FLOOR4-Stack-2.9 # sh stp s1Stpd: s1                Stp: ENABLED            Number of Ports: 250
Rapid Root Failover: Disabled
Operational Mode: 802.1W                        Default Binding Mode: 802.1D
802.1Q Tag: 3116
Ports: 1:1,1:2,1:3,1:4,1:5,1:6,1:7,1:8,1:9,1:10,
       1:11,1:12,1:13,1:14,1:15,1:16,1:17,1:18,1:19,1:20,
       1:21,1:22,1:23,1:24,1:25,1:26,1:27,1:28,1:29,1:30,
       1:31,1:32,1:33,1:34,1:35,1:36,1:37,1:38,1:39,1:40,
       1:41,1:42,1:43,1:44,1:45,1:46,1:47,1:48,1:49,1:50,
       2:1,2:2,2:3,2:4,2:5,2:6,2:7,2:8,2:9,2:10,
       2:11,2:12,2:13,2:14,2:15,2:16,2:17,2:18,2:19,2:20,
       2:21,2:22,2:23,2:24,2:25,2:26,2:27,2:28,2:29,2:30,
       2:31,2:32,2:33,2:34,2:35,2:36,2:37,2:38,2:39,2:40,
       2:41,2:42,2:43,2:44,2:45,2:46,2:47,2:48,2:49,2:50,
       3:1,3:2,3:3,3:4,3:5,3:6,3:7,3:8,3:9,3:10,
       3:11,3:12,3:13,3:14,3:15,3:16,3:17,3:18,3:19,3:20,
       3:21,3:22,3:23,3:24,3:25,3:26,3:27,3:28,3:29,3:30,
       3:31,3:32,3:33,3:34,3:35,3:36,3:37,3:38,3:39,3:40,
       3:41,3:42,3:43,3:44,3:45,3:46,3:47,3:48,3:49,3:50,
       4:1,4:2,4:3,4:4,4:5,4:6,4:7,4:8,4:9,4:10,
Participating Vlans: K2-Media-185,K2-Misc-3116,k2-Printer-184,K2-Staff-180,K2-Staff-181,                     K2-Student-182,K2-Student-183,KW2-GST-186
Auto-bind Vlans: K2-Media-185,K2-Misc-3116,k2-Printer-184,K2-Staff-180,K2-Staff-181,
                     K2-Student-182,K2-Student-183,KW2-GST-186
Bridge Priority: 32768
BridgeID:               80:00:02:04:96:35:c4:30
Designated root:        10:00:00:04:96:35:d6:71
RootPathCost: 2         Root Port: 1:50
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 2
Time Since Last Topology Change: 1365156s
Photo of Rod Robertson

Rod Robertson

  • 222 Points 100 badge 2x thumb
We have other stacks on other distribution switches , its only th
is set of switches that we are currently presenting a number of issues we cannot track down..
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Rod,

Thank you for sharing the details. 
These messages should not obviously come up and it looks like a problem to me. 

Few more questions:

- are you seeing this message on a specific port or multiple ports? 
- Does the message come up when the port goes down or comes back up? 
- Once the port is active, are you able to see the FDB entries learnt on the switch? show fdb port <port no>
- Do you see any traffic forwarding issues on these ports? 

Thanks
Photo of Rod Robertson

Rod Robertson

  • 222 Points 100 badge 2x thumb
In this case it specific ports where some printers are attached..well thise are the devices showing the problems..

latest errors from this switch ..

13-05-2015 14:53:55 <HAL.Sys.Warning> Fan Function pointer is not initialized. Caller: 0x4649ac Parm1: 0x5 Parm2: 0x7fff748013-05-2015 14:53:55 <HAL.Sys.Warning> Fan Function pointer is not initialized. Caller: 0x4648ec Parm1: 0x5 Parm2: 0x7fff73f0
13-05-2015 14:49:17 <HAL.Port.Error> aspenBCMUnitAssignLearnSTG(2:8,180) - Unit 0 is not initialized for STG LEARNing mode!!!
13-05-2015 14:49:17 <HAL.Port.Error> aspenBCMUnitAssignLearnSTG(2:8,180) - Unit 0 is not initialized for STG LEARNing mode!!!
13-05-2015 14:49:16 <vlan.msgs.portLinkStateUp> Port 2:8 link UP at speed 100 Mbps and full-duplex
13-05-2015 14:49:14 <HAL.Port.Error> aspenBCMUnitAssignLearnSTG(2:8,180) - Unit 0 is not initialized for STG LEARNing mode!!!
13-05-2015 14:49:14 <vlan.msgs.portLinkStateDown> Port 2:8 link down
13-05-2015 14:48:55 <HAL.Sys.Warning> Fan Function pointer is not initialized. Caller: 0x4649ac Parm1: 0x5 Parm2: 0x7fff7480
13-05-2015 14:48:55 <HAL.Sys.Warning> Fan Function pointer is not initialized. Caller: 0x4648ec Parm1: 0x5 Parm2: 0x7fff73f0
13-05-2015 14:45:47 <vlan.msgs.portLinkStateUp> Port 5:2 link UP at speed 100 Mbps and full-duplex
13-05-2015 14:45:44 <vlan.msgs.portLinkStateDown> Port 5:2 link down
13-05-2015 14:43:55 <HAL.Sys.Warning> Fan Function pointer is not initialized. Caller: 0x4649ac Parm1: 0x5 Parm2: 0x7fff7480
13-05-2015 14:43:55 <HAL.Sys.Warning> Fan Function pointer is not initialized. Caller: 0x4648ec Parm1: 0x5 Parm2: 0x7fff73f0
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Rod,

Thanks for the reply. 
the fan function pointer errors appear cosmetic during bootup based on the internal research. 

I would suggest opening a GTAC case if not already done as we need to look up multiple issues here. 

Thanks
Photo of Rod Robertson

Rod Robertson

  • 222 Points 100 badge 2x thumb
Thanks for your help ... Yep its over to GTAC ... 
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Rod,

Refer this URL for more details on the fan function pointer error. 
http://gtacknowledge.extremenetworks.com/articles/Solution/Warn-HAL-Sys-Warning-Slot-1-Fan-Function-pointer-is-not-initialized-Caller-0x48aa7c-Parm1-0x3-Parm2-0x7fff7398/?q=fan+function+pointer&l=en_US&fs=Search&pn=1

A reboot could get rid of the error. Also observe if the STP related error pops up after reboot. 
If you need further investigation, GTAC case could be helpful. 

Thanks