Authenticated Registration by RADIUS problem

  • 1
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I've configured a captive portal for authenticated registration. When I check the credential against the local DB, it works fine. I have a RADIUS server, which we use to authenticate users for EAP-PEAP and it works also fine. But, when I try to use it for checking the credential entered for authenticated registration, the RADIUS server returns an Access Reject answer. Does somebody has an idea, where could be a problem?
Photo of Gabriel Bagita

Gabriel Bagita

  • 560 Points 500 badge 2x thumb

Posted 2 years ago

  • 1
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 51,164 Points 50k badge 2x thumb
Check the RADIUS server log to see the reason for the reject.
Photo of Gabriel Bagita

Gabriel Bagita

  • 560 Points 500 badge 2x thumb
I'd like to do it, but I can't. I have no access.
Photo of Keene, Scott

Keene, Scott, Employee NMS/GTAC

  • 1,562 Points 1k badge 2x thumb
You will need access the the RADIUS server's event log to tell.
Photo of Keene, Scott

Keene, Scott, Employee NMS/GTAC

  • 1,562 Points 1k badge 2x thumb
Hello,

It is likely that the RADIUS server's RADIUS policy is missing the needed authentication type or perhaps a Policy Condition is not matching.  The Event log should give a reason for the Reject.


Regards,
Scott Keene
Photo of Gabriel Bagita

Gabriel Bagita

  • 560 Points 500 badge 2x thumb
Hi Scott,
your recommendation has helped to me. There was a problem in the Policy. It it is working correctly now.
Thanks
Photo of Keene, Scott

Keene, Scott, Employee NMS/GTAC

  • 1,562 Points 1k badge 2x thumb
Very nice!  I am glad it is working now.
You're welcome.

-Scott