Both nodes in a 2 switch stack show Role as Master

  • 1
  • 1
  • Problem
  • Updated 6 months ago
  • Solved
Switch 2, previously with Role Backup, is now showing at Role Master.  Switch 1 is still actively the Master.  All ports on Switch 2 are now showing as Ready.  Devices connected to Switch 2 are no longer responding.
Photo of Terry Jacobs

Terry Jacobs

  • 120 Points 100 badge 2x thumb
  • Concerned and anxious.

Posted 6 months ago

  • 1
  • 1
Photo of Patrick Voss

Patrick Voss, Employee

  • 11,354 Points 10k badge 2x thumb
Can you send a "show switch" and "show slot"?
Photo of Terry Jacobs

Terry Jacobs

  • 120 Points 100 badge 2x thumb
Show switch displays only switch 1.  Here's output from show slot:
Slot-1 SJCO-DMZ-X460-48T-2.23 # sh slot
Slots    Type                 Configured           State       Ports
--------------------------------------------------------------------
Slot-1   X460-48t             X460-48t             Operational   58
Slot-2   X460-48t             X460-48t             Failed        58
Slot-3                                             Empty          0
Photo of Terry Jacobs

Terry Jacobs

  • 120 Points 100 badge 2x thumb
version 12.5.4.5
Slot-2 information:
     State:               Failed
     Download %:          100
     Restart count:       1 (limit 5)
     Serial number:       800322-00-07 1151G-82157
     Hw Module Type:      X460-48t
     SW Version:          15.2.3.2
     SW Build:            v1523b2-patch1-12
     Configured Type:     X460-48t
     Ports available:     58
     Recovery Mode:       Reset
     Node MAC:            02:04:96:83:9E:27
     Current State:       FAIL
     Image Selected:      secondary
     Image Booted:        secondary
     Primary ver:         12.6.4.1
     Secondary ver:       15.2.3.2
     Config Selected:     primary.cfg
Photo of Terry Jacobs

Terry Jacobs

  • 120 Points 100 badge 2x thumb
Sorry, 15.2.3.2 is the active version.
Photo of Patrick Voss

Patrick Voss, Employee

  • 11,354 Points 10k badge 2x thumb
Can you send a "show slot 2 detail" and also what version of code is running on this stack? The "show switch" should provide that with the patch.
Photo of Patrick Voss

Patrick Voss, Employee

  • 11,354 Points 10k badge 2x thumb
I am sure a reboot of slot 2 will resolve this. As for why there might be something in the logs. Do we know when this happened?

On the other side I would recommend upgrading this stack to the latest of 16.2. In 15.4 some changes were made to the stacking libraries in the code and it prevented these dual master situations.
Photo of Terry Jacobs

Terry Jacobs

  • 120 Points 100 badge 2x thumb
Rebooting the slot resolved the issue.  It's back online.  Once again, thanks for the help.
Photo of Terry Jacobs

Terry Jacobs

  • 120 Points 100 badge 2x thumb
Log states Backup Node Down.  Log entries go back only to 06:00 PST this morning.  That's the first indication.
I'll reboot Node 2.  Thanks very much for responding.