Cannot Disconnect Telnet Session on S-Series , Firmware 7.71.02.0005

  • 1
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
The current equipment has four users Telnet landing, one of which is the current user, the other three are unknown telnet users, but I can not use the disconnect command to play out the other three users, the equipment is S series switches, the version is 7.71.02.0005 , How can I clear out other telnet sessions?



Photo of FengHua Liu

FengHua Liu

  • 124 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,992 Points 20k badge 2x thumb
# disconnect <IP>

Photo of FengHua Liu

FengHua Liu

  • 124 Points 100 badge 2x thumb
thank you,but I have tried this method, but I can not clear the telnet session with the disconnect command,The disconnect command has no effect
Photo of Straw, Glyn

Straw, Glyn, Employee

  • 2,152 Points 2k badge 2x thumb
Unfortunately , on older codes there have been rare situations where telnet sessions can become "locked" and do not release when using the disconnect command.

The only way to recover this on that firmware is to reset the blade. 

i would recommend upgrading to version 8.42.04 as a minimum to take advantage of fixes which make this situation much less likely to occur and also this adds the ability to recover the situation without resetting the blade in the unlikely event that it should happen again. 

This article describes the fix:

https://gtacknowledge.extremenetworks.com/articles/Solution/S-Series-Telnet-SSH-connections-for-mana...

Best Regards
Glyn
Photo of FengHua Liu

FengHua Liu

  • 124 Points 100 badge 2x thumb
glyn,how to do  reset the blade?and Can you give me your email me?i send you an email
Photo of FengHua Liu

FengHua Liu

  • 124 Points 100 badge 2x thumb
Workaround:

Prior to version 8.42.04 the only workaround is to Reset the management blade 


Hi Glyn,I did not understand,How to do reset the management blade ? Thanks
Photo of Straw, Glyn

Straw, Glyn, Employee

  • 2,152 Points 2k badge 2x thumb
unfortunately the only way to workaround this issue on the older firmware is to reset the host master blade ( one with the cpu led lit )

this can be achieved using front panel button or by typing  "reset x" where x is the module number of the host master blade.  Dependent on connections this could cause some interruption.

Best Regards
Glyn
Photo of FengHua Liu

FengHua Liu

  • 124 Points 100 badge 2x thumb
Thanks Glyn,Is it a reboot switch?
Photo of Straw, Glyn

Straw, Glyn, Employee

  • 2,152 Points 2k badge 2x thumb
yes, it will reboot the blade , not the entire chassis. If there is only one blade installed then effectively its the whole switch