Cannot discover topology of switches

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
I have a lab setup where the controller is connected to the management ports of three OF switches through another L2 switch (another X440).
The three switches are able to connect to the controller but the connection between them isn't discovered by the Topology manager in OpenDaylight. I see an empty topology through the REST API and the web view shows three isolated switches.

I suspect this is because the L2 switch isn't forwarding the LLDP packet sent by the controller to the three OF switches. I may be completely wrong though.

Do I need to enable some LLDP related feature/setting on the X440s to forward LLDPs?
Or disable some feature on the one I'm using as a simple L2 switch?

Kindly help me figure out why the topology isn't discovered by the controller.
Photo of Ankit Agrawal

Ankit Agrawal

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
I guess extreme switches have EDP enabled by default.
And LLDP must be enabled manually.
Please try enabling LLDP.
Photo of Masadi, Ravi

Masadi, Ravi, Employee

  • 100 Points 100 badge 2x thumb
Communication between controller and switches is via Open Flow protocol. LLDP packets get encapsulated in Open Flow protocol and send to controller. So L2 switch is not a problem here.

Output of below commands from all switches may give idea on what's going on in the switches. 
 
1. show openflow
2. show openflow flows
Photo of Ankit Agrawal

Ankit Agrawal

  • 100 Points 100 badge 2x thumb
The output of these commands looks okay.

Switch one
-----------------
X440-8p.1 # show openflow
OpenFlow: Enabled
Versions: OpenFlow10, OpenFlow13
Mode: Standard
FDB: Off
Access-list width: Single

Controller : Primary
Status : ACTIVE
Datapath ID : 000000049697c679
VR : VR-Mgmt
Mode : out-of-band Active
Target : tcp:10.10.1.10:6633
Uptime(secs) : 1152

Controller : Secondary
Not configured.

Total number of VLAN(s): 0
X440-8p.2 # show openflow flows
Total number of OpenFlow flows : 0
Total number of default flows : 2

Flow name Type Duration (secs) Prio Packets
---------------- ---- ------------------- ----- --------------------
ofDefault_0 ACL 1326 0 0
Match :
Actions: CONTROLLER
ofDefault_2 ACL 1326 0 0
Match : Ethernet Type : 0x88cc (LLDP)
Actions: CONTROLLER

Packets: (*) Cumulative packet count for all FDB flows
X440-8p.3 #
X440-8p.3 #
X440-8p.3 # show openflow flows
Total number of OpenFlow flows : 0
Total number of default flows : 2

Flow name Type Duration (secs) Prio Packets
---------------- ---- ------------------- ----- --------------------
ofDefault_0 ACL 1365 0 0
Match :
Actions: CONTROLLER
ofDefault_2 ACL 1365 0 0
Match : Ethernet Type : 0x88cc (LLDP)
Actions: CONTROLLER

Packets: (*) Cumulative packet count for all FDB flows

Switch two
--------------
X440-8p.1 # show openflow
OpenFlow: Enabled
Versions: OpenFlow10, OpenFlow13
Mode: Standard
FDB: Off
Access-list width: Single

Controller : Primary
Status : ACTIVE
Datapath ID : 0000000496979b95
VR : VR-Mgmt
Mode : out-of-band Active
Target : tcp:10.10.1.10:6633
Uptime(secs) : 838

Controller : Secondary
Not configured.

Total number of VLAN(s): 0
X440-8p.2 #
X440-8p.2 # show openflow flows
Total number of OpenFlow flows : 0
Total number of default flows : 2

Flow name Type Duration (secs) Prio Packets
---------------- ---- ------------------- ----- --------------------
ofDefault_0 ACL 1314 0 0
Match :
Actions: CONTROLLER
ofDefault_2 ACL 1314 0 0
Match : Ethernet Type : 0x88cc (LLDP)
Actions: CONTROLLER

Packets: (*) Cumulative packet count for all FDB flows
Photo of Masadi, Ravi

Masadi, Ravi, Employee

  • 100 Points 100 badge 2x thumb
Hi Ankit,

From the above show openflow - (Total number of VLAN(s): 0), I could see that you have not enabled OpenFlow on ports/VLANs that connecting the switches that is the reason for not seeing the topology.  Open Flow process processes the packets that ingress on open flow enabled ports only. 

Since EXOS doesn't allow to enable open flow on port directly, you need create a VLAN in all the switches and add the connecting ports and then enable open flow on the VLAN.  Here is an example configuration

create vlan "v11"
configure vlan v11 tag 11
configure vlan v11 add ports 22, 25-26 tagged
enable openflow vlan "v11"

Regards,
Ravi Masadi
Photo of Ankit Agrawal

Ankit Agrawal

  • 100 Points 100 badge 2x thumb
Thanks Ravi!
I see the topology as expected on the controller now.
Photo of Srinivasan, Satishkumar

Srinivasan, Satishkumar, Employee

  • 80 Points 75 badge 2x thumb
Ankit

Can you try enabling the following on the switch

configure openflow default-rule lldp controller
configure openflow default-rule miss controller

controller uses  OF packet_in and packet_out messages to figure out the topolology. If the default action is set to drop on the switch the LLDP packets might get dropped and will never be sent to controller.


Regards
Sathish
Photo of Ankit Agrawal

Ankit Agrawal

  • 100 Points 100 badge 2x thumb
The config is already present on the switches. I think I'm missing something else.

X440-8p.5 # show configuration "openflow"
#
# Module openflow configuration.
#
configure openflow default-rule lldp controller
configure openflow default-rule miss controller
enable openflow
configure openflow controller primary out-of-band active ipaddress 10.10.1.10 vr VR-Mgmt