Cant config snmp v2c on x670 ExtremeXOS version 16.1.3.6 16.1.3.6-patch1-2

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
cant get any info from snmpd:
09/22/2016 23:01:27.21 <Warn:SNMP.Master.AuthFail> Login failed through SNMPv1/v2c - bad community name (192.168.6.252)09/22/2016 23:01:27.04 <Warn:SNMP.Master.AuthFail> Previous message repeated 2 additional times in the last 1 second(s)

snmp config is 

configure snmpv3 delete user "admin" engine-id 80:00:07:7c:03:02:04:96:8f:c3:e2
configure snmpv3 delete user "initial" engine-id 80:00:07:7c:03:02:04:96:8f:c3:e2
configure snmpv3 delete user "initialmd5" engine-id 80:00:07:7c:03:02:04:96:8f:c3:e2
configure snmpv3 delete user "initialsha" engine-id 80:00:07:7c:03:02:04:96:8f:c3:e2
configure snmpv3 delete user "initialmd5Priv" engine-id 80:00:07:7c:03:02:04:96:8f:c3:e2
configure snmpv3 delete user "initialshaPriv" engine-id 80:00:07:7c:03:02:04:96:8f:c3:e2
configure snmpv3 delete community "private"
configure snmpv3 delete community "public"
configure snmpv3 add community "123456789" name "123456789" user "v1v2c_ro" 
disable snmpv3 default-group

Slot-1 kernel.29 # show snmpv3 community 
Community Index  : 123456789
Community Name   : 123456789
Security Name    : v1v2c_ro
Context EngineID : 80:00:07:7c:03:02:04:96:8f:c3:e2
Context Name     : 
Transport Tag    : 
Storage Type     : NonVolatile
Row Status       : Active

Total num. of entries in snmpCommunityTable : 1

in hub I see
https://gtacknowledge.extremenetworks.com/articles/Solution/SNMP-Not-Working-on-Switch-Stack

configure snmpv3 add access v1v2c_ro sec-model snmpv2c sec-level noauth read-view defaultUserView notify-view defaultNotifyView
configure snmpv3 add mib-view defaultUserView subtree 1 type included
it says - that it exist...

roman@jusi:~$ snmpwalk -v2c -c 123456789 192.168.6.45
Timeout: No Response from 192.168.6.45
roman@jusi:~$ ping 192.168.6.45PING 192.168.6.45 (192.168.6.45) 56(84) bytes of data.
64 bytes from 192.168.6.45: icmp_seq=1 ttl=63 time=0.674 ms


What I done wrong?

romanse@serdi.ru
Photo of Roman Solovyov

Roman Solovyov

  • 200 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Kawawa

Kawawa, GTAC

  • 3,292 Points 3k badge 2x thumb
v1v2c_ro is a default group, therefore using the command disable snmpv3 default-group disables it.

disable snmpv3 default-group
# show snmpv3 group
Group Name      : v1v2c_ro
Security Name   : v1v2c_ro
Security Model  : snmpv1
Storage Type    : NonVolatile
Row Status      : NotInService
Group Name      : v1v2c_ro
Security Name   : v1v2c_ro
Security Model  : snmpv2c
Storage Type    : NonVolatile
Row Status      : NotInService
Either you create a new group that you can associate with your newly created community,
configure snmpv3 add user 123456789
configure snmpv3 add group 123456789 user 123456789 sec-model snmpv2c
# show snmpv3 group
Group Name      : 123456789
Security Name   : 123456789
Security Model  : snmpv2c
Storage Type    : NonVolatile
Row Status      : Active
OR you enable the default groups
enable snmpv3 default-group
# show snmpv3 group
Group Name      : v1v2c_ro
Security Name   : v1v2c_ro
Security Model  : snmpv1
Storage Type    : NonVolatile
Row Status      : Active
Group Name      : v1v2c_ro
Security Name   : v1v2c_ro
Security Model  : snmpv2c
Storage Type    : NonVolatile
Row Status      : Active
Hope this helps,
(Edited)
Photo of Roman Solovyov

Roman Solovyov

  • 200 Points 100 badge 2x thumb
Thanks a lot! Now everything is ok!