Can't ping my subnet under another switch

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)

Hello i have two switch one x440 other x460 and cant ping hosts under another switch with diffret subnet. How to configure switches to make communication possible? Or do i need to make static routing?



 SW1 Config
Bud_1-X460.44 # show config
#
# Module devmgr configuration.
#
configure snmp sysName "Bud_1-X460"
configure timezone 60 autodst begins every last sunday march at 2 0 ends every last sunday october at 3 0
configure sys-recovery-level switch reset

#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-30
configure vr VR-Default add ports 1-30
configure vlan default delete ports 1-30
create vlan "managment2"
configure vlan managment2 tag 100
create vlan "v1-KD"
configure vlan v1-KD tag 10
create vlan "v3-CCTV"
configure vlan v3-CCTV tag 30
create vlan "v4-SCADA"
configure vlan v4-SCADA tag 40
configure ports 29 auto off speed 10000 duplex full
configure ports 30 auto off speed 10000 duplex full
configure vlan managment2 add ports 25 tagged
configure vlan managment2 add ports 20 untagged
configure vlan v1-KD add ports 25 tagged
configure vlan v1-KD add ports 1-8 untagged
configure vlan v3-CCTV add ports 25 tagged
configure vlan v3-CCTV add ports 9-16 untagged
configure vlan v4-SCADA add ports 25 tagged
configure vlan v4-SCADA add ports 23-24 untagged
configure vlan Default ipaddress 172.16.98.1 255.255.255.0
configure vlan Mgmt ipaddress 192.168.10.1 255.255.255.0
configure vlan v3-CCTV ipaddress 192.168.3.254 255.255.255.0
configure vlan v4-SCADA ipaddress 10.244.4.254 255.255.255.0

#
# Module acl configuration.
#
configure access-list zone SYSTEM application NetLogin application-priority 3
configure access-list zone SECURITY application GenericXml application-priority 2

#
# Module stp configuration.
#
configure mstp region 00049698927e
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
enable stpd s0 auto-bind vlan Default



SW2 Config

Bud_21-X440.16 # show config
#
# Module devmgr configuration.
#
configure snmp sysName "Bud_21-X440"
configure sys-recovery-level switch reset

#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-24
configure vr VR-Default add ports 1-24
configure vlan default delete ports 1-24
create vlan "managment2"
configure vlan managment2 tag 100
create vlan "v1-KD"
configure vlan v1-KD tag 10
create vlan "v3-CCTV"
configure vlan v3-CCTV tag 30
create vlan "v4-SCADA"
configure vlan v4-SCADA tag 40
configure vlan managment2 add ports 23-24 tagged
configure vlan managment2 add ports 20 untagged
configure vlan v1-KD add ports 23-24 tagged
configure vlan v1-KD add ports 1-4 untagged
configure vlan v3-CCTV add ports 23-24 tagged
configure vlan v3-CCTV add ports 5-16 untagged
configure vlan Mgmt ipaddress 192.168.10.21 255.255.255.0

#
# Module stp configuration.
#
configure mstp region 00049698acd8
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
enable stpd s0 auto-bind vlan Default

Admin edit:  Removed unneeded / blank config sections to shorten post.
Photo of Piotr Jakubczyk

Piotr Jakubczyk

  • 234 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Stephen Williams

Stephen Williams, Employee

  • 9,034 Points 5k badge 2x thumb
From your diagram it looks like your PC's are using a /16 mask and the switch IP's are using a /24 mask.  I would fix that first.  and if you plan to do routing make sure to "enable ipforwarding"
Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
Hi Piotr, I'm guessing the mask in your diagram is /24 (255.255.255.0) instead of /16 (255.255.0.0).

If that's true, then:

PC1 to PC2 works even in different subnets because both PCs are on the same switch and the switch uses just 1 MAC address for all interfaces (except mgmt port)
PC1 to PC4 works because they are on the same subnet (192.168.1.x)
PC1 to PC3 does not work because you they are on different subnets and different switches

You just need to do "enable ipforwarding" on both switches.