Cisco 7945G is not pulling the correct voip-vlan as advertised with CDP

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I know that this is a common question, so don't punch me. I am only asking because there is new firmware since the last time this was brought up.

In the past I have used lldp to advertise the voice VLAN tag to my Cisco devices. That works! But it does seem to result in a ton of additional lines in my configuration.

I noticed that with Summit firmware 21.x and up, I should be able to use CDP, like this ...
configure cdp voip-vlan "DowntownV" ports all
I tried that, but it doesn't seem to work. The only way I can get the phone to pull an IP address from my "DowntownV" VLAN is to go into the phone settings and manually set the VLAN tag on the device.

Also - I noticed if I do a "show config" there is nothing in there about cdp. As if the switch is pretending to apply the command but then ignoring it.
* Slot-1 Stack.4 # sh conf | incl cdp
* Slot-1 Stack.5 #
Am I missing some additional configuration there?

I am running firmware: 21.1.2.14 patch1-2
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,806 Points 5k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Bastian Sprotte

Bastian Sprotte, Employee

  • 1,660 Points 1k badge 2x thumb
hello,
can you post the command output

show cdp
show cdp neighbor

many thanks
Bastian
-
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,806 Points 5k badge 2x thumb
Hello Bastian,

Here is what I am seeing ...
* Slot-1 Stack.6 # show cdp
CDP Transmit time : 60 seconds
CDP Hold time : 180 seconds
CDP Device ID : 02:04:96:9B:E4:86
CDP Enabled ports :
Power Available TLV Enabled ports :

* Slot-1 Stack.7 # show cdp neighbor
(Edited)
Photo of Bastian Sprotte

Bastian Sprotte, Employee

  • 1,660 Points 1k badge 2x thumb
hello,
you need enable cdp per port, you see no ports are enabled.

enable cdp ports all

let see if that help.

Bastian
-
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,806 Points 5k badge 2x thumb
I knew I was missing something.
Yes, that works!  Thank you. Did an 'enable cdp ports all' and rebooted the phone. It is now on the correct VLAN, and 'show cdp neighbor" has something to report now ...

* Slot-1 Stack.14 # show cdp neighborDevice Id            Local        Hold   Capability   Platform       Port Id
                     Interface    Time
--------------------------------------------------------------------------------
SEP00DA55264BA3      3:21         129        H        Cisco IP Phon> Port 1
---------------------------------------------------------------------------------
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater
> indicates that the value was truncated to the column size in the output.
Use the "detail" option to see the complete value.

I am glad to see that this feature got added. Having that "configure voice vlan XXX" was about the only thing I had left to like about my old Cisco switches.  ;-)
(Edited)