Configuration CISCO BGP to EXTREME X460 SWITCH

  • 1
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Can any one help to convert commanad CISCo BGP to X460 SWitch.


CSCIO COMMANDS:

interface Loopback0 ip address 172.17.23.157 255.255.255.255
!
interface GigabitEthernet0/0
 description ******WAN Connection*****
 ip address 172.17.114.157 255.255.255.252
 ip helper-address 10.1.224.3
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description *****LAN Connection***
 ip address 10.1.224.17 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 10.1.223.17 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/3
 ip address 172.17.114.121 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/2/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2/1
 mtu 1600
 bandwidth 2048
 ip address 191.254.225.98 255.255.255.252
 ip helper-address 10.1.224.3
 encapsulation ppp
 no ip route-cache
 no fair-queue
 clock rate 2000000
!
router bgp 54321
 bgp log-neighbor-changes
 network 10.1.223.0 mask 255.255.255.0
 network 10.1.224.0 mask 255.255.255.0
 network 172.17.23.157 mask 255.255.255.255
 neighbor 172.17.114.122 remote-as 9829
 neighbor 172.17.114.122 weight 500
 neighbor 172.17.114.122 route-map LAN out
 neighbor 172.17.114.158 remote-as 9829
 neighbor 172.17.114.158 weight 500
 neighbor 172.17.114.158 route-map LAN out
 neighbor 192.168.5.114 remote-as 18101
 neighbor 192.168.5.114 local-as 65001 no-prepend replace-as
 neighbor 192.168.5.114 ebgp-multihop 5
 neighbor 192.168.5.114 timers 30 90
 neighbor 192.168.5.114 soft-reconfiguration inbound
 neighbor 192.168.5.114 weight 200
 neighbor 192.168.5.114 route-map LAN1 out
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 172.17.114.158
ip route 10.0.9.0 255.255.255.0 192.168.5.114
ip route 192.168.5.0 255.255.255.0 192.168.5.234
ip route 192.168.5.0 255.255.255.0 192.168.5.114
!
ip access-list standard SNMP
 permit 82.196.34.0 0.0.1.255
 permit 82.196.56.0 0.0.0.255
 permit 82.196.54.0 0.0.0.255
 permit 82.196.32.0 0.0.0.255
 permit 130.20.5.0 0.0.0.255
!
logging facility local0
logging source-interface GigabitEthernet0/1
logging 10.0.15.20
access-list 11 permit 172.17.23.157
access-list 11 permit 10.1.224.0 0.0.0.255
access-list 11 permit 10.1.223.0 0.0.0.255
!
route-map LAN permit 10
 match ip address 11
!
route-map LAN1 permit 10
 match ip address 11
 set as-path prepend 65001 65001
!
!
snmp-server community 648kkjrddcbcjjcl RO SNMP
snmp-server ifindex persist
snmp-server trap-source Loopback0
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps config
snmp-server host 82.196.34.162 RQsfdipXwXnIqwW
snmp-server host 82.196.35.226 RQsfdipXwXnIqwW  config
Photo of Raghavendra vemuganty`

Posted 2 years ago

  • 1
  • 1
Photo of Kevin Kim

Kevin Kim, Employee

  • 2,266 Points 2k badge 2x thumb
I don't think ExtremeXOS supports the 'neighbor local-as' command. To remove the need of the local-as, the 'remote-as 65001' configuration on the neighbor '192.168.5.114' router needs to be modified to 'remote-as 54321'.
(Edited)