Configuring different VLANs for Access Points and WLANs

  • 0
  • 2
  • Question
  • Updated 2 months ago
  • Answered
Hi All,

I'm new to Extreme wireless.
Could someone please assist how can we configure the following:

1. APs get the IP Address from Management Subnet.
2. WLANs users get the IP Address from different subnet than the APs.

Thanks.
Photo of MOIN ILYAS

MOIN ILYAS

  • 154 Points 100 badge 2x thumb

Posted 2 months ago

  • 0
  • 2
Photo of Madeline

Madeline, Employee

  • 210 Points 100 badge 2x thumb
Hey Moin,
  1. By default, WiNG AP is configured with DHCP IP for VLAN 1 which is the native VLAN for ge1
  2. For WLAN user to get Ip address from a different subnet, multiple ways can be done:
Hope this helps~!
Photo of MOIN ILYAS

MOIN ILYAS

  • 154 Points 100 badge 2x thumb
Hi Madeline,

Thanks for your reply.
When you say WiNG AP is configured with DHCP IP for VLAN 1 which is the native VLAN for ge1.
It is the case when the switchport has no config on it? Correct me if I'm wrong?

If we want APs to get IP address from a different VLAN, say VLAN10 and WLAN users on VLAN20. Do we need to configure the switchport as a trunk port with native VLAN as VLAN10?
Photo of Madeline

Madeline, Employee

  • 210 Points 100 badge 2x thumb
1. When you say WiNG AP is configured with DHCP IP for VLAN 1 which is the native VLAN for ge1.
It is the case when the switchport has no config on it? Correct me if I'm wrong?
>> I'll assume that you are referring to AP int ge configuration, and the default behaviour is as below:
interface ge1
switchport mode access
  switchport access vlan 1
interface vlan1
  ip address dhcp
  ip address zeroconf secondary
  ip dhcp client request options all


2.If we want APs to get IP address from a different VLAN, say VLAN10 and WLAN users on VLAN20. Do we need to configure the switchport as a trunk port with native VLAN as VLAN10?
>> Yes, on top of that you will need to configured AP interface ge1 to allow VLAN 10 and VLAN 20
For example:
 interface ge1
  switchport mode trunk
  switchport trunk native vlan 10
  no switchport trunk native tagged
  switchport trunk allowed vlan 10,20
Photo of MOIN ILYAS

MOIN ILYAS

  • 154 Points 100 badge 2x thumb
Hi Madeline,

Thanks for the detailed response. I didn't know if we could configure the AP int Ge interface with switchport commands.

In my case I'd have to configure the following:

AP Ge Interface:
 switchport mode trunk
  switchport trunk native vlan 10
  no switchport trunk native tagged
  switchport trunk allowed vlan 10,20

interface vlan 10
  ip address dhcp
  ip address zeroconf secondary
  ip dhcp client request options all


Switchport Config (Where AP is connected)

interface gi1/0/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20

The Switch Config:

interface vlan 10
ip address 192.168.10.1 255.255.255.0
ip helper-address <IP Address of DHCP Server>


interface vlan 20
ip address 192.168.20.1 255.255.255.0
ip helper-address <IP Address of DHCP Server>


Does it make any sense?
Photo of Madeline

Madeline, Employee

  • 210 Points 100 badge 2x thumb
Dear Moin,

I am not sure about the switch that you are using, but from the WiNG AP side, the configuration looks correct
You can do a show IP interface brief on the AP to check the IP address that it is taking

Hope this helps
Photo of MOIN ILYAS

MOIN ILYAS

  • 154 Points 100 badge 2x thumb
Assuming we have Cisco Switches.
Does the config look good?

Thanks.
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 44,150 Points 20k badge 2x thumb
We are sorry to hear that :-)

It looks OK
just as a reminder.... you'd need a "no shut" on the VLAN interfaces