DCB configuration with Equallogic devices

  • 0
  • 1
  • Problem
  • Updated 3 years ago
Getting DCB errors with equallogic devices.  I have a 6210, 6100, 6500, and 4100 equallogic units.  All the ports say DCB is off except for the 6210 they say its on but I show baseline control errors for those interfaces.  The others just state unknown for baseline.
================================================================================         Baseline DCBX TLV Status:           IEEE DCBX TLV Status:
Port     Control  PG       PFC      App      ETS-Conf ETS-Rec  PFC      App
================================================================================
1:7      ERROR    OK       OK       OK       OK       UNKNOWN  OK       OK
1:9      ERROR    OK       OK       OK       OK       UNKNOWN  OK       OK
1:10     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:11     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:12     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:13     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:14     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:16     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:17     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:19     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:21     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:23     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:26     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:28     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:30     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
1:32     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:1      OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:7      OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:10     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:11     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:12     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:14     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:15     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:16     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:26     OK       OK       OK       UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:28     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:29     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
2:31     UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN  UNKNOWN
================================================================================

This is the config on all the ports, this port is on the 6210 that seems to be working some what but has errors
* Slot-1 10 Gig Core A.1 # sh config | include 1:7
enable jumbo-frame ports 1:7
enable flow-control rx-pause qosprofile qp4 port 1:7
enable flow-control tx-pause priority 4 port 1:7
configure vlan iSCSI add ports 1:7, 1:9-17, 1:19, 1:21, 1:23, 1:25-26, 1:28-32, 2:1, 2:7, 2:9-16, 2:25-26, 2:28-32 untagged
configure qosprofile QP1 minbw 0 maxbw 90 ports 1:7
configure qosprofile QP2 minbw 0 maxbw 90 ports 1:7
configure qosprofile QP4 minbw 0 maxbw 90 ports 1:7
configure qosprofile QP5 minbw 5 maxbw 95 ports 1:7
configure qosprofile QP6 minbw 5 maxbw 95 ports 1:7
enable lldp ports 1:7
configure lldp port 1:7 advertise vendor-specific dcbx ieee
configure lldp port 1:7 advertise vendor-specific dcbx baseline
configure lldp ports 1:7 dcbx add application name iscsi priority 4

I have read the documentation from both equallogic and extreme and both are really rather vague.  Its like both just expect it to work no real troubleshooting documentation on either end.  I have also checked the best practice guide from Equallogic on configuring DCB as well.  

Any help would be appreciated, thx.
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
I forgot to mention the switch model sorry
* Slot-1 10 Gig Core A.3 # sh switch
SysName:          10 Gig Core A
SysLocation:
SysContact:
System MAC:       02:04:96:97:F0:24
System Type:      X670V-48t (Stack)

SysHealth check:  Enabled (Normal)
Recovery Mode:    All
System Watchdog:  Enabled

Current Time:     Fri Apr 10 01:02:35 2015
Timezone:         [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time:        Sun Mar 22 04:18:09 2015
Boot Count:       32
Next Reboot:      None scheduled
System UpTime:    18 days 20 hours 44 minutes 26 seconds

Slot:             Slot-1 *                     Slot-2
                  ------------------------     ------------------------
Current State:    MASTER                       BACKUP (In Sync)

Image Selected:   secondary                    secondary
Image Booted:     secondary                    secondary
Primary ver:      15.2.2.7                     15.2.2.7
Secondary ver:    15.3.3.5                     15.3.3.5

Config Selected:  primary.cfg
Config Booted:    Factory Default

primary.cfg       Created by ExtremeXOS version 15.3.3.5
                  1314090 bytes saved on Fri Apr 10 00:02:23 2015
(Edited)