DHCP server not working correctly on Summit X440 switch

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved

I had an issue the other day on not being able to have our Avaya 9608 phones reach the call server and get an IP address. I fixed that by re-configuring a new summit switch from scratch my way. I isolated the switch, the call server and one phone. It was a success!

Now when adding a data dhcp server for our PC's into the lineup. Located on port 3 of the switch untagged just for the data vlan. The phones get stuck at LLDP on boot. But LLDP is configured perfectly... to my knowledge. I plugged my laptop into the switch and got an IP address from the data dhcp server perfectly. But the phones won't work with the data dhcp server hooked up to the switch (when the call server is hooked up as well). Well they will work with static addresses but who wants to manually enter all that in.

Of course I can separate the switches and have one dedicated for voice call server and one for data dhcp server and everything will be fine, but I wouldn't like to do that. Any good troubleshooters out there no why this is???
Photo of Payton Burdette

Payton Burdette

  • 140 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,714 Points 10k badge 2x thumb
Hello Payton,

Can you provide us with your lldp configuration on one of the ports. Also are the ports configured with the voice VLAN as tagged and data VLAN as untagged. I am assuming so but wanted to make sure. Can you see the phone in the correct VLAN in the FDB table?
Photo of Payton Burdette

Payton Burdette

  • 140 Points 100 badge 2x thumb
What mainly confuses me is how lldp can work fine with the call server is just in the switch, but when the data dhcp is added the phones do not work?

Yes, for example if a device or phone is going to hook up to port 17 on the switch. Port 17 would be untagged for the data vlan and tagged for the voice vlan. 

LLDP config for a port.

enable lldp ports 1
configure lldp port 1 advertise system-capabilities
configure lldp port 1 advertise vendor-specific avaya-extreme call-server 192.168.42.3
configure lldp port 1 advertise vendor-specific avaya-extreme dot1q-framing tagged
configure lldp port 1 advertise vendor-specific med capabilities
configure lldp port 1 advertise vendor-specific dot1 vlan-name vlan voiceconfigure lldp port 1 advertise vendor-specific med policy application voice vlan voice dscp 46
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
The following mandatory TLVs are not configured by default in EXOS:
  • LLDP-MED Capabilities
  • LLDP-MED Network Policy
  • LLDP-MED Extended Power-Via-MDI TLV
Use the following commands to configure them and allow the switch to communicate with the phone via LLDP:
  • enable lldp ports <port number>
  • configure lldp port <port number> advertise vendor-specific med capabilities
  • configure lldp port <port number> advertise vendor-specific dot1 vlan-name vlan <VOIP vlan>
  • configure lldp port <port number> advertise vendor-specific med power-via-mdi
  • configure lldp port <port number> advertise vendor-specific med policy application voice vlan <VOIP vlan> dscp 46
  • Configure lldp port <port number> advertise system-capabilities
  • Configure lldp port <port number> advertise vendor-specific dot1 port-protocol-vlan-id vlan <VOIP vlan>
Above command would definitely resolve your issue.