Dot1p configuration

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I am totally new to extreme.

I am configuring Qos based on dot1p. I configured the dot1p and QP mapping. But the switch cannot detect any CoS 802.1  value at all . all traffic go to qp1.  is there anything I have to do other than maping this cos to qp

X440-48p-10G.420 # sho dot1p   802.1p Priority Value     QOS Profile
           0                QP1
           1                QP2
           2                QP3
           3                QP4
           4                QP5
           5                QP6
           6                QP7
           7                QP8


But when I configure port based Qos everything is going fine
Below example for traffic from port configured as QP6



Port   QP1      QP2      QP3      QP4      QP5      QP6      QP7      QP8       Pkt      Pkt      Pkt      Pkt      Pkt      Pkt      Pkt      Pkt
       Xmts     Xmts     Xmts     Xmts     Xmts     Xmts     Xmts     Xmts
===============================================================================
2      1178     0        0        0        0        336      0        0


even if I make all 802.1p mapped to qp5 the switch cannot see anything
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
Husam, 

There are a couple different ways of configuration as you have found.  Are the ports that you have configured tagged or untagged?  Only tagged ports are configured to support .1p - If you are using untagged ports the easiest way to configure the vlan that was is to shave the whole vlan.. "configure vlan <name> qosprofile <qp?> - This will take all packets per that vlan to the Qosprofile <qp?> - 

Let me know if the ports are tagged..??


Bill
Photo of simon bingham

simon bingham

  • 1,228 Points 1k badge 2x thumb
I agree completely with Bill if your not tagging the 802.1p will not work anyway, there are a lot of ways to implement QoS, vlan based is probably the easiest to implement,

for example
configure vlan "voice" qosprofile qp6

 I try to use DSCP where possible as phones usually mark the DSCP. from experimentation I found If compeating QoS Mechanisms are configured  the Pecking order is

 

Access List QoS

802.1p

VLAN Based Assignment

DSCP

 

Testing completed 22nd May 2014

 

My other discovery was that even with ALL methods disabled the switch then honours 802.1p markings.



 
Photo of Husam

Husam

  • 1,272 Points 1k badge 2x thumb
Thank you all,

You are write I was not tagging the ports. anyway it seemed more complicated as the voice packet of REDcom the PBX my client use, doesn't support dot1p.

So I've did a different setup based on your advice. I configured the whole vlan or the ports as qp7 and the ports with dot1p replacement and then in core switch I did the dot1p examination on tagged port (as you advised).

Now it is working fine and can control the traffic throughout the link based on its dot1p value. am I right?

regards
Husam