Eaps blocks both primary and secondary port for only one protected vlan

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)

I noticed on one of our core switches (X480-24x(10G4X)) - which is eaps master for the given ring - that it had blocked one vlan wrongly. Eaps status is Ok, and shows that secondary port is correctly blocking while primary port is open and forwarding. 

What makes this interesting is that the eaps ring has some tens of protected vlans and this particular vlan is the only one blocked wrongly having its both primary and secondary port blocked. The remaining protected vlans work like charm. And this problematic vlan isn't a member of any other eaps ring.

From the logs, only eaps-related information I can see is the following:

May 11 12:06:09 sw1 System: Starting VLAN protection via EAPS on Switch
May 11 12:06:10 sw1 System: Finished VLAN protection via EAPS on Switch

May 12 07:46:06 sw1 System: START-MIX-PROTECTED-VLAN-DELETE on Switch
May 12 07:46:07 sw1 System: FINISH-MIX-PROTECTED-VLAN-DELETE on Switch

Could these perhaps relate to eaps problem I'm facing?

Current xos version on all eaps ring switches is 15.3.2.11 patch1-2, which should be pretty new.

Anyone else have had the similar kind of problem?

Photo of Mikko Ketola

Mikko Ketola

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
It's interesting to see this problem as there should be two port block on single protected vlan. You can provide the below information to see the issue

1)Network topology
2)show configuration eaps (from all the switch)
3) show eaps (from all the switch)
4) show vlan <vlan_name>  //problematic vlan name (from all the switch)
5) show eaps <domain_name> (from all the switch)
6) show eaps counter <domain name> (from all the switch)

Or else it's better to open TAC case for quick resolution.

 I would never recommend the EXOS 15.3.2 to any of my customer. 

Photo of Mikko Ketola

Mikko Ketola

  • 90 Points 75 badge 2x thumb

Unfortunately the problem isn't on anymore, so providing the asked information wouldn't maybe give relevant information? I fixed the problem by deleting problematic vlan from eaps primary port and adding it again. The problem, according to our observations, take place when one of the switches participating in the ring reboots suddenly. Once the problem occurred by adjusting one switch's time.

Why wouldn't you recommend EXOS 15.3.2? What would be the recommended "stable" version?

Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
I have seen multiple issues on EXOS 15.3.2 software. 


(Edited)
Photo of Mikko Ketola

Mikko Ketola

  • 90 Points 75 badge 2x thumb

Perhaps then software upgrade should be scheduled to some newer version. Any explanations for the log messages posted above? Could not find any references from the documentation and would be interesting to know.

Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
May 12 07:46:06 sw1 System: START-MIX-PROTECTED-VLAN-DELETE on Switch
May 12 07:46:07 sw1 System: FINISH-MIX-PROTECTED-VLAN-DELETE on Switch

The above error message appears when trying to delete the protected VLAN in the EAPS ring without deleting the VLAN from the EAPS ring port.