ELRP disabling ports on ExtremeWare

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
So in getting  ready to configure company wide ELRP I was doing to some testing the other day.
The test case is a  Summit200-24 running Image : Extremeware  Version 7.8e.4.1

Issue is when ELRP detected a loop it disables the port.  FIrst I didnt think Xware supported this feature...............  In the example below I removed all ELRP instances, :

/01/2015 10:26:32.97 <Info:SYST> 10.227.28.8 epicenter: configure elrp-client periodic Legacy interval 1 ports 1 , 2 , 25 log-and-trap
5/01/2015 10:26:24.20 <Info:SYST> 10.227.28.8 epicenter: unconfigure elrp-client Legacy
Result is this:
05/01/2015 10:07:43.42 <Info:SYST> 10.227.28.8 epicenter: disable ports 1
05/01/2015 10:07:42.24 <Erro:SYST> Loop detected on port 1. Disabling port.
05/01/2015 10:07:42.24 <Erro:SYST> Loop detected on port 2. Disabling port.
05/01/2015 10:07:42.23 <Crit:ELRP-C> Loop Detected on VLAN Legacy port sent 2 port received 1
05/01/2015 10:07:42.22 <Crit:ELRP-C> Loop Detected on VLAN Legacy port sent 1 port received 2
05/01/2015 10:07:41.07 <Info:SYST> Port 2 link active 100Mbs FULL duplex
05/01/2015 10:07:41.06 <Info:SYST> Port 1 link active 100Mbs FULL duplex
05/01/2015 10:07:39.16 <Info:SYST> 10.227.28.8 epicenter: enable ports 1
05/01/2015 10:07:03.89 <Info:SYST> 10.227.28.8 epicenter: disable ports 1
05/01/2015 10:05:00.55 <Info:SYST> Port 2 link down

I had a cable run between ports 1 and 2. Nowhere did we ever say to disable the port.. Notice that legacy just has log and  trap, no mention of disabling the port, ....so why does the port get disabled?  I also looked at sh conf detail, but nothing stood out

ty
Photo of Jimmy Sands

Jimmy Sands

  • 432 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hello Jimmy

Unfortunately I don't have anything that is running EW that I can test but can you do a show port info and show port config on the two ports.  I see EPICenter is in play is there a script set in EPICenter to disable the ports?

Thanks
P