ELRP

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Create Date: Nov 22 2012 11:51AM

Hi all,

I'd to enable ELRP to place user access switchports into blocking mode following detection of a loop rather than just logging it (as is currently configured.) I took a look at the video describing configuring ELRP but I think the software version on the switch in question might be missing something. If try show ELRP I see the following with no other command options such as the blocked-ports option.

# show elrp ?
  <cr>            Execute the command

Running the command gives the following output :

# show elrp


ELRP Standalone Client:       Enabled


Number of ELRP sessions:          1
Number of ELRP pkts transmitted:  10154816
Number of ELRP pkts received:     0


Client  Vlan        Ports  Int.    Count Cyclic Pkts-Xmit Pkts-Rcvd Action
--------------------------------------------------------------------------
CLI     VOICE        1:1-47, 2:1-47, 3:1-48 1        0     Yes    10154816  0         LT
--------------------------------------------------------------------------
Action : (P) Print , (L) Log , (T) Trap , (C) Callback

There doesn't appear to be a block option shown? Or does this option only appear after it has been enabled?

I'd like to get to the bottom of this before I actually attempt to configure the blocking.

The software version is ExtremeXOS version 12.1.3.14 v1213b14-patch1-4

Many thanks

Dominic


(from craig_nichol)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Nov 23 2012 4:17PM

The command to enable port blocking would go like this:

configure elrp-client periodic VOICE ports all log disable-port duration 30

This runs ELRP on all ports, logs loops, and disables the port(s) involved for 30 seconds before unblocking and rechecking the port. Depending on your policy you may wish to disable the port permanently, which requires the administrator to manually reenable the port via CLI after the loop is disconnected. I am not aware of any issues in the EXOS version you list, but I have no real experience with it either, as it's very out of date. If possible, I would recommend you upgrade to a newer version. The more recent versions add a "disable-ports" configuration option, where you can exclude uplink ports and/or EAPS ring ports from disablement via ELRP, which simplifies the configuration quite a bit. In my environment, for example, I run ELRP on all ports in every client-facing VLAN, but use this option to keep EAPS ring ports from getting blocked in the event of a larger network problem. This way, we can just configure ELRP on "all" ports, rather than having to snip out selective ranges.

EDIT: fixed poor formatting.

(from Ansley_Barnes)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Nov 26 2012 9:27PM

This functionality is available on 12.5 onwards. The version you are running would require a UPM profile to achieve the goal. 

(from Arpit_Bhatt)
Photo of EtherNation User

EtherNation User, Official Rep

  • 20,340 Points 20k badge 2x thumb
Create Date: Nov 29 2012 10:14AM

Thanks to both for the response. I'll take a look at getting 12.5 installed onto a test switch and try out the config.

Regards

Dominic

(from craig_nichol)