EMC 8.0.3 syslog received in /var/log/syslog file, but now shown in OneView or console

  • 0
  • 2
  • Problem
  • Updated 1 year ago
  • Solved
Hi, I've got in my demokit environment a strange problem.
My EMC for some time has worked well as syslog server, but not despite the fact that I see the syslog messages correctly received in the /var/log/syslog file

in the Oneview page or in console, these messages are not shown.
If I made a tcpdump on EMC interface where receive the syslog messages, I see these message:

and with netstat -na I see the port 514 correctly open and the syslog process is running.
I've also tried to made a backup of the EMC server and to install a new one and restore the previous configurations, but the problem still remain.
How I can debug this problem more in deep for resolve it?
Thanks
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,216 Points 2k badge 2x thumb

Posted 1 year ago

  • 0
  • 2
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
Did you add syslog to the event viewer ?
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,216 Points 2k badge 2x thumb
Yes, of course in the event viewer I've select to see the syslog messages.

But also in the console view I don't see nothing.
Photo of Bharathiraja, Suresh

Bharathiraja, Suresh, Employee

  • 3,536 Points 3k badge 2x thumb
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,216 Points 2k badge 2x thumb
Hi Bharathiraja,
I've found the problem was infact due to an error setting in the syslog alarm manager where the path were set to /var/log/messages instead to /var/log/syslog

Now with tis change I'm again able to receive and see in OneView the syslog messages:


The strange is why tis path is changed for some reason (for several time the syslog has worked without problem).