EMC maps wireless coverage

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
Hello,

I've setup an EMC lab for testing NMS advanced features, specifically the maps wireless coverage.

I've added the controller to EMC, enabled location services under the radar configuration on the controller and on the AP's themselves.  I created a Map structure and imported some ekahau surveys, which displays fine and links the AP's to the map (cool!), however when I go to "View>wireless coverage>show coverage", i'm not presented with a heat map.  I also noticed that when i go to "View>wireless coverage>access points" there is an option to select all, however there aren't any ap's listed.  I must be missing a configuration step.  Any ideas?

These are 3935i AP's running 10.11.05 and EMC 7.0.6.   

Thanks much.
Photo of Joshua Puusep

Joshua Puusep

  • 2,254 Points 2k badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 44,984 Points 20k badge 2x thumb
Could you post a screenshot so we'd take a look.
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 44,984 Points 20k badge 2x thumb
"View>wireless coverage>access points" there is an option to select all, however there aren't any ap's listed."

Sounds like that the APs are not added to the map.

Edit the map (screenshot below) and then in the same pull-down select > Add > APs and select the ones that are on that you'd like to place on this map,

They are places in the middle so drag and drop the icon to the exact location.
Last step is to save the map - select > save in the menu.

Photo of Joshua Puusep

Joshua Puusep

  • 2,254 Points 2k badge 2x thumb
It looks like they were auto added to he map from the ekahau file.  I noticed yours are green, however mine are grey.  If i click on them, i can also see the EMC data.
Photo of Joshua Puusep

Joshua Puusep

  • 2,254 Points 2k badge 2x thumb
This is what the map view looks like with wireless coverage enabled and the AP selection drop down.

Photo of Joshua Puusep

Joshua Puusep

  • 2,254 Points 2k badge 2x thumb
Okay, so it looks like i have to manually add them, as Ron mentioned, in order to see the heat maps.  It's a bit odd, because when i do that, it just creates a duplicate of the AP that is already on the map.   The icon for the manually added one is green rather than grey, however the are both linked to the same data in EMC....  So not sure why the ones imported from ekahau don't work for coverage.
Photo of Steve Ballantyne

Steve Ballantyne

  • 5,566 Points 5k badge 2x thumb
Hey Joshua,

After importing your map from Ekahau, did you ever "swap out" the AP serial numbers with *real* AP's? You will have to right click each one of those.

Click File > Edit (you should see a grid background now)
Right-click an AP and choose "Edit AP serial number".

You should get a nice drop-down list that includes the names and serial numbers of any AP's that are not yet placed on a map. If you only see serial numbers and not any names, you should upgrade Netsight as this was fixed in later versions.

*EDIT* Also after doing this, you usually have to right click the AP and Refresh/Rediscover. And still sometimes I have to leave the map and come back to it before wireless coverage shows up.
(Edited)
Photo of Joshua Puusep

Joshua Puusep

  • 2,254 Points 2k badge 2x thumb
Thanks Steve.  This has the same results as manually adding the AP's, with the added benefit of not having to move them to the correct location on the map :-).

The AP's that were imported from ekahau actually already have the correct serial number when i click on them and go to more detail.  These were surveyed AP's rather than simulated AP's.  So when you import the ekahau file, i assume netsight links data to the surveyed AP's via MAC address.

Since it's already linked, i would think nothing else would need to be done, but i guess that is not the case currently.  Thanks again.