Enable ssh2 or telnet on XOS without using the console port

  • 0
  • 1
  • Question
  • Updated 4 months ago
  • Answered
Hello, at all!
I have made a mistake by disabling ssh2 and telnet on an X460G2 (fw 22.4.1.4). And now i can't manage the switch per remote. Is there a possibility by enabling ssh2 or telnet on this switch without driving to the system and using the console port?
Thanks for your interesting!
Photo of Carsten Volmer

Carsten Volmer

  • 274 Points 250 badge 2x thumb

Posted 4 months ago

  • 0
  • 1
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,574 Points 10k badge 2x thumb
Hello Carsen,

I apologize. I think your only option is to console in to make the configuration change.
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 47,434 Points 20k badge 2x thumb
is web still enabled ?
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 47,434 Points 20k badge 2x thumb
did you save the config > if not could someone onsite just unplug/plug the power cable
Photo of Dave Hammers

Dave Hammers, Dir SW Engineering

  • 3,502 Points 3k badge 2x thumb
Is the web interface still working? You could try that.

If you have a python environment on your server, you could try using the jsonrpc_client.py  
https://github.com/extremenetworks/EXOS_Apps/tree/master/JSONRPC
Photo of Necheporenko, Nikolay

Necheporenko, Nikolay, Employee

  • 1,450 Points 1k badge 2x thumb
If snmp rw community is configured you may try to do reboot remotely - https://gtacknowledge.extremenetworks.com/articles/How_To/Setting-the-Next-Reboot-time-via-SNMP-with...
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 47,182 Points 20k badge 2x thumb
Is it possible to just set ssh to enable via SNMP or is there no such MIB object ?
Photo of Carsten Volmer

Carsten Volmer

  • 274 Points 250 badge 2x thumb
The web interface isn't working  either ..
Photo of Rod Robertson

Rod Robertson

  • 2,344 Points 2k badge 2x thumb

How about using the password recovery solution. .XSF file.

Don't know if I  am allowed to copy and paste it here , Im sure there will be a GTAC document , just replace create account admin test test with Enable Telnet.

Basically autoexec.xsf should load before the configuration.