EXOS IP-SECURITY

  • 0
  • 1
  • Problem
  • Updated 4 years ago
Hello,

a question to Extreme guys, any chance to fix the problem described bellow ?

By default ARP learning is enabled with:
enable ip-security arp learning learn-from-arp vlan lan1 ports 1

If I disable learn-from-arp and enable only learn-from-dhcp:
disable ip-security arp learning learn-from-arp vlan lan1 ports 1
enable ip-security arp learning learn-from-dhcp vlan lan1 ports 1

The config in runing switch shows that:
disable ip-security arp learning learn-from-arp vlan lan1 ports 1
enable ip-security arp learning learn-from-dhcp vlan lan1 ports 1

but if I save the config and reboot the switch I have both enabled:
enable ip-security arp learning learn-from-arp vlan lan1 ports 1
enable ip-security arp learning learn-from-dhcp vlan lan1 ports 1


I've checked the xml config and I see inside:
<arpLearning><learnFromArp>0</learnFromArp><learnFrom><![CDATA[DHCP]]></learnFrom><port>1</port><vlan><![CDATA[lan1]]></vlan><learnFromDhcp>1</learnFromDhcp></arpLearning>

It seems that the xml parser ignores "<learnFromArp>0</learnFromArp>".


Regards
--
Jarek
Photo of Jarek

Jarek

  • 2,398 Points 2k badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,382 Points 4k badge 2x thumb
Its looks to me a bug.
could you raise it to TAC
Photo of Jarek

Jarek

  • 2,398 Points 2k badge 2x thumb
I can't do it via e-support portal, but I will write to our partner.

--
Jarek