EXOS VM absorbing ERPS packets causing other switch to stay in Pending ERPS state

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
After a lot of unsuccessful tries to build a VM lab with 5 switches in EAPS ring and other 2 in a ERPS subring of the main ring, I started to capture packets in VirtualBox and found out that the switches are absorbing the R-APS packets instead of forwarding them into the control VLAN. Is that expected behaviour?
That is causing one of the interconnected nodes (the one away from the RPL) to remain in Pending state because it never receives R-APS packets from the root. 

The EAPS ring, starting with the master, is: S5 - S3 - S2 - S4 - S1 - S5.
The ERPS subring is S1-S7-S6-S3, being S7 the RPL master and S6 the neighbor.
S1 and S6 both receive packets from S7, and remain in Idle state, but S3 does not.
The ERPS control vlan is configured and protected in the EAPS ring. ERPS config in the interconnected nodes are correctly tied to EAPS ring (otherwise it wouldn't even allow me to enable it because they have only one ring port).

The only 2 differences from every other lab here in Hub and in Extreme Docs are:
- All of them uses CFM. I'm using ELSM to monitor links. Shouldn't be a issue according to the docs because CFM is used only to monitor link state and is optional.
- All of them have small rings/subrings, so they never have a switch 2 nodes away from the RPL master.

I have tried with VM 16.2 and 22.1 with the same result.

Any thoughts?
Photo of Luis Coelho

Luis Coelho

  • 122 Points 100 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of OscarK

OscarK, ESE

  • 7,702 Points 5k badge 2x thumb
Are you sure the vSwitch is forwarding the packets to EXOS ?
Photo of Luis Coelho

Luis Coelho

  • 122 Points 100 badge 2x thumb
well both ELSM and EDP are untagged, but I've also  tested a ping with the protected client vlan which is tagged.
Photo of OscarK

OscarK, ESE

  • 7,702 Points 5k badge 2x thumb
That is no proof, vSwitch can pass some packets and drop others as they use special destination MAC. ERPS packets are special, you need to check if these really arrive at the EXOS switch, Compare the tx packets on the attached switch with rx packets and you should have no difference. If there is a difference your vswitch is dropping some packets. 
You have your vSwitch configured for all vlans I hope ?
In VMWare you need to enable accept Forged Transmits, Mac address changes and Promiscuous mode (last one maybe not needed but just in case).
Photo of Luis Coelho

Luis Coelho

  • 122 Points 100 badge 2x thumb
I dont think this is configurable in VirtualBox, I'm not using VMWare. Anyway, neighbor switches are receiving ERPS packets because they go into Idle state. I also see this packets in wireshark when I capture them.  But I don't see any packet coming out of other switches than the RPL master.
Photo of Stephen Williams

Stephen Williams, Employee

  • 8,838 Points 5k badge 2x thumb
This is a current bug in EXOS-VM.  You can see in our ERPS GNS3 project we noted this issue.  https://github.com/extremenetworks/Virtual_EXOS/blob/master/gns3_projects/erps_subring/README.md
Photo of Luis Coelho

Luis Coelho

  • 122 Points 100 badge 2x thumb
Thanks for the information. I'll have to build the lab with real switches...
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,086 Points 10k badge 2x thumb
Hi Luis,

As Stephen mentioned, this is a bug in EXOS VM. This only affects the R-APS packets, but it will prevent any ERPS rings with >3 nodes from functioning with EXOS VM.

This is documented in the ERPS project on the EXOS VM GitHub page:
https://github.com/extremenetworks/Virtual_EXOS/blob/master/gns3_projects/erps_subring/README.md

-Brandon
(Edited)