extreme switch connected to cisco switch and losing packet

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)

Hi All



 

Can someone help me, I have 2 ExtremeXOS  440 switches  version 21.1.1.4 connected to cisco switch 6500.

Problem : when I’ doing continues ping I’m getting packet loss and when one switch responding to my pings another will not respond vice vasa .

 

This is my configuration on extreme switches

create vlan "internal-man-105"

configure vlan internal-man-105 tag 105

configure vlan internal-man-105 add ports 2:24 tagged

configure vlan internal-man-105 ipaddress 1.1.1.1 255.255.255.248

enable ipforwarding vlan internal-man-105

configure ports 2:24 auto on speed 1000 duplex full

 

this is my configuration on cisco switch

 

interface GigabitEthernet3

 description Extreme-switch Uplink

 switchport

 switchport mode trunk

 logging event link-status

 logging event trunk-status

 logging event bundle-status

 logging event spanning-tree status

 logging event subif-link-status

 load-interval 30

 keepalive 30

 speed 1000

 duplex full

 udld port aggressive

 mls qos trust cos

 flowcontrol receive on

 flowcontrol send on

 spanning-tree portfast edge trunk

 spanning-tree bpduguard enable

end
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,574 Points 10k badge 2x thumb
Hello Siva,

What switch are you pinging and where are you pinging from? What are the IP addresses of each switch?
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi Patrick

My extreme switch IP address are 10.1.1.2 / 24 and 10.1.1.3 / 24 default gateway 10.1.1.1 /24
Cisco switch 10.1.1.1/24

 i'm pinging extreme switch from my laptop cmd 
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,404 Points 2k badge 2x thumb
ip on your laptop is on the same subnet?
Photo of Patrick Koppen

Patrick Koppen

  • 750 Points 500 badge 2x thumb
Hi Siva,

on EXOS you turned auto-negotiation on and advertise only 1000/full.

Are you sure duplex full and speed 1000 does not turn auto-negotiation off on cisco?
Spanningtree or udld could be a problem. You should look at the error counters, fdb,
spanningtree, link state, ..... Turn on logging on IOS and EXOS. Does any happen?
Link los, errors disable, duplicate ip, arp change, TCN, ...?

show ip int brief
show interface
show controllers GigabitEthernet3
....

Regards
Patrick
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Hi Patrick 


I have check Spanningtree on cisco log i dont see and any errors so i believe Spanningtree is not an issue problem .

* Slot-2 Stack.1 # configure ports 2:24 auto off speed 1000 duplex full Error: Auto negotiation off is not supported on copper medium of combo port 2:24 at 1G or 10G speed.

when I try to make it off i'm getting above error 
How to configure speed on EXOS not to be auto ?
(Edited)
Photo of Patrick Koppen

Patrick Koppen

  • 750 Points 500 badge 2x thumb
I hope not. Gigabit should always use auto negotiation. Try speed auto on Cisco.
An please check the error counters. Without a picture of you network and a detailed
error description it's just fishing in the dark.
 
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 12,886 Points 10k badge 2x thumb
speed 1000 on Cisco IOS uses auto-negotiation, speed 100 disables it
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,404 Points 2k badge 2x thumb
any speed command on cisco disables auto-negotiation
to re-enable auto-negotiation you should issue 
no speed
under selected interface
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 12,886 Points 10k badge 2x thumb
Hi Nick,

"speed 1000" on Cisco IOS does not disable auto-negotiation, it just restricts the advertised speeds to gigabit only. This is a trap I have seen many people fall into when trying to interconnect non-Cisco and Cisco switches with a "fixed" speed of 1000.

Thanks,
Erik
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,868 Points 5k badge 2x thumb
Siva,

Are the two switches(10.1.1.2,10.1.1.3) are in stacking?
If so can you post the "show switch" output from both the switches?
Photo of Patrick Koppen

Patrick Koppen

  • 750 Points 500 badge 2x thumb
Hi Siva,

error counters look normal (pause is strange...). Could you tell us a little more about you problem?

  • What is the IP of your laptop?
  • Which port is you laptop connected to?
  • What are the exact timings of the packet losses (e.g. loss after every 30 seconds, or work for 10 seconds, stopps for 60 seconds....)?
But still... it could be anything...

Regards
Patrick
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,868 Points 5k badge 2x thumb
configure ports 2:24 auto on speed 1000 duplex full
as per the port number 2:24 it looks like a stacking switch to me but anyways can you share the "show switch" output from both the switches ?
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
Maybe I need to plug 2 switches on the different blade on cisco switch, I will do this tomorrow. 
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,868 Points 5k badge 2x thumb
Siva,

Is it possible to share the "show switch" output from both the switches ?
Photo of Siva

Siva

  • 710 Points 500 badge 2x thumb
I have to change the cable's and change ports on both Cisco switch and extreme switch but still experiencing the same issue.

At this stage, I think extreme switch are not the good one. :-(
 
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,868 Points 5k badge 2x thumb
Hi Siva,

Can you share the "show switch" output from both the switches please?

The last one you posted was "show conf" i am looking for the "show switch" output from both the switches and see what MAC address they have....
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,868 Points 5k badge 2x thumb
Hi Siva,

I guess during configuration you may have configured the same MAC address for both the stacks which is causing this issue.

please use the below command so that the MAC address will get configured automatically.
"configure stacking mac-address"

Please note that you need to reboot the stack once the command is executed.

I hope you will not see the reported issue once you do the above.
Photo of Karthik Mohandoss

Karthik Mohandoss, Employee

  • 5,868 Points 5k badge 2x thumb
Hi Siva,

If i understood correctly although the switches have stacking enabled they do not have any physical connections via the stacking cable to any other node (switch).
If yes then the given command will only change the MAC address.
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 12,886 Points 10k badge 2x thumb
Hi,

do you use a fiber connection between the Extreme and Cisco switches? If so, activating UDLD on the Cisco is problematic, because it is a Cisco proprietary feature that does not work with other vendors' switches.

Using Ethernet flow control (active on the Cisco) is not a good idea in general, it might cause intermittent problems, like dropping one ping packet or the other.

The "keepalive 30" setting on the Cisco is dubious as well, as this should enable a Cisco proprietary keepalive mechanism, but the EXOS switch does not send responses.

Since you have configured BPDU Guard on the Cisco, you must not enable STP on the EXOS switch. You can check if BPDU Guard error disabled an interface using "show interfaces err-disable."

Thanks,
Erik
Photo of Nick Yakimenko

Nick Yakimenko

  • 2,404 Points 2k badge 2x thumb
they resolved issue 
they had the switches stacking enabled but they did not have any physical connections via the stacking cable to any other node
they used the below command so that the MAC address will get configured automatically. 
"configure stacking mac-address" 
Photo of Drew C.

Drew C., Community Manager

  • 38,472 Points 20k badge 2x thumb
It looks like Siva has deleted most of their responses here. I'm going to mark this one solved and close the thread for further comment to prevent confusion.

This conversation is no longer open for comments or replies.