Factory reset B2G124-48 without console access

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hello everyone.

I Recently got a B2G124-48 switch. When trying to access it through the console interface, nothing happens. I can not get any feedback from the console, even after performing the admin password reset procedure.
Apparently, this switch was a stack member.

Is there any way to clean the settings without accessing the switch through the console?

Best Regards
Photo of Paulo Pereira

Paulo Pereira

  • 176 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Christoph

Christoph

  • 1,862 Points 1k badge 2x thumb
Hey

There is a knowledge article from GTAC which describes the procedure in detail:
https://community.extremenetworks.com/extreme/topics/password_recovery_for_the_securestack_series-1jwf24

Kind regards
(Edited)
Photo of Paulo Pereira

Paulo Pereira

  • 176 Points 100 badge 2x thumb
Hi, and thanks for the reply

I already tried this procedure, but does not work, nothing appears on the console terminal.
The terminal e correctly configured and the cable is working fine.
Photo of Alex Morrissey

Alex Morrissey, Employee

  • 862 Points 500 badge 2x thumb
Hi Paulo,

If you follow the procedure that Christoph linked to there is a option in there to reset to factory defaults.  If however you do not get any output from console you may be using the wrong cable or settings.  The Switch should use a DB9 Null Modem cable with standard console settings of 9600 8/1/N as described in this article.  If you still get nothing from the switch after checking your cable and settings I would contact the GTAC for further assistance.

-Alex
Photo of Jason Parker

Jason Parker, Employee

  • 3,038 Points 3k badge 2x thumb
a few questions to start
1. Is this unit in a stack and not the manager then the console will not work for you , It is Functioning as designed
The access has limited coomans and are only used when we are debugging a problem. Be awae that we cannot access any commands on the switch without a customer inputting the admin acount and passwords

If not in a stack, then you can ry a ew option
1. on te back of te unit next to te stacking cale port is a pin hole, iput a toothpick or smething non metal and push in and hold or about 10-15 seconds and you may)should see a messsage on the onsole stating that the console has been cleared. This is where I would wait about 1 minute (manager updates even as a standalone
then try amin and enter, rw and enter
2. Reboot the swith and whn you see the boot menu here will be a 1 and 2 hit imediately 2 ener (fast) then tpe administrator as passworrd
Photo of Paulo Pereira

Paulo Pereira

  • 176 Points 100 badge 2x thumb
Hi there,

Once again, thank you all for your reply's.

Well, this unit was a stack member and was removed from it due to infrastructure upgrade. He keeps the settings it had when it was in the stack.

My company gave me the equipment, but now I can not access it in order to make its reconfiguration in order to serve my needs.

I am sure that this is not a terminal settings or cable problem, because both work fine on other equipment.

Best Regards
(Edited)
Photo of Buster Flynn

Buster Flynn

  • 222 Points 100 badge 2x thumb
Even as a stack member you should still be able to see the boot sequence and interrupt the boot process to do a reset. If you are seeing nothing on the terminal it is very likely a cable/adapter/pinout issue. When you say the terminal settings and cables work on other equipment...is that other Enterasys B2 equipment or just "other equipment"? I keep at least 4 different serial adapters for different switches. The cables/adapter I used for the SecureStack switches will not work on the Extreme switches, Cisco switches or the Enterasys 800 series switches. 
Photo of Paulo Pereira

Paulo Pereira

  • 176 Points 100 badge 2x thumb
Hello everyone,

I apologize for the delay, but I've been a little busy.

That was the first things I checked, the pin-out (Only three pins, 2, 3 and 5, which correspond respectively to the RX, TX, and GND), the cable and the connection settings.

This equipment uses the same pin-out and definitions of many others. The only difference to others is the connector, in this case it is a male connector.

After debating me for so long with the question, I'm starting to assume that I have a defective unit.

Best Regards
Photo of Paulo Pereira

Paulo Pereira

  • 176 Points 100 badge 2x thumb
Hi,

ok, as there was a strong suspicion of failure/damage, I decided to open the unit and investigate.
After a while I found the problem. Was the small flat cable that connects the board to the external console plug.
After replacing the flat cable, everything works perfectly.

The strange thing is, how does an internal cable, which is not touched by anyone, breaks/damage ??? Anyway ...

Now, it is to explore and know the limits of the machine ...

Thanks to everyone for the tips, I got very good impression of the community.
I hope to come to help, as you helped me!

Best Regards
Photo of Drew C.

Drew C., Community Manager

  • 37,036 Points 20k badge 2x thumb
Hi Paulo,
I'm glad to hear that were able to figure it out and get it working again!  Barring other factors (shock, connector stresses, etc.), temperature changes can sometimes cause connectors to work their way loose.  Maybe that happened in this case?

Come back and visit us often here!  I hope you'll find that we're a helpful and friendly bunch of people willing and eager to help.

-Drew
Photo of Atux Atux

Atux Atux

  • 170 Points 100 badge 2x thumb
Hi. i do have an Enterasys B5G124-48 switch that i would like to reset to defaults due to forgotten password. I got the console and it prompts "This switch is manager of the stack". I unplug it from power and plug it again and press the reset pin next to "stack down". Unfortunately it does not reset to factory defaults. i tried to follow the guidelines from https://community.extremenetworks.com/extreme/topics/password_recovery_for_the_securestack_series-1j...   without success.
Any ideas please?