failed to find VPIF 0

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Hi, all!

Have log in stack of X670V
10/28/2015
11:24:07.40 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 32] on VLAN 1000020

10/28/2015 11:24:07.40 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 31] on VLAN 1000020

After that vlan 2935 is automatically disabled.
After enable this vlan - enable vlan "VLAN_2935_SIP" this logs appear again
10/28/2015 13:13:56.69 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 32] on VLAN 1000020

10/28/2015 13:13:56.69 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 32] on VLAN 1000020

10/28/2015 13:13:56.69 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 31] on VLAN 1000020

Any ideas?

Thank you!


Photo of Alexandr P

Alexandr P, Embassador

  • 12,596 Points 10k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,304 Points 10k badge 2x thumb
Does this error pop up immediately after enabling the VLAN? Or is there a delay between the VLAN being enabled and the logs appearing?

Also, was this working previously, or is this a new implementation? If it was working, were there any changes recently made?

-Brandon
Photo of Alexandr P

Alexandr P, Embassador

  • 12,596 Points 10k badge 2x thumb
First time - almost at once with login to switch:
10/28/2015 11:24:07.40 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 32] on VLAN 1000020

10/28/2015 11:24:07.40 <Erro:Kern.Card.Error> Slot-2: exvlan: setVpifState:3075: KERNEL_EXVLAN_ERROR: failed to find VPIF 0 [slot 256 port 31] on VLAN 1000020

10/28/2015 11:23:56.73 <Info:AAA.LogSsh> Slot-1: Msg from Master : Did password authentication for user duzhvenko (10.10.200.24)

10/28/2015 11:23:56.73 <Info:AAA.authPass> Slot-1: Login passed for user duzhvenko through ssh (10.10.200.24)

Second time after enable vlan.

New configuration - it's create 4 new vlans with tags and ports.

Thank you!

Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,304 Points 10k badge 2x thumb
After a quick search, I don't see any known issues that seem to match this, but it does seem like it may be a bug.

It may be best to open up a case with GTAC so we can look into this deeper. I'd suggest attaching the .cfg file to the case, in addition to a show tech.

-Brandon
Photo of Alexandr P

Alexandr P, Embassador

  • 12,596 Points 10k badge 2x thumb
Hi, Brandon!

Case is opened.
Isn't "show tech-sup all" contain "sh conf" section?

Thank you!
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,304 Points 10k badge 2x thumb
Hi Alexandr,

'show tech all' does include 'show conf', but the .cfg is actually an XML file, which is the actual config file that the switch reads on boot. I'm thinking that there may be something strange in the config, so having the actual XML file that the switch loads the config from would be helpful. You can see the config file that was booted in the output of 'show switch', and you can TFTP this file off to a TFTP server.

If you do 'upload debug', this will also get the current .cfg file.

-Brandon
Photo of Alexandr P

Alexandr P, Embassador

  • 12,596 Points 10k badge 2x thumb
Hello, Brandon!

What exactly information I can give you for investigate this problem?
We investigate that this log-message appear 2 times after disable and after enable VLAN.
As this stack in the Customers core he is worry about it.
Where I can give you .cfg file for parallel investigate? Or have you a time to watch this?

Thank you!
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
I have not seen the case or documents but may I ask how many VLANs are on the switch and are all ports added to all of these VLANs??  Any VPIF errors are related to VLAN and port mappings.  There is a fixed number of ports and VLAN combinations within XOS that was set some time ago when XOS was first off the ground.  I had some discussion regarding this when a customer of mine wanted to create 4000 VLANs and add all ports from a loaded X8 to all VLANs, which in this case exceeded VPIF allocations within XOS.  
Photo of Alexandr P

Alexandr P, Embassador

  • 12,596 Points 10k badge 2x thumb
There is not so many VLANs:
-> show vlan             -----------------------------------------------------------------------------------------------
Name            VID  Protocol Addr       Flags                         Proto  Ports  Virtual   
                                                                              Active router
                                                                              /Total
-----------------------------------------------------------------------------------------------
Default         1    ------------------------------------------------- ANY    0 /0   VR-Default 
Mgmt            4095 xx.xx.xx.251   /24  ----------------------------- ANY    1 /1   VR-Mgmt    
VLAN380_fg-sum  380  xx.xx.xx.1  /29  -f--------------------------- ANY    2 /2   VR-Default 
VLAN381_cb-sum  381  xx.xx.x.9  /29  -f--------------------------- ANY    2 /2   VR-Default 
VLAN382_logs    382  xx.xx.xx.17 /29  -f--------------------------- ANY    6 /6   VR-Default 
VLAN383_fg-fmg  383  xx.xx.xx.25 /29  -f--------------------------- ANY    4 /4   VR-Default 
VLAN384_Sum_to_PCIDSS 384  xx.xx.xx.33 /29  -f--------------------------- ANY    2 /2   VR-Default 
VLAN385_fg-sum_int 385  xx.xx.xx.41 /29  -f--------------------------- ANY    2 /2   VR-Default 
VLAN_2935_SIP   2935 ------------------------------------------------- ANY    4 /4   VR-Default 
VLAN_3001_tnom  3001 ------------------------------------------------- ANY    4 /4   VR-Default 
VLAN_3055_Nb    3055 ------------------------------------------------- ANY    4 /4   VR-Default 
VLAN_3081_tnm   3081 ------------------------------------------------- ANY    4 /4   VR-Default 
Vlan_3441_empwr 3441 ------------------------------------------------- ANY    4 /4   VR-Default 
Vlan_3806_Cnm   3806 ------------------------------------------------- ANY    4 /4   VR-Default 
Vlan_3844_abis  3844 ------------------------------------------------- ANY    4 /4   VR-Default 
(Edited)