Flow Control Issue

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
  • (Edited)
Hi, we are having some issues with flow control on our BD 8800. The interface on the BD is connected to a carrier's Accedian ENID. When we put the circuit into production, we saw a lot of dropped packets on our interface using the "show port congestion" command. GTAC advised that we disable Flow-Control rx-pause and have the carrier disable flow-control. This worked and we have not seen any dropped packets on that interface, but now we have a new issue. Since we made the change, the video and voice quality for our Lync calls have declined tremendously. A report from the lync server for one of our calls showed a packet loss of ~45%. The utilization on the circuit is at 10% so im not sure why Lync would have an issue after flow-control was disabled. We have the DCSP enabled in our environment and we do have qosprofiles qp4 and 5 with the code points needed for video and voice, and the shared buffer is at 30%. From my understanding QoS only comes into play when the interface is overloaded which it is not. 

Is there anything else that can be done on the interface to improve the quality for Lync?
Photo of Darren Saliva

Darren Saliva

  • 662 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of EtherMAN

EtherMAN, Embassador

  • 7,370 Points 5k badge 2x thumb
We have seen some weirdness from the Accedian NIDS where they were sending out an excessive amount of packets 10,000 pps on an interface to a broadcast mac and ip so cpu was having to process each packet.  We were seeing large packet loss and arp learning was being affected on the 8900 where the nid was installed.  We had a webx session with TAC and they did a tcp dump on switch to see what packets were hitting the cpu .... we could not have figured this out easily with out TAC.  Our case was case # 01206510 if anyone from Extreme thinks this is something simular.  Good luck ... 
Photo of Stephen Williams

Stephen Williams, Employee

  • 9,076 Points 5k badge 2x thumb
Darren,

This is something that happens from time to time when you go through a carrier.  You where seeing dropped packets on the port because a device on the other side of the link was sending pause frames telling our switch to send less traffic.  When we send less traffic we have to buffer the traffic and eventually can drop traffic if it's too much.  This is what you where seeing.

When we buffer traffic, EXOS has the opportunity to prioritize the traffic with QOS using 802.1p and DSCP values to make sure your high priority traffic like your Lync traffic doesn't get dropped.  When you disabled RX pause frames EXOS no longer listen to the cries for help telling us to slow down, and we just send traffic as it comes in.  This is not always good because this gives the carrier the responsibility to drop traffic, and I'm sure your QOS values are not taken into account when dropping traffic.

This is why disabling Flow-Control rx-pause stopped the dropped packets on the switch but degraded your Lync quality.  I would turn it back on so we can prioritize your traffic, and ask the ISP why they are dropping your traffic.

Just a theory but i hope this helps.

Stephen
(Edited)
Photo of Darren Saliva

Darren Saliva

  • 662 Points 500 badge 2x thumb
Thanks Stephen. I actually just got off the phone with the carrier and enabled rx-pause again.
Photo of Stephen Williams

Stephen Williams, Employee

  • 9,076 Points 5k badge 2x thumb
What did the Carrier say?
Photo of Darren Saliva

Darren Saliva

  • 662 Points 500 badge 2x thumb
They said they don't have any settings that would point to them dropping packets. The usual carrier response.
Photo of Drew C.

Drew C., Community Manager

  • 40,846 Points 20k badge 2x thumb
Hi Darren, are you any closer to a resolution on this?