hardware software compatibility matrix typo?

  • 0
  • 1
  • Question
  • Updated 4 years ago
In the following link, most of the switches and modules show as last supported version the version 12.4.x.x, Isn't it supposed to be 15.4.x.x? 
There is even a X460-24t that the last supported version is lower than the minimum required version... 
http://extrcdn.extremenetworks.com/wp-content/uploads/2014/05/ExtremeXOS-Hardware-Software-Compatibi...
Photo of MrGuga

MrGuga

  • 294 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Daniel Flouret

Daniel Flouret, Employee

  • 7,470 Points 5k badge 2x thumb
MrGuga,

Everything seems to be right, except for the entry for the X450-24t, a very old switch, that shows a minimum required EXOS version of 12.5.1 that should probably read 11.5.1.

Most of the equipment with maximum EXOS version 12.4 is old, obsolete modules and switches that have reached their End of Life.

All switches that have recently reached End of Sale (X150/X250e/X350/X450e/X450a/X650) support EXOS versions up to v15.3 due to HW limitations.

Only the currently shipping switches (X430/X440/X46/X670/X770/BD8K/BDX8) upport v15.4 and higher.

Thanks for spotting the error. I'll pass it to the right people to have it corrected.
Photo of MrGuga

MrGuga

  • 294 Points 250 badge 2x thumb
So all our X250 and X450 that are running on 15.2.3.2 are just not supported by Extreme anymore or are they incompatible (and I am in serious trouble)?

By the time we bought our BD8806, current stable version was 12.6, but one of the modules we have (8900-G48T-xl) is not supported anymore according to the matrix (says 12.4.x.x). Did we buy an obsolete module?

Should I go for a downgrade?
Photo of Daniel Flouret

Daniel Flouret, Employee

  • 7,470 Points 5k badge 2x thumb
The older switches are still supported. They just can't run v15.4 and higher.

There are some implications to that that you should be aware of:
  • If you need to implement a feature that is available in one of the newer versions of EXOS (more than one MLAG neighbor, for example), you can't have it in the old hardware.
  • As new models come out, it won't be possible to stack them with older switches because all switches in a stack must run the same image version and there old ones won't support the newer version required by the new swich.

So while your old switches may have a happy long life ahead (I visit many customers still running v12.0 in their switches with no intention or need to upgrade them), you may want to start planning their replacement if your network environment is demanding and requires state of the art features.

Regarding the 8900 modules, sorry, I missed those. That's a mistake too. Those modules are 'alive and kicking' and have no limitations regarding maximum EXOS versions... They are not obsolete and have no announced End of Sale date, so you should not worry.
Photo of MrGuga

MrGuga

  • 294 Points 250 badge 2x thumb
Thanks, we were really scared here about the BD.

About the 450, ours are actually X450e and X450a models, so it makes sense to support up to 15.3. I was looking at the old X450 in the table, my bad.

Which is the most stable version for the BD8800 with 8900 modules and MSM128?
Photo of Daniel Flouret

Daniel Flouret, Employee

  • 7,470 Points 5k badge 2x thumb
That's a question for the GTAC. I don't know which version they are currently recommending.