high temperature X430-24t Port flapping

  • 0
  • 1
  • Question
  • Updated 4 years ago
Hello

I have a switch X430-24t that sends log high temperature. The version XOS is 15.3.2.11 patch1-2. 

SWBFCC28.9 # show fans

FanTray information:
 State:                  Operational
 NumFan:                 1
 Fan-1:                  Operational at 5900 RPM
SWBFCC28.10 # show temperature
Field Replaceable Units               Temp (C)   Status   Min  Normal   Max
---------------------------------------------------------------------------
Switch         : X430-24t               36.50    Normal   -10    0-48  55
SWBFCC28.11 #

These log high temperature, they may cause flapping on port users?

09/02/2014 08:02:53.47 <Info:vlan.msgs.portLinkStateUp> Port 13 link UP at speed 100 Mbps and full-duplex09/02/2014 08:02:50.88 <Info:vlan.msgs.portLinkStateDown> Port 13 link down
09/02/2014 08:02:50.22 <Info:vlan.msgs.portLinkStateUp> Port 3 link UP at speed 100 Mbps and full-duplex
09/02/2014 08:02:48.22 <Info:vlan.msgs.portLinkStateUp> Port 13 link UP at speed 1 Gbps and full-duplex
09/02/2014 08:02:47.57 <Info:vlan.msgs.portLinkStateDown> Port 3 link down
09/02/2014 08:02:45.02 <Info:vlan.msgs.portLinkStateDown> Port 13 link down
09/02/2014 08:02:41.62 <Info:vlan.msgs.portLinkStateUp> Port 13 link UP at speed 1 Gbps and full-duplex
09/02/2014 08:02:41.26 <Info:vlan.msgs.portLinkStateUp> Port 3 link UP at speed 1 Gbps and full-duplex
09/02/2014 08:02:38.12 <Info:vlan.msgs.portLinkStateDown> Port 3 link down
09/02/2014 08:02:36.97 <Info:vlan.msgs.portLinkStateDown> Port 13 link down
09/02/2014 08:02:34.94 <Info:vlan.msgs.portLinkStateUp> Port 3 link UP at speed 1 Gbps and full-duplex
09/02/2014 08:02:30.37 <Info:vlan.msgs.portLinkStateDown> Port 3 link down
09/02/2014 08:00:29.83 <Info:vlan.msgs.portLinkStateUp> Port 7 link UP at speed 100 Mbps and full-duplex
09/02/2014 08:00:27.24 <Info:vlan.msgs.portLinkStateDown> Port 7 link down
09/02/2014 08:00:24.66 <Info:vlan.msgs.portLinkStateUp> Port 7 link UP at speed 1 Gbps and full-duplex
09/02/2014 08:00:21.50 <Info:vlan.msgs.portLinkStateDown> Port 7 link down
09/02/2014 08:00:18.65 <Info:vlan.msgs.portLinkStateUp> Port 7 link UP at speed 1 Gbps and full-duplex
09/02/2014 08:00:13.81 <Info:vlan.msgs.portLinkStateDown> Port 7 link down
09/02/2014 07:58:36.02 <Info:vlan.msgs.portLinkStateUp> Port 2 link UP at speed 100 Mbps and full-duplex
09/02/2014 07:58:33.44 <Info:vlan.msgs.portLinkStateDown> Port 2 link down
09/02/2014 07:58:22.10 <Info:vlan.msgs.portLinkStateUp> Port 2 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:58:17.24 <Info:vlan.msgs.portLinkStateDown> Port 2 link down
09/02/2014 07:57:12.79 <Info:vlan.msgs.portLinkStateUp> Port 1 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:57:09.65 <Info:vlan.msgs.portLinkStateDown> Port 1 link down
09/02/2014 07:56:54.41 <Info:vlan.msgs.portLinkStateUp> Port 1 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:56:49.87 <Info:vlan.msgs.portLinkStateDown> Port 1 link down
09/02/2014 07:55:33.71 <Info:vlan.msgs.portLinkStateUp> Port 12 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:55:30.59 <Info:vlan.msgs.portLinkStateDown> Port 12 link down
09/02/2014 07:55:19.03 <Info:vlan.msgs.portLinkStateUp> Port 12 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:55:14.19 <Info:vlan.msgs.portLinkStateDown> Port 12 link down
09/02/2014 07:40:20.19 <Info:vlan.msgs.portLinkStateUp> Port 1 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:40:17.05 <Info:vlan.msgs.portLinkStateDown> Port 1 link down
09/02/2014 07:40:01.25 <Info:vlan.msgs.portLinkStateUp> Port 1 link UP at speed 1 Gbps and full-duplex
09/02/2014 07:39:56.68 <Info:vlan.msgs.portLinkStateDown> Port 1 link down
09/02/2014 07:15:49.35 <Noti:DM.Notice> Setting hwclock time to system time, and broadcasting time
09/02/2014 06:15:57.45 <Noti:DM.Notice> No Environment warnings present.  Setting Environment LED color back to Green (normal)
09/02/2014 06:15:57.45 <Noti:DM.Notice> Switch: Temperature (48 C) is back to operating range (0 to 48 Celsius). (X430-24t, P/N: 800542-00-03, S/N: 1324G-00397, Rev: 3.0)
09/02/2014 06:15:47.55 <Noti:DM.Notice> Setting hwclock time to system time, and broadcasting time
09/02/2014 05:20:55.63 <Erro:DM.Error> Switch: Temperature (48 C) is reaching maximum limit (55 Celsius). (X430-24t, P/N: 800542-00-03, S/N: 1324G-00397, Rev: 3.0)
09/02/2014 05:16:25.60 <Erro:DM.Error> Switch: Temperature (48 C) is reaching maximum limit (55 Celsius). (X430-24t, P/N: 800542-00-03, S/N: 1324G-00397, Rev: 3.0)


Regards
Photo of Jhonn Bejar

Jhonn Bejar

  • 320 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
Hi Jhonn,

As the switch is just near the max temp and the link flapping starts over an hour after it has recovered back to normal I would not say that these two effects are related. I once had a switch way below min temp and it worked just fine.

-Robert
Photo of Jhonn Bejar

Jhonn Bejar

  • 320 Points 250 badge 2x thumb
Hello Robert

which could be the cause of too many link down, link up at ports ?

09/03/2014 20:03:11.85 <Info:vlan.msgs.portLinkStateUp> : Port 20 link UP at speed 10 Mbps and full-duplex09/03/2014 20:03:10.06 <Info:vlan.msgs.portLinkStateDown> : Port 20 link down
09/03/2014 20:03:09.73 <Info:vlan.msgs.portLinkStateUp> : Port 20 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:03:07.27 <Info:vlan.msgs.portLinkStateDown> : Port 20 link down
09/03/2014 20:02:32.85 <Info:vlan.msgs.portLinkStateUp> : Port 1 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:02:30.03 <Info:vlan.msgs.portLinkStateDown> : Port 1 link down
09/03/2014 20:01:57.41 <Info:vlan.msgs.portLinkStateUp> : Port 15 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:57.01 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:55.22 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 20:01:55.07 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:54.36 <Info:vlan.msgs.portLinkStateDown> : Port 15 link down
09/03/2014 20:01:54.18 <Info:vlan.msgs.portLinkStateUp> : Port 22 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:53.08 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 20:01:49.64 <Info:vlan.msgs.portLinkStateDown> : Port 22 link down
09/03/2014 20:01:45.91 <Info:vlan.msgs.portLinkStateUp> : Port 5 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:44.90 <Info:vlan.msgs.portLinkStateDown> : Port 18 link down
09/03/2014 20:01:42.89 <Info:vlan.msgs.portLinkStateDown> : Port 5 link down
09/03/2014 20:01:37.07 <Info:vlan.msgs.portLinkStateUp> : Port 19 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:32.57 <Info:vlan.msgs.portLinkStateDown> : Port 19 link down
09/03/2014 20:01:24.43 <Info:vlan.msgs.portLinkStateUp> : Port 11 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:22.83 <Info:vlan.msgs.portLinkStateUp> : Port 12 link UP at speed 10 Mbps and full-duplex
09/03/2014 20:01:20.79 <Info:vlan.msgs.portLinkStateDown> : Port 11 link down
09/03/2014 20:01:19.74 <Info:vlan.msgs.portLinkStateDown> : Port 12 link down
09/03/2014 19:37:28.05 <Noti:DM.Notice> : Setting hwclock time to system time, and broadcasting time
09/03/2014 19:01:10.33 <Info:vlan.msgs.portLinkStateUp> : Port 3 link UP at speed 10 Mbps and full-duplex
09/03/2014 19:01:06.01 <Info:vlan.msgs.portLinkStateDown> : Port 3 link down
09/03/2014 18:37:29.82 <Noti:DM.Notice> : Setting hwclock time to system time, and broadcasting time
09/03/2014 17:49:16.59 <Info:vlan.msgs.portLinkStateUp> : Port 6 link UP at speed 1 Gbps and full-duplex
09/03/2014 17:47:25.95 <Info:vlan.msgs.portLinkStateDown> : Port 6 link down
09/03/2014 17:37:31.61 <Noti:DM.Notice> : Setting hwclock time to system time, and broadcasting time
09/03/2014 15:37:35.15 <Noti:DM.Notice> : Previous message repeated 2 additional times in the last 3598 second(s)
09/03/2014 15:14:07.22 <Info:vlan.msgs.portLinkStateUp> : Port 6 link UP at speed 1 Gbps and full-duplex
09/03/2014 15:14:03.49 <Info:vlan.msgs.portLinkStateDown> : Port 6 link down
09/03/2014 14:59:26.92 <Info:vlan.msgs.portLinkStateUp> : Port 6 link UP at speed 10 Mbps and full-duplex
09/03/2014 14:59:24.17 <Info:vlan.msgs.portLinkStateDown> : Port 6 link down
09/03/2014 14:37:36.92 <Noti:DM.Notice> : Setting hwclock time to system time, and broadcasting time
09/03/2014 14:12:24.88 <Info:vlan.msgs.portLinkStateUp> : Port 5 link UP at speed 100 Mbps and full-duplex
09/03/2014 14:12:22.48 <Info:vlan.msgs.portLinkStateDown> : Port 5 link down
09/03/2014 14:12:10.76 <Info:vlan.msgs.portLinkStateUp> : Port 5 link UP at speed 1 Gbps and full-duplex
09/03/2014 14:12:05.34 <Info:vlan.msgs.portLinkStateDown> : Port 5 link down
09/03/2014 14:11:55.25 <Info:vlan.msgs.portLinkStateUp> : Port 5 link UP at speed 10 Mbps and full-duplex
09/03/2014 14:11:52.07 <Info:vlan.msgs.portLinkStateDown> : Port 5 link down
09/03/2014 14:02:18.87 <Info:vlan.msgs.portLinkStateUp> : Port 2 link UP at speed 100 Mbps and full-duplex
09/03/2014 14:02:16.55 <Info:vlan.msgs.portLinkStateDown> : Port 2 link down
09/03/2014 14:02:13.32 <Info:vlan.msgs.portLinkStateUp> : Port 2 link UP at speed 1 Gbps and full-duplex
09/03/2014 14:02:10.39 <Info:vlan.msgs.portLinkStateDown> : Port 2 link down
09/03/2014 14:02:07.07 <Info:vlan.msgs.portLinkStateUp> : Port 2 link UP at speed 1 Gbps and full-duplex
09/03/2014 14:02:02.78 <Info:vlan.msgs.portLinkStateDown> : Port 2 link down
09/03/2014 13:57:41.52 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 100 Mbps and full-duplex
09/03/2014 13:57:39.13 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 13:57:35.77 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 1 Gbps and full-duplex
09/03/2014 13:57:32.90 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 13:57:28.37 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 1 Gbps and full-duplex
09/03/2014 13:57:24.11 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 13:57:23.59 <Info:vlan.msgs.portLinkStateUp> : Port 14 link UP at speed 100 Mbps and full-duplex
09/03/2014 13:57:21.93 <Info:vlan.msgs.portLinkStateDown> : Port 14 link down
09/03/2014 13:57:13.12 <Info:vlan.msgs.portLinkStateUp> : Port 14 link UP at speed 100 Mbps and full-duplex
09/03/2014 13:57:10.91 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 10 Mbps and full-duplex
09/03/2014 13:57:09.12 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 13:57:08.96 <Info:vlan.msgs.portLinkStateUp> : Port 8 link UP at speed 10 Mbps and full-duplex
09/03/2014 13:57:06.97 <Info:vlan.msgs.portLinkStateDown> : Port 8 link down
09/03/2014 13:57:04.96 <Info:vlan.msgs.portLinkStateDown> : Port 14 link down
09/03/2014 13:56:14.65 <Info:vlan.msgs.portLinkStateUp> : Port 2 link UP at speed 10 Mbps and full-duplex
09/03/2014 13:56:11.72 <Info:vlan.msgs.portLinkStateDown> : Port 2 link down
09/03/2014 13:56:10.40 <Info:vlan.msgs.portLinkStateUp> : Port 1 link UP at speed 100 Mbps and full-duplex
09/03/2014 13:56:08.08 <Info:vlan.msgs.portLinkStateDown> : Port 1 link down
09/03/2014 13:56:04.32 <Info:vlan.msgs.portLinkStateUp> : Port 1 link UP at speed 1 Gbps and full-duplex
09/03/2014 13:56:01.37 <Info:vlan.msgs.portLinkStateDown> : Port 1 link down
09/03/2014 13:55:58.10 <Info:vlan.msgs.portLinkStateUp> : Port 1 link UP at speed 1 Gbps and full-duplex
09/03/2014 13:55:53.78 <Info:vlan.msgs.portLinkStateDown> : Port 1 link down
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
Seeing the reported speeds, especially 10 Mbps, I'd say bad cabling. Or do you actually have devices that are only able to do 10 Mbps?

You could try doing a "configure ports <range> auto on speed 10 duplex half" and see if this reduces link flapping, especially for the ports that connect using 1 Gbps right now. If it helps, cabling is very likely to be the cause. But attention: 10 Mbps half-duplex won't make your users happy, as this is veeery slow. And you actually need to dis- and re-enable the ports to force the new setting.
Photo of Stephane Grosjean

Stephane Grosjean

  • 762 Points 500 badge 2x thumb
10Mbps Full Duplex is definitely uncommon.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
For temp issues, I would say physically touch the switch and see if switch actually got high temp. If not then there could be chances that s/w has some bugs.