How to configure 1G BaseT SPF in Summit X670-G2

  • 0
  • 1
  • Question
  • Updated 3 years ago
Hi im using a X670G2-48x-4q with the firmware v15.7.1.4

I want to use some 10/100/1000 BaseT SPF but they wont show link.

I have configured the with the command
"
configure ports x auto on speed 1000 duplex full
"

can you help me out is there somthing missing in the configuration?
Photo of John Dave Thurley

John Dave Thurley

  • 90 Points 75 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Venko Velev

Venko Velev

  • 70 Points
Hello John,
I didn't have the chance to negotiate 1000baseT SFP with this firmware of Extreme you are using , but on the 15.3.2 XOS image i am using this command and it helps :
configure ports x auto off speed 1000 duplex full

In this case you are forcing the port to work at 1000mbps.

Tell me if it helps :)

Regards!
Photo of Jeremy Thornton

Jeremy Thornton

  • 292 Points 250 badge 2x thumb
Try show port xx transceiver information detail  to see if the gbics are supported. Also, be aware that it may show unsupported if the gbic does not support displaying information about its' properties. You can also try show port xx information detail  and see if there are any messages related to the port being shutdown by the switch, disabled, etc. 

Are you connecting to an ISP, is that why you hard set the port properties? 
Photo of hasan issa

hasan issa

  • 154 Points 100 badge 2x thumb
HI

tray to use this configuration

configure ports 24 medium fiber auto on speed 1000 duplex full

Regards,
Hasan
Photo of John Dave Thurley

John Dave Thurley

  • 90 Points 75 badge 2x thumb
Hi, thanks for your comments!

@Venko
    i cant set a 1G port on autoneg off. it is recommenced for 1G

@jeremy
    the port informations are ok. SFP status is ready and the port is enabled but not active.
    i just connected the port to an notebook with 1G NIC for tests.

@hasan
    it is not possible to use the medium command on a non combo port.

 
Photo of Jeremy Thornton

Jeremy Thornton

  • 292 Points 250 badge 2x thumb
Did the port come up when the notebook was connected? If so, then make sure your gbics match. I know, I know... just humor me, I'm sure you've already double-checked. What is the next device upstream? I had issues getting a black diamond talk to a Cisco 9K last week and wound up having to move the circuit to a 3850 stack. 
Photo of Zelnosky, Kevin

Zelnosky, Kevin, Employee

  • 1,124 Points 1k badge 2x thumb
Yes, as Jeremy suggested, make sure that both sides are either LR or SR.  If you mix these, the link will not come up and you may even have the ability to damage an optic due to signal strength.
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
Hi,

I would suspect that you are experiencing the same issue that we had with SX optics with the 15.7 firmware.  Can you downgrade to 16.3.1 and give it a shot?  There was an issue in 15.7 where 1Gig optics on G2 would not give a link and go active.  Let me know...

Bill
Photo of Jeremy Thornton

Jeremy Thornton

  • 292 Points 250 badge 2x thumb
John, is it electric or optic? I was thinking electric since you hooked a notebook to it...
Photo of McClane

McClane, Employee

  • 410 Points 250 badge 2x thumb
FYI... I have an Extreme certified 10/100/1000 BASE-T mini GBIC and it works fine on my G2 running 15.7.1.4 with the default switch config... which is 'configure ports 24 auto off speed 10000 duplex full' and oddly enough the link comes up fine at 1G.
Photo of John Dave Thurley

John Dave Thurley

  • 90 Points 75 badge 2x thumb
it's an electric sfp for regular RJ-45 copper cable...
so i cant missmatch RX and TX ;)

@collins: I'm not using the certified GBICs but compatible ones...maybe thats the fault.
                But my reseller promised they would work...I'll order a pair of certified ones and try it out.