How to configure NTP authentication

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
Trying to get NTP authentication working on a Extreme Black Diamond with no success and not much support
Photo of Dennis Bell

Dennis Bell

  • 100 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,714 Points 10k badge 2x thumb
Hi Dennis,

Did you open a case with GTAC and they did not assist you?

NTP works with an xmod depending on what version of code you are running. Can you provide some more information on what your issue is?
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,608 Points 10k badge 2x thumb
Hi Dennis,

Can you give us a brief rundown of what you have tried so that we can have an idea of where you are with this?

Also, what version of EXOS are you running on this BlackDiamond?

-Brandon
Photo of Dennis Bell

Dennis Bell

  • 100 Points 100 badge 2x thumb
Brandon:

enable ntpenable ntp authentication
create ntp key 1 md5 encrypted "0MujpNXF@iCMjh"
configure ntp key 1 trusted
create ntp key 2 md5 encrypted "w\\io]/lgnvgArM"
configure ntp key 2 trusted
enable ntp vlan OA
configure ntp server add 192.168.192.170 key 1 initial-burst
configure ntp server add 192.168.192.209 key 2 initial-burst

BD-Spare.5 # sh ntp association
Remote                    Reference ID    St Poll Reach Delay   Offset   Disp
========================= =============== == ==== ===== ======= ======== =======
 !192.168.192.170          INIT            16 1024 0     0.00000 +0.00000 3.99217
 !192.168.192.209          INIT            16 1024 0     0.00000 +0.00000 3.99217

St(ratum)   : Distance from the reference clock
Disp(ersion): Maximum offset error of clock
Flags       : (*) System Peer, (.) Candidate, (#) Short List, (!) Configured


Chassis     : 800128-00-06 09255-00489 Rev 6.0Slot-1      : 800227-00-06 1350G-00208 Rev 6.0 BootROM: 1.0.4.1    IMG: 15.6.3.1
Slot-2      :
Slot-3      :
Slot-4      :
Slot-5      :
Slot-6      :
Slot-7      : 800224-00-05 0939G-00196 Rev 5.0 BootROM: 1.0.4.1    IMG: 15.6.3.1
Slot-8      :
Slot-9      :
Slot-10     :
MSM-A       : 800314-00-03 1349G-01039 Rev 3.0 BootROM: 1.0.4.5    IMG: 15.6.3.1
MSM-B       : 800314-00-03 1349G-01022 Rev 3.0 BootROM: 1.0.4.5    IMG: 15.6.3.1
PSUCTRL-1   : 450105-00-03 09245-00131 Rev 3.0 BootROM: 2.18
PSUCTRL-2   : 450105-00-03 09245-00079 Rev 3.0 BootROM: 2.18
PSU-1       :
PSU-2       :
PSU-3       :
PSU-4       :
PSU-5       : PS 2336 4300-00145 0910K-36941 Rev 10.0
PSU-6       : PS 2336 4300-00145 0910K-36551 Rev 10.0

Image   : ExtremeXOS version 15.6.3.1 v1563b1-patch1-5 by release-manager
          on Sun Aug 16 21:40:56 EDT 2015
BootROM : 1.0.4.5
Diagnostics : 1.20


Thanks
Photo of Dennis Bell

Dennis Bell

  • 100 Points 100 badge 2x thumb
Brandon:

I thought I should add that the show command tells us NTP is stratum 16 and that says it is not working.  Shoud I open a case?  We have support but the last time I talked with them they wanted all of the logs and I really did not want to do that becuse I would have to scrub them first.  I will open a new ticket if you think it is the best way to resolve this. 

Thanks
Photo of Patrick Voss

Patrick Voss, Alum

  • 11,714 Points 10k badge 2x thumb
I think that will be the best plan moving forward. Unfortunately in order to fully troubleshoot an issue this information needs to be requested.
Photo of Dennis Bell

Dennis Bell

  • 100 Points 100 badge 2x thumb
I opened a ticket I will post the outcome.