How to copy one Switch configuration to another Switch with encrypted passwords

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered

Hi,

i need to copy the config from a LAN attached Switch to a local switch to replace it later?

If i run the show conf to get the running config of the LAN attached switch in plaintext and paste it to the local(not LAN Attched device) it will not enter the encrypted passwords for Radius.(not well formated)

I dont know the Passwords and their are encrypted.

How can i copy a configuration from the LAN Attched device to the local device or create from this config a template to for configuration of other devices?

Photo of holden

holden

  • 452 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Drew C.

Drew C., Community Manager

  • 37,350 Points 20k badge 2x thumb
Hi Holger,
The configure radius mgmt-access [primary|secondary] shared-secret encrypted "(encrypted_secret)" command will allow you to copy the config over to another switch and should work.  In our lab, this is how I apply my RADIUS config to other switches.  You won't be able to take the password in the config directly and enter it - you'll need to use the "encrypted" keyword to tell EXOS that you're giving it an already encrypted password.

If you knew the password, you would enter it directly without the "encrypted" keyword in the command.  The switch would then encrypt it and safely store it in the config.

Here's some more information on the command:  http://documentation.extremenetworks.com/exos_commands/EXOS_All/EXOS_Commands_All/r_configure-radius-sharedsecret.shtml
(Edited)
Photo of holden

holden

  • 452 Points 250 badge 2x thumb
thanks, the switch has to be reset. after i reset it, it has accept the command.
Photo of holden

holden

  • 452 Points 250 badge 2x thumb

Sorry, after configuring another switch, i have the same issue again:

configure netlogin add mac-list ff:ff:ff:ff:ff:ff 48 encrypted "xxxxxxxxx"
not well-formed (invalid data)* Slot-1


The encrypted password contains:"&;'=" and Characters(capital-noncapital) and Numbers


Photo of Drew C.

Drew C., Community Manager

  • 37,322 Points 20k badge 2x thumb
What version of EXOS are you running?  I wonder if what you're experiencing is related to this issue...
https://gtacknowledge.extremenetworks.com/articles/Q_A/Are-There-Illegal-Password-Characters-in-XOS/
(Edited)
Photo of holden

holden

  • 452 Points 250 badge 2x thumb

Hi,

we are using 15.3.5.2

Photo of Drew C.

Drew C., Community Manager

  • 37,350 Points 20k badge 2x thumb
It may have gotten fixed in one place and not another.  Sounds like we need to get a ticket opened to confirm and get over to Engineering.
Can you open a case with GTAC?
Photo of holden

holden

  • 452 Points 250 badge 2x thumb
no thats not neccessary. i will enter it unencrypted.