How to enable Wake-on-LAN with NetLogin

  • 0
  • 1
  • Question
  • Updated 8 months ago
  • Answered
Hi,

we have a request to make WoL possible in our network.
I already found that aritcle: https://gtacknowledge.extremenetworks.com/articles/How_To/Wake-On-LAN-WOL-to-work-with-Netlogin
but I have a few issues:
  • The first method doesn't work here. I can see, that "show udp-profile" forwards traffic to my dummy-vlan, but the device doesn't wake up. If I send out the WoL packet, when the computer is on, my wireshark can see the incoming WoL packet. I did all the commands, which are described for that method
  • The second method is not applicable, because we don't want to edit scripts on the switch, when changing a netlogin-port - that is simply too much
  • The third method is not applicable, because most of our switches doesn't support OnePolicy
I'm sure that I am not the only one who experience these issues - has anyone a working solution for that scenario?

Best Regards
Chacko
Photo of Chacko

Chacko

  • 1,206 Points 1k badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of David Coglianese

David Coglianese, Embassador

  • 7,128 Points 5k badge 2x thumb
Windows 10 seems to disable will by default. It has to do with a default power setting and can be fixed with a gpo.

Not sure if this is part of your issue or not, but thought it was worth mentioning.
Photo of Chacko

Chacko

  • 1,206 Points 1k badge 2x thumb
Hi,

ok, good to know.

But I do the testing with Windows 7.
When I configure the test-port without netlogin, the WoL instantly wakes up the computer.

BR
Chacko
Photo of Hagemann, Olaf

Hagemann, Olaf, Employee

  • 1,306 Points 1k badge 2x thumb
You should consider IP directed broadcast or enable broadcast flooding into the netlogin VLAN.
Photo of Chacko

Chacko

  • 1,206 Points 1k badge 2x thumb
Hi, where do I exactly need to enable that?
We have a NetLogin-VLAN without an IP address and a few Layer-3 VLANs where the clients are assigned to.
BR
Chacko
Photo of Chacko

Chacko

  • 1,206 Points 1k badge 2x thumb
Ok, problem solved.
You need to enable egress broadcasts to the Netlogin-VLAN.
After that is done, it works like stated in the KB-article
Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Not sure which KB article you  have referred. Anyway here is what i can find the procedure from one of the article mentioned earlier. If not then please refer this for  your future reference:

https://gtacknowledge.extremenetworks.com/articles/How_To/Wake-On-LAN-WOL-to-work-with-Netlogin/?q=e...

Anyway good to hear that after enabling the egress broadcast this started to work as expected.

 
This solution seems to work for EXOS with Netlogin (802.1x and/or mac).
But the command "netlogin ports [port_list | all] allow egress-traffic [none | unicast | broadcast | all_cast]"
is no more available, if OnePolicy (Enterasys Policy) are used.

As described in command reference: "Enabling ONEPolicy removes the action of this command. This command is supported only in non-policy mode"

I'm not able to find a solution for following scenario:
- X440-G2 L2-Access Switch (no option for making them routing)
- Extreme NAC with Policy
- EXOS 22.3
- One Policy enabled

Regards
Micha