How to restart database in NSight server

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • Answered

Hi


I have a vx9000 with Nsight installed. Today I have not been able to enter Nsigh showing me the following error: communication error.

The sh nsight status command shows the following:

Nsight is enabled
 Nsight report and aggregation daemon is running
 Nsight alarm daemon is running
 Nsight server daemon is running
 Database server is local
 Database server is not reachable


I tried to restart the service with the command: service database server restart but it shows me the following error:

% Error: NSight must be disabled before using this command.


Is there any way to restart the Nsigh service without having to restart the vx9000 completely?

Thanks.


Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of Robert Zarzycki

Robert Zarzycki, Employee

  • 4,272 Points 4k badge 2x thumb
service database server (start|stop|restart)
Photo of Robert Zarzycki

Robert Zarzycki, Employee

  • 4,272 Points 4k badge 2x thumb
Can you confirm the firmware version your running and also ensure that you are scaling as per requirements. 

Scaling – NSight on Virtualized VX9000 Platform
Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb
Hello, Robert
I've tried this. But this command returns the error:
% Error: NSight must be disabled before using this command.
Photo of Robert Zarzycki

Robert Zarzycki, Employee

  • 4,272 Points 4k badge 2x thumb
can you provide the output of command 'show file systems' ?
Photo of Robert Zarzycki

Robert Zarzycki, Employee

  • 4,272 Points 4k badge 2x thumb
Also 'show database statistics' & 'show database status'
(Edited)
Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb

I attach the results of the commands:

vx9000-B004F8*#sh file systems
File Systems:

      Size(Mb)      Free(Mb)  Use%    Type  Prefix
            68            58    14   flash  nvram:
          1930          1596    17   flash  flash:
          3860             0   100       -  vmsdb:
          3860             0   100   flash  internal (/vms)

   


vx9000-B004F8*#sh database statistics
% Database server is not running


vx9000-B004F8*#sh database status
% Database server is not running

Photo of Vedran Jurak

Vedran Jurak

  • 1,018 Points 1k badge 2x thumb
Well, there's your problem. You ran out of space.
Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb

Sorry, I had not seen it.
And that space of 3860, what do you mean?
Is the RAM assigned to the virtual machine?
I'm not sure, I would have to verify it, but I think the machine has a minimum of 24GB of RAM.
If I was wrong. Could more RAM be allocated to the virutal machine without losing licenses or config?

Thanks.

Photo of Robert Zarzycki

Robert Zarzycki, Employee

  • 4,272 Points 4k badge 2x thumb
Essentially you have not scaled your NSight correctly when you built the VX9000. 
Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb
and has no solution?
Can I expand the VX's features to expand the Nsight features?
Photo of Vedran Jurak

Vedran Jurak

  • 1,018 Points 1k badge 2x thumb
You ran out of disk space (storage), not RAM. There are several solutions, but I suggest contacting the GTAC for step by step instructions.

These include attaching a new disk or migrating to another VM with proper amount of resources.

It might be tricky if you need your old data, so GTAC is your best bet.
Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb
you were right. The VX9000 does not have the necessary resources. The vx was installed with the default values of 8GB of hard disk and 4GB of RAM. I will open a case with GTAC.
Thanks
Photo of Jose_LV

Jose_LV

  • 1,174 Points 1k badge 2x thumb
The version of vx9000 is 5.9.1.2
Photo of Robert Zarzycki

Robert Zarzycki, Employee

  • 4,272 Points 4k badge 2x thumb
Photo of Andrew Blomley

Andrew Blomley, Employee

  • 652 Points 500 badge 2x thumb
Can you confirm that you have enabled the database

I believe the command is

En
Self
Use database-policy default

But I’m on phone not my computer