How do I set X440-24p back to Factory Default?

  • 0
  • 2
  • Question
  • Updated 9 months ago
  • Answered
So I setup this new out-of-box switch, I set the admin password, but I can no longer get into it.  I obviously set the password to something that I can't seem to replicate.  Anyways I am trying to set the switch back to factory default but I am not able to.  I go into the bootloader by holding the space bar a the appropriate time.  From there all documentation states to perform a config none command and reboot.  Well this command is not accepted, it doesn't recognize the 'config' command.  I have called TAC and they sent me the same documentation in which I have already read.  I have not disabled the failsafe-account, but still has default username and password, but I don't know what they are.  There is conflicting documentation on this, TAC stated that has to be manually set, other documentation states TAC has a utility to determine the creds for me.  So what is the real deal here?????  Getting frustrated.
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 2
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
Hey Jason

There are actually two boot options first is the boot strap and the second is the boot loader.

When you power up the switch and hold the spacebar you first go into the boot strap.  You need to then type boot and continue to hold the space bar and that will take you to the boot loader that is where you put the config none.

Please let me know if this helps
P
Photo of Gopu T

Gopu T

  • 62 Points
Thank u Paul Russo,
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
I am in the BootROM> I am only given 1 option to boot into.  There are not 2 options.
(Edited)
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
if you hit ? what menu do you get?

P
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

Gives me the help menu same as pressing 'h' or 'help'


                                                                            =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.05.29 14:10:13 =~=~=~=~=~=~=~=~=~=~=~=


Extreme Networks



Alternate BootStrap Image

Starting CRC of Default image

Using Default image ...



Extreme Networks



Default BootLoader Image

DRAM Post


Press and hold the <spacebar> to enter the bootrom.
Copyright 2003 - 2013 Extreme Networks, Inc.



BootRom >                  config factory_default
config: Command not found. Try 'h' for help!

BootRom > h
                             Boot and Load                           
                            --------------                           
   pboot  boot                                                               
   oload  load memory from hostport                                          
    load  load file                                                          
    boot  boot an image                                                      
                                 Misc                                
                            --------------                           
  loader  Sets which BootLoader BootStrap will boot                          
    call  call function                                                      
   devls  list devices                                                       
  reboot  Reboot system (hard reset)                                         
   flash  program flash memory                                               
    show  display information                                                
                               Debugger                              
                            --------------                           
more...

(Edited)
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
yes can you cut and paste that here?

P
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

                                                                            =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.05.29 14:10:13 =~=~=~=~=~=~=~=~=~=~=~=


Extreme Networks



Alternate BootStrap Image

Starting CRC of Default image

Using Default image ...



Extreme Networks



Default BootLoader Image

DRAM Post


Press and hold the <spacebar> to enter the bootrom.
Copyright 2003 - 2013 Extreme Networks, Inc.



BootRom >                  config factory_default
config: Command not found. Try 'h' for help!

BootRom > h
                             Boot and Load                           
                            --------------                           
   pboot  boot                                                               
   oload  load memory from hostport                                          
    load  load file                                                          
    boot  boot an image                                                      
                                 Misc                                
                            --------------                           
  loader  Sets which BootLoader BootStrap will boot                          
    call  call function                                                      
   devls  list devices                                                       
  reboot  Reboot system (hard reset)                                         
   flash  program flash memory                                               
    show  display information                                                
                               Debugger                              
                            --------------                           
more...

Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
What bothers me is that is starts of with 'Alternate Bootstrap Image'
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
ok so type boot and continue to hold down the space bar until you go into the next command line.  then do the config command and let me know

P
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
ok, been there done that, trying again.....
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
It just starts loading the XOS image.  Doesn't go to another cmd line, doesn't prompt for the bootloader again. :(
Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
ok thanks
P
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

Here is the output


BootRom > boot


 


Loading EXOS Image ...


 


Running Image ...


 


                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     Starting ExtremeXOS 15.3.1b4


Copyright (C) 1996-2013 Extreme Networks.  All rights reserved.


Protected by US Patent Nos: 6,678,248; 6,104,700; 6,766,482; 6,618,388; 6,034,957; 6,859,438; 6,912,592; 6,954,436; 6,977,891; 6,980,550; 6,981,174; 7,003,705; 7,017,082; 7,046,665; 7,126,923; 7,142,509; 7,149,217; 7,152,124; 7,154,861; 7,245,619; 7,245,629; 7,269,135; 7,448,045; 7,447,777; 7,453,874; 7,463,628; 7,483,370; 7,499,679; 7,502,374; 7,539,750; 7,522,516; 7,546,480; 7,552,275; 7,554,978; 7,558,273; 7,568,107; 7,577,996; 7,581,024; 7,580,409; 7,580,350; 7,584,262; 7,599,292; 7,602,721; 7,606,249; 7,606,240; 7,606,263; 7,613,209; 7,619,971; 7,646,773; 7,646,770; 7,649,879; 7,657,619; 7,657,635; 7,660,259; 7,660,894; 7,668,969; 7,672,228; 7,675,915; 7,689,678; 7,693,158; 7,710,993; 7,719,968; 7,724,734; 7,724,669; 7,733,899; 7,752,338; 7,773,507; 7,783,733; 7,792,058; 7,813,348; 7,814,204; 7,817,549; 7,817,633; 7,822,038; 7,822,032; 7,821,931; 7,823,199; 7,822,033; 7,835,348; 7,843,927; 7,856,019; 7,860,006; 7,889,750; 7,889,658; 7,894,451; 7,903,666; 7,908,431; 7,912,091; 7,936,764; 7,936,687; 7,944,942; 7,983,192; 7,990,850; 8,000,344; 8,055,800; 8,059,658; 8,072,887; 8,085,779; 8,107,383; 8,117,336; 8,117,657; 8,135,007; 8,139,583; 8,159,936; 8,160,074; 8,161,270; 8,174,980; 8,204,070; 8,208,418; 8,233,474; 8,255,996; 8,274,974; 8,279,874; 8,295,188.


 


                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 


(pending-AAA) login:                                                                                                                                                                                                                                                             


 


Authentication Service (AAA) on the master node is now available for login.


 


 

Photo of Paul Russo

Paul Russo, Alum

  • 9,694 Points 5k badge 2x thumb
thanks Jason

This is strange.  I dont have one in front of me let me check.

P
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
We have tried downloading an image from a tftp server, no dice comes back with not enough space.  But it does reference a recovery image, and we can't find one available.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
BootRom > config none

config: Command not found. Try 'h' for help!

 

If we upgrade switch to any EXOS software from BOOTROM, it will erase all information from flash memory (including configuration, XOS image file). Therefore, it will allow you to login into the switch using the default username and password, but it will not show “config none” command. To provide more security we have disabled the “config none” command in 2.0.2.1 bootrom(Latest).


Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

Well that gets the big WTF 

Make it more secure from the BOOTLOADER you disable the command to reset the config, ok whatever.   How do I reset the config??   I have definitely tried downloading an image and it states its too large try increasing block size.......

Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
You may try to downgrade the bootrom version to get the "config none" command back, but it is not recommended.


Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
That is an awesome idea, where do I download a bootrom version from???
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Call the TAC and ask  bootrom 2.0.1.7 which has config none command.
Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb

Well it now looks like the image download is working now.  We tried a different tftp server software and that handles it apparently.  It appears to download once at a block size of 1428, but then downloads it again at a smaller block size of 512.  I don't know why it needs to download it twice but its done formatting the partitions and is now installing the image. 

Bad TFTP server software: Blue Pumpkin

Good TFTP server software: WinAgents

We also placed the switch address within the same Class C address range even though they are in a Class B subnet.

Photo of Jason Weems

Jason Weems

  • 412 Points 250 badge 2x thumb
That did seem to work, thx for your help.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
No issue.. Let us know if you need any more information ..


(Edited)
Photo of Jason Cohenour

Jason Cohenour

  • 100 Points 100 badge 2x thumb
I'm in the same boat as Jason, the other night I changed password for admin and typed ENCRYPTION, as this is what I would have done with a Cisco.  Big Mistake, now I cannot login, as I deleted user account and did not setup failsafe.

I also typed ENCRYPTION on the backdoor account I created for myself.... BIG DUMMY.  Why doesn't the manual tell you the SEVERE consequences of using the word encryption?  IE:  IF you fail to record the HASH of the password you entered entered you will NOT be able to log in to the account.

Removing the config.none command seems like a HORRIBLE idea causing maximum anguish for customers who have already made a mistake, by not leaving a method to default switch available..  Is extreme worried about someone breaking into a secure room or data center and stealing a switch and then hacking the config??

So please, What do I need to type from BootRom > in order to get this switch running again? 

PC has IP address of 10.0.1.21/24 
Do I plug patch cable into MGT port on switch?


 I have solar winds TFTP server running on my PC and used it to get SummitX-15.3.1.4-patch1-19-ssh.xmod installed on the switch before I tanked it.


Thanks,


Jason Cohenour
 
Photo of Jason Cohenour

Jason Cohenour

  • 100 Points 100 badge 2x thumb
My switches are Summit X440-48p Purchased last week.
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Execute below command from bootrom,
1)Connect the PC which has TFTP server application running to the management port and type via CLI:       

      configip ipaddress <ipaddress/mask> gateway <ipaddress>

{NOTE: gateway ipaddress is TFTP server}

 

2)type via CLI: showip

{NOTE: confirmS ipaddress of switch’s management port}

 

3) type via CLI: download image <ipaddress> <filename>

{NOTE: ipaddress is TFTP server; filename is XOS image being downloaded}


Our team has decided to put it back config none command  in new bootrom as many customers are requesting for the same.

Please get new bootrom after calling Extreme TAC.

Photo of Jason Cohenour

Jason Cohenour

  • 100 Points 100 badge 2x thumb
Thank you for the help, I've trolled around and viewed the folllowing:
https://community.extremenetworks.com/extreme/topics/how_do_you_reset_a_summit_x450a_24t_to_factory_...
I am DL 15.3.4.6 now to upgrade XOS