Howto: ipv6 Router Advertisement Option DNS Server

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Has anybody realized a working ipv6 config in EXOS 15.1 with router advertisement for DNS Server? (RFC 6106)
I tried:
configure vlan NAME router-discovery ipv6 ...
but there is no further option.

conf vlan dhcp ... 
acceptes only IPv4 Adresses

as i can see, there is no specific command for enabling these router advertisements.

regards
Manfred



Photo of Manfred Huels

Manfred Huels

  • 98 Points 75 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Rex

Rex, Employee

  • 100 Points 100 badge 2x thumb
The command and example as following. But not all the OS an support this feature. 
configure {vlan} <vlan_name> router-discovery {ipv6} add dnssl <dns_suffix>{{dnssl-lifetime} [<dnssl_lifetime> | infinity]}
configure {vlan} <vlan_name> router-discovery {ipv6} add rdnss <ipaddress>
configure vlan v6 router-discovery ipv6 add dnssl mycompany.com
configure vlan v6 router-discovery ipv6 add rdnss 
fd00:52c0:d5a9:58fb:f66d:4ff:fe42:4a82

http://en.wikipedia.org/wiki/Comparison_of_IPv6_support_in_operating_systems
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
One of my customer has same type of issue couple of years back and below was the solution,

configure vlan bedvu212 router-discovery ipv6 add dnssl sumittokle.com
configure vlan bedvu212 router-discovery ipv6 add rdnss 2620:f6:8000:3::2
configure vlan bedvu212 router-discovery ipv6 add prefix 2620:f6:8000:2711::/64
configure vlan bedvu212 router-discovery ipv6 set prefix 2620:f6:8000:2711::/64 autonomous-flag on
configure vlan bedvu212 router-discovery ipv6 set prefix 2620:f6:8000:2711::/64 onlink-flag on
configure vlan bedvu212 router-discovery ipv6 set prefix 2620:f6:8000:2711::/64 preferred-lifetime 604800
configure vlan bedvu212 router-discovery ipv6 set prefix 2620:f6:8000:2711::/64 valid-lifetime 2592000
configure vlan bedvu212 router-discovery ipv6 min-interval 30
configure vlan bedvu212 router-discovery ipv6 managed-config-flag on
configure vlan bedvu212 router-discovery ipv6 other-config-flag on
enable router-discovery ipv6 vlan bedvu212
enable router-discovery ipv6 vlan cc3uc1

http://en.wikipedia.org/wiki/Comparison_of_IPv6_support_in_operating_systems

Windows does not support rdnss without a special addon. I see from the advert that the switch is sending the dnssl and rdnss. Tests on linux/mac that support this grab the dns list fine. 
Photo of Manfred Huels

Manfred Huels

  • 98 Points 75 badge 2x thumb
It seems, not all ExOS supports this feature.


System Type:      X250e-48t
Primary ver:      15.1.2.12              
                  patch1-6

does not. I will ask our reseller, if we miss a license or something like that.

IPv6-Testswitch.2 # configure vlan net1ipv6 router-discovery ipv6 add
  prefix          prefix advertised for this vlan
IPv6-Testswitch.2 # configure vlan net1ipv6 router-discovery ipv6 add dnssl lbswest.ipv6
                                                                                                                          ^
%% Invalid input detected at '^' marker.
IPv6-Testswitch.3 #

Photo of Elmer

Elmer

  • 250 Points 250 badge 2x thumb
This feature is supported since  15.2. But not sure if your X250e can upgrade to 15.2 or not? 
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Yes..X250 can upgrade to 15.2.

Use below link to get software/hardware compatibility matrix information,

http://enterasys.wpengine.netdna-cdn.com/wp-content/uploads/2014/02/HW-SW-Compatibility-Matrix-Rev-0...

Photo of Manfred Huels

Manfred Huels

  • 98 Points 75 badge 2x thumb
ok - with 15.3 it works.

Unfortunately seems there not to be any Client, which understands the Switch Advertisings.

With

configure vlan net1ipv6 router-discovery ipv6 add dnssl lbswest.ipv6
configure vlan net2ipv6 router-discovery ipv6 add dnssl lbswest.ipv6
configure vlan net1ipv6 router-discovery ipv6 add rdnss 2a00:7460:da11:be00::98
configure vlan net2ipv6 router-discovery ipv6 add rdnss 2a00:7460:da11:be00::98
configure vlan net1ipv6 router-discovery ipv6 add prefix 2a00:7460:da11:be00::/64
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 autonomous-flag on
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 onlink-flag on
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 preferred-lifetime 604800
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 valid-lifetime 2592000
configure vlan net2ipv6 router-discovery ipv6 add prefix 2a00:7460:da11:be01::/64
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 autonomous-flag on
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 onlink-flag on
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 preferred-lifetime 604800
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 valid-lifetime 2592000
enable router-discovery ipv6 vlan net1ipv6
enable router-discovery ipv6 vlan net2ipv6

my SLES Clients do not get the IP address of the DNS server.

If i apply a DHCP Service:

configure bootprelay ipv6 add 2a00:7460:da11:be01::2 vr VR-Default
enable bootprelay ipv6 vlan net1ipv6
enable bootprelay ipv6 vlan net2ipv6
configure vlan net1ipv6 router-discovery ipv6 add dnssl lbswest.ipv6
configure vlan net2ipv6 router-discovery ipv6 add dnssl lbswest.ipv6
configure vlan net1ipv6 router-discovery ipv6 add rdnss 2a00:7460:da11:be00::98
configure vlan net2ipv6 router-discovery ipv6 add rdnss 2a00:7460:da11:be00::98
configure vlan net1ipv6 router-discovery ipv6 add prefix 2a00:7460:da11:be00::/64
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 autonomous-flag on
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 onlink-flag on
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 preferred-lifetime 604800
configure vlan net1ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be00::/64 valid-lifetime 2592000
configure vlan net2ipv6 router-discovery ipv6 add prefix 2a00:7460:da11:be01::/64
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 autonomous-flag on
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 onlink-flag on
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 preferred-lifetime 604800
configure vlan net2ipv6 router-discovery ipv6 set prefix 2a00:7460:da11:be01::/64 valid-lifetime 2592000
enable router-discovery ipv6 vlan net1ipv6
configure vlan net2ipv6 router-discovery ipv6 managed-config-flag on
configure vlan net2ipv6 router-discovery ipv6 other-config-flag on
enable router-discovery ipv6 vlan net2ipv6

the router sends no router advertisings until i had rebooted him. Additionally only my SLES 11 SP3 client gets some DNS config from the DHCP Server, the SLES 11 SP2 does not. NTP service advertisings from the DHCP was not understood from either.

So i have finally concluded:
- DNS autoconfig does not work respectively works only with DHCPv4
- Until further, IPv6 works with Extreme Networks routers only in a Dual Stack environment


regards
Manfred

 

 



(Edited)