i BGP next hop self issue

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Next hop self not working as expected in i-BGP peering. We have e-BGP peering across Extreme pair of L3 switches towards ISP routers. Also we have i-BGP peering between application nodes and the Extreme switches. Refer to diagram below. Default route is advertised by ISP routers and reaches Extreme A and B, but not till Application node at the left-most side. Next-hop self is enabled for IPv6, still I can see on Extreme that the default route next hop is shown as the ISP router interface, instead of the Extreme switch.

This works fine with IPv4, as expected.

Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
What does the config look like?  Are you using a loopback for the iBGP stuff?
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi Jeremy

Please see snapshot of BGP config. i-BGP is across switches A and B, for IPv4 and with the left most side application nodes, running BGP. Do we need IPv6 across switch A and B as well?

e-BGP is across switches and ISP routers.


Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Also, it is under a child VR.
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi Experts

Any assistance please on this? We have some time constraints on this.
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
Why are you using BGP for this?  Sounds like you should be using eBGP at the edge, and using OSPF to do route redistribution.  

A topology drawing with interfaces that are labeled would be helpful.  

Also, it depends on what you are doing with ipv6.  Do you have v6 routes that you are learning about via iBGP from your application stack or the other way around?  

I am assuming you are using BGP to advertise some public IP addresses and not do route selection (since you said you are only receiving a default route from your ISP.

I would run iBGP between both the Extreme 670s and another routing protocol between the applications.  
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,546 Points 10k badge 2x thumb
Are the Extreme BGP routers sending the route to the App? Is your BGP daemon on the server side receiving the route? Do you have some routing policy? What about ASN? No AS-Path loop there?
Photo of Sumanta Ghosh

Sumanta Ghosh

  • 458 Points 250 badge 2x thumb
Hi All

It got fixed by enabling IPv6 unicast next hop self. Normal next hop self only enables for IPv4, by default. For IPv6, it has to be enabled under address family.


configure bgp neighbor fd00:x.y.y::1 address-family ipv6-unicast next-hop-self

Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,414 Points 10k badge 2x thumb
Oh yes, I thought you did it, I miss read your snippet. It applies for anything, btw. IPv4 unicast is assumed by default, so we are generally not used to it, but yes, you have to specify the address-family. Good you found it.
Photo of Jeremy

Jeremy, Embassador

  • 9,788 Points 5k badge 2x thumb
Nice. I actually had that in my last reply but that that was to trivial. Anyway, that does make sense and glad it worked.