I/G/C/B/A-Series f/w 6.61.08.0013 Cannot Append a Config to Change Flowcontrol Status

  • 0
  • 1
  • Article
  • Updated 5 years ago
  • (Edited)
Article ID: 14983 

Products
I-Series, firmware 6.61.02.0007 through 6.61.08.0013
G-Series, firmware 6.61.02.0007 through 6.61.08.0013
C5-Series; firmware 6.61.02.0007 through 6.61.08.0013, 6.71.01.0067 through 6.71.02.0008
C3-Series, firmware 6.61.02.0007 through 6.61.08.0013
B5-Series; firmware 6.61.02.0007 through 6.61.08.0013, 6.71.01.0067 through 6.71.02.0008
B3-Series, firmware 6.61.02.0007 through 6.61.08.0013
A4-Series; firmware 6.61.02.0007 through 6.61.08.0013, 6.71.01.0067 through 6.71.02.0008 

Changes
Attempting to dynamically change the flowcontrol operational status of a unit/stack by means of the 'configure configs/<config-filename> append' command.
In this scenario, the device is running the (default) 'set flowcontrol enable' command and the append file contains the 'set flowcontrol disable' command - or vice versa. 

Symptoms
The command editor rejects the operation, with a CLI error message:
Not able to execute command 'set flowcontrol' with append option
Solution/Workaround
Upgrade to 6.61 firmware 6.61.09.0012 or higher.
Release notes state, in the 'Changes and Enhancements in 6.61.09.0012' section:
17116    Corrected the inability to append to a configuration file that has flow control disabled.

The restriction will now only apply while Advanced Buffer Mode (optimizes system buffer distribution for non-stacking single CoS queue operation) is enabled ('set system advancedbuffermode enable'). This is because while Advanced Buffer Mode is enabled, by design any flowcontrol change will reset not only the port link state but the entire system as well. Enabling and disabling Advanced Buffer Mode itself also by design resets the entire system. 

Also fixed as of C5/B5/A4-Series firmware 6.71.03.0025 (though not stated in release notes). 

Pre-upgrade workaround:
Do not use the 'append' option. The unit will reset onto the new configuration, entirely replacing the old configuration.
Photo of FAQ User

FAQ User, Official Rep

  • 13,620 Points 10k badge 2x thumb

Posted 5 years ago

  • 0
  • 1

There are no replies.

This conversation is no longer open for comments or replies.