Igmp snoop timers

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
Hello community,

I have a doubt about the igmp snoop time.
I`m using the extreme X350 with a IP QAM Harmonic who doesn`t send the igmp query frequently causing the IGMP group to drop.
There`s why I incresead the time of igmp, using configure igmp snooping timer 604800 604800 vlan Multicast-IPTV but, of course, the igmp group drop after that period.

Is there something else to do  ?  Any advices?


Thank you!
Photo of Julian Eble

Julian Eble

  • 1,394 Points 1k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Jarek

Jarek

  • 2,398 Points 2k badge 2x thumb
Hi

you can set igmp static group.

--
Jarek
Photo of EtherMAN

EtherMAN, Embassador

  • 7,200 Points 5k badge 2x thumb
could disable igmp snooping if you are not concerned about the amount of multicast traffic being generated by this service.  If this service is limited to a single vlan and a few ports then it should not be a problem just killing igmp snooping on that vlan... There have been some other threads about dealing with vlan based filtering of igmp if you search for them..  Best would be to get the IP QAM to update their software to send out valid joins at a reasonable interval.. I have seen many not so pretty things from IPTV and video related IP equipment where they become a challenge to deal with... Good luck 
Photo of Stephen Williams

Stephen Williams, Employee

  • 9,040 Points 5k badge 2x thumb
I agree with Jarek.  A static join will do the trick.
Photo of JS

JS, Employee

  • 630 Points 500 badge 2x thumb
Hi Julian,

Have you  configured an IP address on the vlan where your IP QAM Harmony resides ?

I could be wrong but you have increased the IGMP timers which would mean that your QAM Harmony either doesn't send IGMP membership report [or doesn't respond to IGMP membership queries] OR there is no IGMP querier on your network [periodically sending IGMP membership query]

Given the default IGMP query interval is 125s on an XOS switch and given it can/will be an IGMP querier  [without extra configuration], it looks like you don't have an IP address on your vlan....?

if no IP address is configured, leave all IGMP parameters with their default values ; simply configure an IP address on the vlan --> it should work.

if you have an IP address on the vlan interface, then I would start taking a packet capture.
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 13,648 Points 10k badge 2x thumb
I'd be on the "set a static group" side, dealing with QAM means you also want to control the groups. I know some ISP using static for "security" reasons, as well.