In need of some help.. Summit X450a-48t, Uplink not negotiating to 1000mbps

  • 0
  • 1
  • Problem
  • Updated 4 years ago
For some reason my switch is not showing my uplink at 1gbps. At first a few months ago when I setup my switch in the DC and they updated my port to 1 gig it went from showing the port at 100 to 1000, I had to take some time off and when they reconnected my hardware they put it on a 100mbps, I had it upgraded back 1 gig and they assured me that it is indeed running at 1000 but the switch is still showing 100. Any ideas?

Any help would be appreciated.. I am very new to working with Extreme switches and getting it setup to begin with was a bit of a pain but I finally got it with some help of looking through the forums and one of my friends helping me out. All servers were online and working, and the switch showed port 1 at 1000mbps, but now its only showing 100. I tried the following commands:

* X450a-48t.8 # configure ports 1 medium copper auto on speed 1000 duplex fullError: Medium specific configuration is not supported on non-combo port 1.
* X450a-48t.9 # configure ports 1 auto on speed 1000 duplex full

--

After that last command it froze, I had to have the support team in the DC reboot the switch for me, they are also VERY clueless on how to work an Extreme Networks switch so they are absolutely no help to me. I am going at this alone and want to setup everything correctly and with correct DDoS protection configuration settings. If someone can help It would be greatly appreciated. Maybe my entire configuration is wrong. I will paste it here:

--

* X450a-48t.4 # show config#
# Module devmgr configuration.
#
configure sys-recovery-level switch reset

#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-50
configure vr VR-Default add ports 1-50
configure vlan default delete ports 1-50
create vlan "lan"
create vlan "uplink"
disable port 2
disable port 27
disable port 28
disable port 29
disable port 30
disable port 31
disable port 32
disable port 49
disable port 50
configure vlan lan add ports 4, 6, 8, 10, 12, 14, 16, 18, 20, 22, 24, 26, 34, 36, 38, 40, 42, 44, 46, 48 untagged
configure vlan uplink add ports 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 21, 23, 25, 33, 35, 37, 39, 41, 43, 45, 47 untagged
configure vlan lan ipaddress 10.0.0.1 255.255.255.0
enable ipforwarding vlan lan
configure vlan uplink ipaddress 209.151.171.132 255.255.255.128
enable ipforwarding vlan uplink

#
# Module fdb configuration.
#

#
# Module rtmgr configuration.
#
configure iproute add default 10.0.0.1
configure iproute add default 209.151.171.131

#
# Module mcmgr configuration.
#

#
# Module aaa configuration.
#
configure account admin encrypted "jWzoOe$y6VS1n5gQTU.o4gJHIuFv1"
configure account user encrypted "jWz71o$weNTUwzg1kCcuPb7pec/i0"

#
# Module acl configuration.
#



configure access-list zone SYSTEM application NetLogin application-priority 3
configure access-list zone SYSTEM application HealthCheckLAG application-priority 4
configure access-list zone SYSTEM application IdentityManager application-priority 5
configure access-list zone SYSTEM application VMTracking application-priority 6

#
# Module bfd configuration.
#

#
# Module ces configuration.
#

#
# Module cfgmgr configuration.
#

#
# Module cna configuration.
#
configure cna-testplug scheduler vlan Default

#
# Module dosprotect configuration.
#
configure dos-protect interval 3

#
# Module dot1ag configuration.
#

#
# Module eaps configuration.
#

#
# Module edp configuration.
#

#
# Module elrp configuration.
#

#
# Module ems configuration.
#

#
# Module epm configuration.
#

#
# Module erps configuration.
#

#
# Module esrp configuration.
#

#
# Module ethoam configuration.
#

#
# Module etmon configuration.
#

#
# Module exsshd configuration.
#
enable ssh2

#
# Module hal configuration.
#

#
# Module idMgr configuration.
#
create ldap domain "Unknown" default
configure ldap domain "Unknown" base-dn none

#
# Module ipSecurity configuration.
#

#
# Module ipfix configuration.
#

#
# Module lldp configuration.
#

#
# Module mrp configuration.
#

#
# Module msdp configuration.
#

#
# Module netLogin configuration.
#

#
# Module netTools configuration.
#
configure bootprelay add 10.0.0.2 vr VR-Default
enable bootprelay vlan Default
enable bootprelay vlan lan
enable bootprelay vlan uplink

#
# Module ntp configuration.
#

#
# Module ospf configuration.
#
configure ospf vlan lan priority 0
configure ospf vlan uplink priority 0

#
# Module ospfv3 configuration.
#


#
# Module pim configuration.
#
configure pim register-checksum-to include-data

#
# Module poe configuration.
#

#
# Module rip configuration.
#

#
# Module ripng configuration.
#

#
# Module snmpMaster configuration.
#

#
# Module stp configuration.
#
configure mstp region 00049637361a
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
enable stpd s0 auto-bind vlan Default

#
# Module synce configuration.
#

#
# Module telnetd configuration.
#

#
# Module tftpd configuration.
#

#
# Module thttpd configuration.
#
enable web http

#
# Module vmt configuration.
#

#
# Module vrrp configuration.
#

#
# Module vsm configuration.
#

This is what was told to me on how to setup my switch by my friend and it seemed to do the job but I dont know why its not auto negotiating to 1000. Thanks in advance.
Photo of fame

fame

  • 132 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of fame

fame

  • 132 Points 100 badge 2x thumb
Here is some more information incase this helps:

X450a-48t.6 # show ports information detailPort:   1
        Virtual-router: VR-Default
        Type:           UTP
        Random Early drop:      Unsupported
        Admin state:    Enabled with  auto-speed sensing  auto-duplex
        Link State:     Active, 100Mbps, full-duplex
        Link Ups:       1        Last: Wed Aug 27 08:31:01 2014
        Link Downs:     0        Last: --

        VLAN cfg:
                 Name: uplink, Internal Tag = 4093, MAC-limit = No-limit, Virtual router:   VR-Default
        STP cfg:

        Protocol:
                 Name: uplink       Protocol: ANY      Match all protocols.
        Trunking:       Load sharing is not enabled.

        EDP:            Enabled
        ELSM:           Disabled
        Ethernet OAM:           Disabled
        Learning:       Enabled
        Unicast Flooding:       Enabled
        Multicast Flooding:     Enabled
        Broadcast Flooding:     Enabled
        Jumbo:          Disabled

        Flow Control:   Rx-Pause: Enabled       Tx-Pause: Disabled
        Priority Flow Control: Disabled
        Reflective Relay:       Disabled
        Link up/down SNMP trap filter setting:  Enabled
        Egress Port Rate:       No-limit
        Broadcast Rate:         No-limit
        Multicast Rate:         No-limit
        Unknown Dest Mac Rate:  No-limit
        QoS Profile:    None configured
        Ingress Rate Shaping :          Unsupported
        Ingress IPTOS Examination:      Disabled
        Ingress 802.1p Examination:     Enabled
        Ingress 802.1p Inner Exam:      Disabled
        Egress IPTOS Replacement:       Disabled
        Egress 802.1p Replacement:      Disabled
        NetLogin:                       Disabled
        NetLogin port mode:             Port based VLANs
        Smart redundancy:               Enabled
        Software redundant port:        Disabled
        IPFIX:   Disabled               Metering:  Ingress, All Packets, All Traffic
                IPv4 Flow Key Mask:     SIP: 255.255.255.255            DIP: 255.255.255.255
                IPv6 Flow Key Mask:     SIP: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
                                        DIP: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff

        auto-polarity:                  Enabled
        Shared packet buffer:           default
        VMAN CEP egress filtering:      Disabled
        Isolation:                      Off
        PTP Configured:                 Disabled
        Time-Stamping Mode:             None
        Synchronous Ethernet:           Unsupported
        Dynamic VLAN Uplink:            Disabled
        VM Tracking Dynamic VLANs:      Disabled
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
Without going through the configuration, based on personal experience: Check the configuration of the other end and the cabling.

- The other end may only support or 100 Mb full, or it is configured to do only 100 Mb.
- Old cabling - Cat.5 for example - may not support Gigabit Ethernet. Use Cat.6 or better instead. Also, the total link length is important - up to 100 metres from end to end are allowed.
Photo of fame

fame

  • 132 Points 100 badge 2x thumb
Hi, Thanks for your response. The cable is a Cat6. That I am sure of. I was there when it was originally setup and ran into my switch and it worked immediately and I was receiving the full 100mbps speeds, but now when I have plugged the Cat6 cable back in and they had told me that it is set for 1000mbps and not 100mbps but the switch isn't picking that speed up. I believe the error to be on their end but the one of the admins said it may be something with my switch which i am quite positive its not the switch. But it is indeed a Cat6 running into the port on my switch at the moment.
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
If they are talking about "set to 1000mbps", what do they mean? Fixed configuration saying "do 1000 MB full duplex at that port?" If so, they should set their port to auto negotiation without any speed or duplex definitions. After that, dis- and re-enabling the port on one side of the link should do the trick. (Based on the configuration above you are doing auto negotiation, which is good.)

May I ask what's connected on the other end? Perhaps a router, maybe even one from Cisco? Those Cisco routing guys tend to set fixed speed and duplex settings on their boxes... If they insist on fixed settings you woukd have to disable auto negotiation on your end:

configure ports 1 auto off speed 1000 duplex full
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
Robert has mentioned correct information. 

If still you faced this problem then create physical loopback(same cable on two different port of same switch) and check the speed. Please make sure that those two ports are not being part of same vlan.
Photo of Matt Tinonga

Matt Tinonga

  • 372 Points 250 badge 2x thumb
I would confirm that the cable is good end to end, all 4 pairs are need for 1000. I've seen were 1 pair does not make a connection dropping the connection to 100. Also check the RJ45 pins in the switch ports of each end, my not be making contact.
(Edited)
Photo of fame

fame

  • 132 Points 100 badge 2x thumb
Thanks for the responses everyone. @Robert, its connected to a Cisco router on the other end, I am more than sure because the DC is a bunch of Cisco junkies and have no idea how to configure or work any other switch except Cisco. If you ask me for a DC to not know how to work any other switch but Cisco and use the excuse saying "We are Cisco certified only" that makes for a poor DataCenter. But for the services and price I am paying I couldnt refuse although they are a bunch of idiots at the facility. They told me that had set the speed to 1000mbps on a Cat6 line but I had yet to see my switch auto negotiate to it.

For whatever reason, when I asked them to turn my services off for 2 months they decided to throw in a 100mbps line (even while all my power was down on my servers and nothing online at all as I was going through a few issues). When I had went back into the DC and reconfigured my servers and checked the switch and seen 100mbps I was like wtf is going on? So I asked and they said they did it temporarily and will upgrade back to a 1g port asap. I was told that was done but of course I am not getting the speeds and they insist that they have set it up. I am more than sure the error is on their end since I know there is nothing wrong with my switch.

I also tried what you suggested and this was the output I received:

X450a-48t.1 # configure ports 1 auto off speed 1000 duplex full
Error: Auto negotiation off is not supported on port 1 at 1G speed.

@Sumit, Thanks for your input as well. If they dont get the issue handled, I will take your advice and try that out the next time I go there which would probably be tomorrow since I cannot make it in there today.

@Matt I would assume that the cable is good end to end. It was a brand new fresh line ran into my switch when they first set it up. I was there configuring some of my servers at the time it was originally done and nothing should have been touched or gone wrong. But the only thing that was touched, as I mentioned earlier, is the original Cat6 cable. It was taken out and the original 100mbps line put back into port 1 of my switch. I had removed that line when I went back there and put back in the Cat6 line. I was going to run the 100mbps line into my remote management port like I had it before but I didnt want to run it in there without making sure they had me set back at 1Gbps.

Thanks again everyone for your responses, it is greatly appreciated. I have contacted them and let them know what was mentioned here, I am just waiting for there response. I will keep you guys updated on the status.
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
Alright then, for the Cisco guys, assuming that Gigabit Ethernet 1/0/1 is the interface you are connected to:

enable
configure terminal
interface GigabitEthernet1/0/1
shutdown
speed auto
duplex auto
no shutdown

This, along with a "configure ports 1 auto on" on your side, should do it. Except they have some specialities configured.

(Sorry guys, I'm also Cisco certified ;-))
Photo of fame

fame

  • 132 Points 100 badge 2x thumb
Everything is set and working now. @Robert, when I pasted them your response and emailed them, I was immediately disconnected from my servers, I reconnected and seen I was now receiving 1gbps on the port, followed by this email from one of the admins,

"Hi Mario,

We checked the switch configuration on our end, everything shows 1000Mb. We checked the physical cable to make sure it’s connected to the right port. We also reconnected cable to see if that would work, please check your port now. Re-enable the port on your switch , perhaps that will also help. It is 1000Mb full duplex on our side. You should be able to set it to that to match. Let me know how that goes. Are you sure that port on your switch supports 1000Mb?"

lol.. It worked out :) Thanks again Robert, and everyone else who responded.
Photo of fame

fame

  • 132 Points 100 badge 2x thumb
I just have 1 other question. Does anyone have a sample of what good a good DDoS configuration should look like? Or should I open up another ticket for this request? I wanted to add some DDoS configuration settings on the switch and make sure they are correct and working properly but am not quite sure how to set it 100%
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
Better open up a new thread with a descriptive topic, so that experts in that field are able to see and answer it.