invalid ssh key after config restore

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
Dear all.

ssh is not working after restore a previously saved config.

1. save config new.cfg
2. unconfigure switch all
3. use configuration new.cfg
4 reboot

The configuration is loaded successful and complete, but ssh is not working anymore. Connection error.

checking "show management" show me an invalid ssh key.

X460G2-24p-10G4.3 # show management

...
SSH access                       : Disabled (Key invalid, tcp port 22 vr all)
                                 : Secure-Mode    : Off
                                 : Access Profile : not set
SSH2 idle time                   : 60 minutes
...

I need to renew the key by "configure ssh2 key"

Any Idea how to fix it?

Thanks
Alex


Photo of aloeffle

aloeffle

  • 980 Points 500 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Alexandr P

Alexandr P, Embassador

  • 12,670 Points 10k badge 2x thumb
(Edited)
Photo of aloeffle

aloeffle

  • 980 Points 500 badge 2x thumb
Hi Alexandr.

thanks for your fast feedback.

This is bad...
I will talk to GTAC about this.

regards
Alex
Photo of Steven Lin

Steven Lin, Employee

  • 2,330 Points 2k badge 2x thumb
Hello Alex,
If your switch is running at 16.2 or 21.3, then it was possible trigger below CR.There is workaround from below article if you really hit it.

https://gtacknowledge.extremenetworks.com/articles/Solution/Switch-gets-into-reboot-loop-if-configur...
Photo of aloeffle

aloeffle

  • 980 Points 500 badge 2x thumb

Hi Steven.

we run 22.2.x on all of our devices...

thx

Alex

Photo of Ram

Ram, Employee

  • 1,450 Points 1k badge 2x thumb
Did try to do ‘run update’ and ‘restart process thttpd’?
Photo of aloeffle

aloeffle

  • 980 Points 500 badge 2x thumb

Hi Ram.

to make the ssh key valid again, I need to execute "configure ssh2 key".

Then a new key is generated and ssh is working again. The problem is, that this can not be done remote. I need onsite access.

regards

Alex


(Edited)
Photo of Peter Chang

Peter Chang

  • 394 Points 250 badge 2x thumb
We had the ssh key go invalid on us after a config restore as well. Thanks, as finding this thread helped us. Regenerating the key fixed this issue.