Is there a way to manage port poe on and Exos switch through NetSight

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
We have a customer who wants to reset inline-power on an Exos port using NetSight. I was trying to create a column in a FlexView and thought I found the right mib.

extremePethPortResetPower OBJECT-TYPE          SYNTAX                     INTEGER { set(1), clear(2) }
          MAX-ACCESS read-write
          STATUS current
          DESCRIPTION
                "Resets the power on the port. Reading always returns clear(2)"
          ::= { extremePethPsePortEntry 5 }

I have tried this on several code versions including 16.1 but always get the red X. 
NetSight is 6.3.0.162 and 6.3.0.168 same results on both
Any help would be greatly appreciated.
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,650 Points 5k badge 2x thumb
Did you try setting it using Mibtools first, to take the complexity of Flexviews out of it?
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb
I get an output from the mib query using the mib tool but did not know disabling the port from there would be possible.
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,650 Points 5k badge 2x thumb
You should be able to set to the 1 or 2 value above, if you get a set failed, make sure you have write credentials set correctly.
You could try changing sysLocation or sysLocation for instance, a very common writeable MIB. That would be a baseline
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb
Ok so I found that and am able to get it to work through the mib tool useing 
extremePethPortResetPower=1.3.6.1.4.1.1916.1.27.2.1.1.5
set powers it down and clear powers it up. 

In the flexview I do not even get the same output. In the mib tool it shows clear in the flexview it shows N/A

Here is a link to the tpl file
https://www.dropbox.com/s/wo9w3klwdfhgims/POE%20Status%203.tpl?dl=0

It seems like there has to be a check box or something that is making the FlexView send the information differently than the mib tool is.

Thanks for your help
Photo of Alexandr P

Alexandr P, Embassador

  • 12,670 Points 10k badge 2x thumb
Hello, David!

Also Extreme have xkit portal wich have many usefull apps.
For example for PoE - https://xkit.extremenetworks.com/app/search?keyword=PoE

Thank you!
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb
Thank you

This is very interesting information and I will investigate deployment of this at our office for testing.

Unfortunately this does not help with the issue I am currently working on. Our customer has some problem cameras that require a reboot from time to time. That is why I am trying to get this flexview to work.

But again thanks for the information I look forward to investigating it further.  
Photo of Drew C.

Drew C., Community Manager

  • 40,206 Points 20k badge 2x thumb
That xkit site may be decommissioned soon.  All of the content has been migrated to gitHub.
https://github.com/extremenetworks
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,650 Points 5k badge 2x thumb
David, can you send in a chunk of screen capture to show me what your seeing and doing? And also what specific switch your using it against.
Thanks!
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb


Current testing is on a 450, we are in the process of upgrading the network to 460-G2's, I will get you a screen shot from the Flexview as soon as possible. One of the most confusing or perhaps revealing things is that the which displays "clear" above displays "NA"  in the FlexView.

Thanks
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,650 Points 5k badge 2x thumb
David, 
Try this instead. It may not work, but try to save off as .tpl and load it. It will momentarily set, then return to clear. It should reset your port.
We have built this already.


    XOS PoE Port
        com.ets.nac.tables.TbModel
        ReqID
           
            OID::ReqID:::SNMP::ReqID
        IP Address
           
            OID::IP Address:::SNMP::IP Address
        Instance
           
            OID::Instance:::SNMP::Instance
        PortOperatorLimit
           
            OID::extremePethPortOperatorLimit:::SNMP::SNMPW;false;2;3;true;false;4;2;0;0;0;0;0
        PortReservedBudget
           
            OID::extremePethPortReservedBudget:::SNMP::SNMPW;false;2;4;true;false;4;2;0;0;0;0;0
        PortViolationPrecedence
           
            OID::extremePethPortViolationPrecedence:::SNMP::SNMPW;false;2;5;true;false;4;2;0;0;0;0;0
        PortClearFault
           
            OID::extremePethPortClearFault:::SNMP::SNMPW;false;2;6;true;false;4;2;0;0;0;0;0
        PortResetPower
           
            OID::extremePethPortResetPower:::SNMP::SNMPW;false;2;7;true;false;4;2;0;0;0;0;0
        PortMeasuredPower
           
            OID::extremePethPortMeasuredPower:::SNMP::SNMP;false;66;8;false;false;4;2;0;0;0;0;0
       
        TBLHASH::::TBLHDR::0;0;true;30;None;V.0.3.3.0;0;0;106
(Edited)
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb
I tried saving this as a tpl file but NetSight wont open it. Can you post a link to the tpl file or tell me what I am doing wrong?

I have to be very close. Right?
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,650 Points 5k badge 2x thumb
David,  A coworker created them previously. I sent you them directly. Let me know if you get them. We are assuming you want the port one. It should 'set' then go back to clear to reboot the PoE device.
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb
Mike,

Thank you very much for the files the are very helpful. 
My problem was that I was trying to add a column to a flexview that was looking at interfaces instead of instances. Does that make sense? If not I can attach a screen shot.
I am working with this new information to try and give the customer exactly what they want. Is it possible to add a user defined column?
Photo of Mike Thomas

Mike Thomas, Employee - GTAC - NMS

  • 7,650 Points 5k badge 2x thumb
You should be able to customize those Flexviews and "save as" to something else. I think you know well how to do that based on the previous flexview you created. So I would modify as needed and test.
But in general, to add a column, you would open flexview->Properties->Columns->Find OID->Click New 
See below - #2 and #4 are outputs of arrows #1 and then #3.
You can then drag and drop those columns around till it's visually pleasing.
Photo of David Coglianese

David Coglianese, Embassador

  • 7,208 Points 5k badge 2x thumb
Yes,

I have that procedure down. All I really need though to make the customer happy is a column they can type in, like the User Data columns on the properties device tab.
So I just need to add a column that does not have a mib associated with it.