lacp load balancing with mpls

  • 0
  • 1
  • Problem
  • Updated 3 years ago
I've experience a problem where i have a topology networking  in ring and all switch is set up mpls with lacp.
So the problem is the lacp doesn't work in mode load balance with mpls, other words, when i put 2 ports (port 1 and port 2)interface in mode sharing with load balance l3 or l3_l4, and through vpls on this sharing, it just sent traffic for only one port, in this case port 2, and the port 1 there isn't traffic, i see only when port 2 stay in mode down.
however i tried changed to load balance mode l2 and the same result.

So, anyone expirence for this problem?
Photo of welisson

welisson

  • 908 Points 500 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Grosjean, Stephane

Grosjean, Stephane, Employee

  • 12,582 Points 10k badge 2x thumb
Hi,
Hashing is done differently with MPLS. This is why load-balancing needs a specific attention. Starting with EXOS 15.4.1, Extreme has introduced LSP sharing for VPLS, and is supported on most MPLS-capable platforms. This gives a very good result when it comes to load-balance traffic in a LAG or through ECMP.

You should have a look at the Concepts Guide (User Guide) of this version (or later) to see how it works and on what platforms, to see if it fits your needs.
(Edited)
Photo of PARTHIBAN CHINNAYA

PARTHIBAN CHINNAYA, Alum

  • 4,362 Points 4k badge 2x thumb
For lsp sharing in vpls to work
Please use 15.4.1.3 latest patch.
There was a bug when this feature was introduced
Photo of welisson

welisson

  • 908 Points 500 badge 2x thumb
good news but the same time i'm a little disappointed, but i will update these switch and as soonest i come back report the result.

tks for time.
Photo of welisson

welisson

  • 908 Points 500 badge 2x thumb
Hi Guys,

Are you using this firmware to distribute traffic over sharing with lsp dynamic or static?

tks