LAG Cisco 2960 to Summit x480

  • 0
  • 1
  • Question
  • Updated 4 years ago
I am having trouble setting up an LACP LAG group between a cisco switch (2960g) and a Summit x460, can someone provide a sample config that has worked between these two OS's I have tried and been failing miserably. I have been successful at Cisco - Cisco LACP and Summit - Summit LACP but not a mix of the two.
Photo of Tyler Bartel

Tyler Bartel

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Sumit Tokle

Sumit Tokle, Alum

  • 5,738 Points 5k badge 2x thumb
There is no special configuration required between Cisco-----Extreme when you want to configure LAG.

Many times I have seen that LAG won't come up, you need to go to virtual interface and execute command no shut on Cisco to start negotiating LACP PDU.

I would like you to execute below command on Extreme device and check if LACP PDU's are being sent out from Extreme switch. Below command will provide RX/TX LACP pdu counter information.

"show lacp counter"

If possible check if they are able to from sharing using the static algorithm instead of LACP.

I hope this helps you,

Sumit
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
On Cisco side:

interface Port-channel 1
duplex auto
speed auto
exit
interface range GigabitEthernet 1/0/1 - 4
channel-group 1 mode active
no shutdown

On Extreme side:

enable sharing 1 grouping 1,2 lacp

This should do it. If not, as Sumit said, dis- and re-enable the ports on either side. And _wait_ - negotiating everything may take quite some time.

Edit: At the Cisco end the physical ports should be set to "speed auto" and "duplex auto" as well.
(Edited)
Photo of Tyler Bartel

Tyler Bartel

  • 100 Points 100 badge 2x thumb
thanks for the replies, I have tried this and after the config Robert provided the ports synched up but the cisco switch put the Po1 and gigE ports into err-disable with the messages:

channel-misconfig (STP) error detected on Gi0/47, putting Gi0/47 in err-disable state
channel-misconfig (STP) error detected on Gi0/48, putting Gi0/48 in err-disable state

strangely enough i dont even have a cable connected to the Gi0/48 port yet

Any thoughts on why Spanning tree would indicate a misconfiguration?
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
My guess would be that the STP configuration of two physical ports (maybe take the port channel into account as well) have different STP settings - whatever those may be. If I remember correctly, physical ports have to have the same basic configuration on a Cisco if you want to put them in a port channel.

Fastest solution: "show run" and compare the settings of all three (two physical, one virtual) ports.
Hello friends, i am actually trying to do this same thing right now between a Cisco 2960 and a Summit x450x-48t. The Cisco Config side looks like this :

interface Port-channel1

description Trunk to Eng Extreme Switch

switchport trunk allowed vlan 113,560,561

switchport mode trunk

 

interface FastEthernet0/47

description Trunk to Eng Extreme Switch

switchport trunk allowed vlan 113,560,561

switchport mode trunk

shutdown

channel-group 1 mode active

 

interface FastEthernet0/48

description Trunk to Eng Extreme Switch

switchport trunk allowed vlan 113,560,561

switchport mode trunk

shutdown

channel-group 1 mode active

I need to connect ports 47,48 to the trunk etherchannel on the Cisco. then i will have ports on the extreme assigned to the 3 vlans as i need them.
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
enable sharing 47 grouping 47,48 lacp
configure vlan name-of-113 add ports 47 tagged
configure vlan name-of-560 add ports 47 tagged
configure vlan name-of-561 add ports 47 tagged

Awesome Robert! i cant believe it is that simple. I cant thank you enough. I am comfortable with Cisco stuff, but i have to have this config ready tomm. morming so you are right on time.Do i not have to touch STP settings at all? this is an edge switch where i am simply giving my RnD dept more ports for deployments and such. There will be no more switches connected to this switch. I was confused about whether to make port based vlans or just tag the ports? in those commands am i supposed to specify all the ports that i want to participate in that respective vlan?


or do i add the ports on a seperate command. i know how to do it i just dont know wether to use port-based or just tags.
Photo of rbrt_weiler

rbrt_weiler

  • 834 Points 500 badge 2x thumb
STP is disabled by default on any Extreme switch, so do not expect any problems. If you want/require loop protection on Extreme I recommend reading about ELRP.

Regarding the VLAN question: In ExtremeXOS, VLANs are not added to ports, instead ports are added to VLANs. The command above would enable the Extreme switch to "get" all of the VLANs on one single port, hence the keyword "tagged". If you want to configure what Cisco calls access ports it's a simple

configure vlan name-of-vlan add ports 3 untagged

This also works with port ranges like "1-4,8,10-11". Should you get an error message that a port is aleready assigned to a VLAN you can delete the old assignment via

configure vlan name-of-old-vlan delete ports 3

For more information, please refer to the Concepts Guide and/or Command Reference Guide for your specific ExtremeXOS release.
makes perfect sense ! thank you!
Photo of Tyler Bartel

Tyler Bartel

  • 100 Points 100 badge 2x thumb
I managed to bypass the STP configuration error with some further research on the error. for the benefit of all, here are my two physical port configs and the portchannel config, it seems to be working fine but I have not added the second physical link to the LAG:

interface GigabitEthernet0/47
switchport trunk native vlan 999
switchport mode trunk
switchport nonegotiate
channel-group 1 mode passive
spanning-tree portfast trunk
end

interface GigabitEthernet0/48
switchport trunk native vlan 999
switchport mode trunk
switchport nonegotiate
channel-group 1 mode passive
spanning-tree portfast trunk
end

interface Port-channel1
switchport trunk native vlan 999
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
spanning-tree bpdufilter enable
spanning-tree bpduguard disable
spanning-tree link-type shared
end

Tyler