LAG going down

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
I'm running into an issue where my LAG is going down but nothing is jumping out at me. I've got an x450 acting as a aggregate layer on the floors with Dell 6248 models as the edge devices for the clients. Been working fine for the last 4 years, nothing has been upgraded recently, but recently am running into this issue. I'm hoping to confirm some things on the XOS side.
model: x450 / rev. 15.3.1.4

enable sharing 1 grouping 1-2, 17-18 algorithm address-based L2 lacp

09/28/2015 07:59:46.68 <Info:LACP.RemPortFromAggr> Remove port 17 from aggregator
09/28/2015 07:56:49.80 <Info:LACP.RemPortFromAggr> Remove port 2 from aggregator
09/28/2015 07:55:16.80 <Info:LACP.RemPortFromAggr> Remove port 1 from aggregator
09/28/2015 07:38:18.91 <Info:LACP.RemPortFromAggr> Remove port 18 from aggregator

So all I see in the log is that the ports are being removed from the LAG. The ports themselves seem to remain up as if I disable the LAG on the Dell side, I then see the ports going down on the x450. If it were spanning-tree disabling them, I should see some sort of message about that, right?

-Is there a command that I can use to get the ports to be re-added back to the LAG or possibly disable/enable the LAG?

-Are there any additional logging that I might be able to enable that may give me more details?

TIA,
-DarkSide
Photo of DarkSide

DarkSide

  • 70 Points
  • ???

Posted 3 years ago

  • 0
  • 1
Photo of Hernandez, Joshua

Hernandez, Joshua, Employee

  • 1,564 Points 1k badge 2x thumb
Ed,

When using the LACP protocol at the end of the sharing command you are telling the switch to send LACP PDU health checks and expect to receive them.  However if the remote side is not sending them the X450 will not bring the ports up in the LAG.  They are added dynamically with LACP as they send and receive the PDU health check packets.

Verify that the Dell side is sending LACP PDU health checks.  If it is not, change it to use the LACP protocol.  However if it cannot, you can change the X450 to act as a static (non-LACP) LAG by issuing the same command you have above without the LACP keyword. 

This will tell the switch not expect to send or receive LACP PDU health checks in order to bring the ports up into the LAG.
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Hi 

Following article could help you to identify if the LACP PDUs are received from the Dell switch. 

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-verify-if-the-LACP-PDUs-are-received-from-the-peer-device/
(Edited)