LAG Master Config and Master Current are different

  • 0
  • 1
  • Question
  • Updated 4 weeks ago
  • Answered
Hi 

Have a pair of switches joined together via a LAG but the Config Master and the Current Master are different. I'm not sure why this is, or how to correct it, although I don't think its specifically doing any harm.

Here is currently how it looks:

Core1.1 # show sharing

Load Sharing Monitor
Config    Current Agg     Min    Ld Share  Flags Ld Share  Agg Link  Link Up
Master    Master  Control Active Algorithm       Group     Mbr State Transitions
================================================================================
    24     21     LACP       1    L3_L4     A     21        Y     A       1
                                  L3_L4           22        Y     A       1
                                  L3_L4           23        Y     A       1
                                  L3_L4           24        Y     A       1
================================================================================

enable sharing 24 grouping 21-24 algorithm address-based L3_L4 lacp

Core2.1 # show sharing

Load Sharing Monitor
Config    Current Agg     Min    Ld Share  Flags Ld Share  Agg Link  Link Up
Master    Master  Control Active Algorithm       Group     Mbr State Transitions
================================================================================
    24     21     LACP       1    L3_L4     A     21        Y     A       1
                                  L3_L4           22        Y     A       1
                                  L3_L4           23        Y     A       1
                                  L3_L4           24        Y     A       3
================================================================================

enable sharing 24 grouping 21-24 algorithm address-based L3_L4 lacp

Maybe this this is related to the LACP negotiation, or the way the ports come up - although I've not come across this before and for peace of mind rather it was right way around.

Perhaps I just need to shut them down and bring them back in the order I would like?

The switches are X440 G1's and running firmware version 16.2.3.5-patch1-3.

Many thanks in advance.
Photo of Martin Flammia

Martin Flammia

  • 5,368 Points 5k badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Sushruth Sathyamurthy

Sushruth Sathyamurthy, Employee

  • 486 Points 250 badge 2x thumb
Hi Martin, 

To my understanding, although a higher port number is configured, the lower port number will take up mastership in LAG.
Photo of Martin Flammia

Martin Flammia

  • 5,368 Points 5k badge 2x thumb
Thanks Sushruth.