Loop prevention on LAN

  • 0
  • 2
  • Question
  • Updated 2 years ago
  • Answered
Our current network configuration, is only running ESRP (active/pasive) no stp or mstp, I'll like to implement some loop prevention configuration. Just today I had an issue in one switch that loose the uplink to the Primary Core, this turn into a failover to the secondary core, and it appear the issue was some kind of loop in a communication closet (I unplugged communication link in the whole closet). What do you suggest, do you think ELRP might help me? Thanks 
Photo of Karina Del Moral

Karina Del Moral

  • 804 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 2
Photo of Vellachery, Sumeesh

Vellachery, Sumeesh, Employee

  • 3,288 Points 3k badge 2x thumb
Karina,

Yes, we could configure ELRP to detect the loop. I have included an KB Article for your reference below:-

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-ELRP-to-disable-ports
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
Yes, ELRP will provide the L2 edge loop protection that you are looking for.  It works fantastic and is easy to configure.  You need to configure it per port in each vlan and can use options to log, log-and-trap and disable port for a duration or permanently so you can intervene. Check out the options here in the documentation:

http://documentation.extremenetworks.com/exos/EXOS_All/Troubleshooting/t_configure-standalone-elrp.s... 
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,638 Points 3k badge 2x thumb

I use  the vlan default for it.I configure all ports in vlan default tagged, except  the uplinks.

Reason: If someone connects a cable in to ports that belongs to different vlan's it will be also noticed.

Photo of Karina Del Moral

Karina Del Moral

  • 754 Points 500 badge 2x thumb
But only for the ELRP or all your port are in vlan default?
Photo of Johan Hendrikx

Johan Hendrikx

  • 3,638 Points 3k badge 2x thumb
Yes, only for ELRP
Photo of Karina Del Moral

Karina Del Moral

  • 754 Points 500 badge 2x thumb
So you enable the ELRP on the Default and tag the ports you want to monitor for LOOPS excluded the uplinks, correct?
Photo of Karina Del Moral

Karina Del Moral

  • 754 Points 500 badge 2x thumb
Johan, I'm testing the configuration using the default vlan on stack, It works great, just testing the log part, now, I'm checking the documentation to know if it is possible to block the port and how to do it.
Photo of Karina Del Moral

Karina Del Moral

  • 804 Points 500 badge 2x thumb
Thanks, Our Cores are XOS, but I still have some Extremeware Edge switches, the ELRP is configure in each Edge switch, correct?
Photo of Bill Stritzinger

Bill Stritzinger, Alum

  • 6,036 Points 5k badge 2x thumb
ELRP is on Extremeware too, the link to the documentation is here under the archives:

http://www.extremenetworks.com/support/documentation-archives

The configuration is very similar.
Photo of Karina Del Moral

Karina Del Moral

  • 804 Points 500 badge 2x thumb
Also, when this happen on the server level one of the servers that is running SQL it show this error "Cluster IP address resource 'SQL IP Address (SMTMSSQL) cannot be brought online because a duplicate IP address  'ipofheserver' was detected on the network. Please ensure ll IP addresses are unique.

On the Cores, there was no ESRP aware flush warning message, only the link down, but on the switch with the issue it did show the esrp warning, I'm not sure if it was so fast that's why... but you know if we need to do some special configuration for servers?

All of my VLAN's are in one failover domain, will it help if share info from my core configuration?
Photo of Drew C.

Drew C., Community Manager

  • 38,566 Points 20k badge 2x thumb
This is a different issue than loop prevention mechanisms. Moving this to a new thread will help get better attention.

Please reference the new conversation here: ESRP and failover scenarios