loss of wlan connection after several minutes

  • 1
  • 2
  • Problem
  • Updated 7 months ago
  • Solved
Hi

I have a vx9000 controller with several rfdomain and several wireless networks.

The intermec terminals connected to these wireless networks lose the connection after being unused for several minutes.

Is there any configuration in the controller part to eliminate these connection losses?


Thanks.
Photo of Jose_LV

Jose_LV

  • 1,274 Points 1k badge 2x thumb

Posted 7 months ago

  • 1
  • 2
Photo of Andrew Webster

Andrew Webster

  • 1,878 Points 1k badge 2x thumb
When mobile computers sleep for long periods of time, they can potentially loose connection with the wireless network.
By default, a  WLAN has a client inactivity timeout of 30 minutes.   Check that this value hasn't been changed shorter on the controller, or longer on the mobile device.

 wireless-client inactivity-timeout 1800
Photo of Jose_LV

Jose_LV

  • 1,274 Points 1k badge 2x thumb
Hi Andrew.

Effectively this parameter is configured with the default values of 30 minutes. I will configure it with the maximum value of 24 hours. I understand that for the part of the controller there is no other parameter to configure? the wireless networks are wpa2 and wep, there is no radius.

Photo of Andrew Webster

Andrew Webster

  • 1,878 Points 1k badge 2x thumb
Interesting that the devices are still timing out...
I don't recommend setting the timeout to 24 hours, as this could potentially consume a lot of system resources if you have many devices coming and going from the network.
Several factors could be at play.
  • Client isn't configured in power save mode.  Make sure it is PSP mode.  PSP mode clients inform the WLAN that they will be sleeping. 
  • Smart-rf is making changes to channel/power and is not aware of sleeping clients.
  • Smart off channel scanning is taking too long and/or is not client aware.
Photo of Jose_LV

Jose_LV

  • 1,274 Points 1k badge 2x thumb

Hi Andrew
I update information
Clients are disconnected from the wireless network when entering standby mode and when they wake up they reconnect ok to the wireless network automatically.
The problem is the program that is running, it is a connection by telnet against a server. The program when the connection is lost is frozen, logically. But previously this connection was maintained. Is there any configuration on the part of the driver to configure this behavior?

This problem has arisen as a result of migrating from a rfs to a vx.



Thanks
Photo of Christoph S.

Christoph S., Employee

  • 3,450 Points 3k badge 2x thumb
Hello Jose,

Make sure that stateful-packet-inspection-l2 is disabled in the firewall policy. 

Have you applied the best practices firewall policy?

What is the best practice firewall policy for WiNG devices and how to apply it?

On the other hand, this is what we used to do on the Motorola/Zebra terminals when using Wavelink TelnetCe, not sure if it applies to the Intermec devices, but worth having a look at:

MOBILEUNIT SESSION TIMES OUT AFTER 10 MINS OF INACTIVITY:

Solution: 

1- On the config manager go to Emulations Parameters >> Emulation >>Network, and disable TCP Keep Alive and change Use Timing Mark Heartbeat to NO. 

2- Check how long it takes for the session to actually time out and convert timeinto seconds. Under Emulation Parameters >> Emulation >> Common>> Keep Session active interval set the time to a lower number than theactual session time out number you previously noted down. This will tell theunit to send out a ping message at specified time.

 3- Set the Keep Session Active key. Select a key that does not trigger any eventon the host side. Obtain the hex value of the key and place it in the KeepSession Active field. Once the specified time is up, the unit will send the keyover to the host telling it that the client is still active. The key should nottrigger any event since its invalid but might trigger a error message. This hasto be tested to make sure that no issues arise.

 Thepreferred method would be to use the refresh key (F7). Obtain value of refreshkey and place in Keep Session Active field.

Thank you,

Chris
(Edited)
Photo of Jose_LV

Jose_LV

  • 1,274 Points 1k badge 2x thumb
Hi Chistoph
I have applied the settings of the article of best practices firewall policy and I have disabled the energy saving in the wireless cards of handheld devices and everything has started to work ok.
Thank you very much Chistoph