migration of C4110-2 and AP3620 to Hardware Controller C5210 and AP3935i...

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hello Community,

we have to do a smooth migration with Hardware Controller C4110-2 Firmware Version 9.21.01 and Access Points AP3620 in a Failover cluster to Hardware Controller C5210 and Access Points AP3935i.

Has someone experience with such kind of migration? Is it just an configuration export and import job?

Thank you in advance.

best regards
Ben
Photo of Taylor Durden

Taylor Durden

  • 100 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Umut Aydin

Umut Aydin, Escalation Support Engineer

  • 2,300 Points 2k badge 2x thumb
Hi Ben,

since AP36xx doesn't support V10 the only possibility is use 2 different v10 pair for the new AP's and put the old Controllers and the new Controller in a mobility domain.


There is no tool where you can push the old config from different EWC  to new different type Controllers.

Regards
Umut
Photo of Rajesh Jeevendran

Rajesh Jeevendran, Employee

  • 354 Points 250 badge 2x thumb
Hi Aydin

Correct me if I am wrong.I see this as overhead though.

How about upgrading both C4210 and C5210 to code 9.21.16 [common code that is supported by both controller and AP36XX but NOT by 3935]

Then having them in HA pair should help sync configuration from C4210 to C5210.

Move the AP36XX to C5210. once the setup good.Remove C5210 from HA pair,upgrade only the C5210 to latest code to support 3935.

AP39XX does not support code 9.X
AP36XX does not support code 10.x

I have not tested the above,please consider the license factor and Physical port/VLAN configuration.

Regards
Rajesh J
Photo of Umut Aydin

Umut Aydin, Escalation Support Engineer

  • 2,300 Points 2k badge 2x thumb
Hi Rajesh,

not all settings will be synced.
The rest need to be done manually.

Or you can do it like here
https://gtacknowledge.extremenetworks.com/articles/How_To/Wireless-controller-replacement-different-...

but also in this way you have adjust your config manually.


Regards

Umut
Photo of Taylor Durden

Taylor Durden

  • 100 Points 100 badge 2x thumb
Okay, that sounds like an adventure :)
Photo of Taylor Durden

Taylor Durden

  • 100 Points 100 badge 2x thumb
Okay, i have an update for you.
We have received our controllers and we tried to downgrade the firmware...with the following result:

Error: Cannot upgrade with AC-MV-09.21.16.0013-1.rue
Output:
Running New System Upgrade Preparation script
prepareu was extracted from /mnt/rescue/root/AC-MV-09.21.16.0013-1.rue file:
-rw-r--r-- 1 admin chantry_admin 121M Mar 16 09:13 /mnt/rescue/root/AC-MV-09.21.16.0013-1.rue
OS_STRING: OS-10_11_2-0
Major Release: 10
Error! Upgrade is not supported from Major Release: 10

Failed to start full system upgrade: check upgrade parameters


What we have to do now?

BR
Ben
Photo of Nathiya Munuswamy

Nathiya Munuswamy, Employee

  • 1,706 Points 1k badge 2x thumb
Hi Ben,

Are you downgrading firmware from V10 to V9?

https://gtacknowledge.extremenetworks.com/articles/Solution/Cannot-downgrade-WS-C35-from-V10-to-V9



Regards,
Nathiya M
Photo of Umut Aydin

Umut Aydin, Escalation Support Engineer

  • 2,300 Points 2k badge 2x thumb
Hi,

you can take every rescue image 9.x.x. with the certain Controller type.
You need this in order to get down to v9.xx and than you can downgrade or upgrade like always.

Rescue image will have also the config .
If it's not your rescue image you need set the controller to factory default before you maybe start to re-build the config.

After this you need install your saved config on to this controller.

Regards
Umut Aydin