MLAG+VRRP is not works properly

  • 0
  • 1
  • Problem
  • Updated 4 months ago
  • Solved
Hello, community!

I have some trouble in work two X690 like core switches, First is HQ-690, second is TR-690.
They are MLAG-peers, VRRP-peers.

We have VLAN 100, HQ-690 has ip 192.168.100.253, TR-690 has ip 192.168.100.252, VIP is 192.168.100.254.
MLAG VLAN has tag 2000, HQ-690 has ip 172.16.0.1/30, TR-690 has ip 172.16.0.2/30.

Then the problem:
When I connecting to HQ-690 via 192.168.100.253 through telnet, it has greate delays for inputed commands or close connection at all.
When I connecting to TR-690 via 192.168.100.252 through telnet, it has no delays. Then I connecting from TR-690 to HQ-690 via 172.16.0.1. It has no delays too.

Another devices in VLAN 100 has the same delays in work.

Both switches has the same EXOS  22.4.1.4 patch1-2

Config of HQ-690:
 Module vrrp configuration.
#
create vrrp vlan VLAN_0099 vrid 100
configure vrrp vlan VLAN_0099 vrid 100 priority 200
create vrrp vlan VLAN_0095 vrid 100
configure vrrp vlan VLAN_0095 vrid 100 priority 200
create vrrp vlan VLAN_0100 vrid 100
configure vrrp vlan VLAN_0100 vrid 100 priority 200
create vrrp vlan VLAN_0101 vrid 100
configure vrrp vlan VLAN_0101 vrid 100 priority 200
create vrrp vlan VLAN_0103 vrid 100
configure vrrp vlan VLAN_0103 vrid 100 priority 200
create vrrp vlan VLAN_0105 vrid 100
configure vrrp vlan VLAN_0105 vrid 100 priority 200
create vrrp vlan VLAN_0106 vrid 100
configure vrrp vlan VLAN_0106 vrid 100 priority 200
create vrrp vlan VLAN_0210 vrid 100
configure vrrp vlan VLAN_0210 vrid 100 priority 200
create vrrp vlan VLAN_0114 vrid 100
configure vrrp vlan VLAN_0114 vrid 100 priority 200
configure vrrp vlan VLAN_0099 vrid 100 add 192.168.99.254
configure vrrp vlan VLAN_0095 vrid 100 add 192.168.95.254
configure vrrp vlan VLAN_0100 vrid 100 add 192.168.100.254
configure vrrp vlan VLAN_0101 vrid 100 add 192.168.102.254
configure vrrp vlan VLAN_0101 vrid 100 add 192.168.101.254
configure vrrp vlan VLAN_0103 vrid 100 add 192.168.104.254
configure vrrp vlan VLAN_0103 vrid 100 add 192.168.103.254
configure vrrp vlan VLAN_0105 vrid 100 add 192.168.105.254
configure vrrp vlan VLAN_0106 vrid 100 add 192.168.106.254
configure vrrp vlan VLAN_0210 vrid 100 add 192.168.210.254
configure vrrp vlan VLAN_0114 vrid 100 add 192.168.114.254
enable vrrp vlan VLAN_0099 vrid 100
enable vrrp vlan VLAN_0095 vrid 100
enable vrrp vlan VLAN_0100 vrid 100
enable vrrp vlan VLAN_0101 vrid 100
enable vrrp vlan VLAN_0103 vrid 100
enable vrrp vlan VLAN_0105 vrid 100
enable vrrp vlan VLAN_0106 vrid 100
enable vrrp vlan VLAN_0210 vrid 100
enable vrrp vlan VLAN_0114 vrid 100

#
# Module vsm configuration.
#
create mlag peer "TR-690"
configure mlag peer "TR-690" ipaddress 172.16.0.2 vr VR-Default
enable mlag port 11 peer "TR-690" id 6
enable mlag port 12 peer "TR-690" id 7
enable mlag port 22 peer "TR-690" id 2
enable mlag port 23 peer "TR-690" id 5
enable mlag port 31 peer "TR-690" id 1
enable mlag port 47 peer "TR-690" id 4
enable mlag port 48 peer "TR-690" id 3
Conf of TR-690:

#
# Module vrrp configuration.
#
create vrrp vlan VLAN_0099 vrid 100
create vrrp vlan VLAN_0095 vrid 100
create vrrp vlan VLAN_0100 vrid 100
create vrrp vlan VLAN_0101 vrid 100
create vrrp vlan VLAN_0103 vrid 100
create vrrp vlan VLAN_0105 vrid 100
create vrrp vlan VLAN_0106 vrid 100
create vrrp vlan VLAN_0210 vrid 100
create vrrp vlan VLAN_0114 vrid 100
configure vrrp vlan VLAN_0099 vrid 100 add 192.168.99.254
configure vrrp vlan VLAN_0095 vrid 100 add 192.168.95.254
configure vrrp vlan VLAN_0100 vrid 100 add 192.168.100.254
configure vrrp vlan VLAN_0101 vrid 100 add 192.168.102.254
configure vrrp vlan VLAN_0101 vrid 100 add 192.168.101.254
configure vrrp vlan VLAN_0103 vrid 100 add 192.168.104.254
configure vrrp vlan VLAN_0103 vrid 100 add 192.168.103.254
configure vrrp vlan VLAN_0105 vrid 100 add 192.168.105.254
configure vrrp vlan VLAN_0106 vrid 100 add 192.168.106.254
configure vrrp vlan VLAN_0210 vrid 100 add 192.168.210.254
configure vrrp vlan VLAN_0114 vrid 100 add 192.168.114.254
enable vrrp vlan VLAN_0099 vrid 100
enable vrrp vlan VLAN_0095 vrid 100
enable vrrp vlan VLAN_0100 vrid 100
enable vrrp vlan VLAN_0101 vrid 100
enable vrrp vlan VLAN_0103 vrid 100
enable vrrp vlan VLAN_0105 vrid 100
enable vrrp vlan VLAN_0106 vrid 100
enable vrrp vlan VLAN_0210 vrid 100
enable vrrp vlan VLAN_0114 vrid 100
#
# Module vsm configuration.
#
create mlag peer "HQ-690"
configure mlag peer "HQ-690" ipaddress 172.16.0.1 vr VR-Default
enable mlag port 11 peer "HQ-690" id 6
enable mlag port 12 peer "HQ-690" id 7
enable mlag port 22 peer "HQ-690" id 2
enable mlag port 23 peer "HQ-690" id 5
enable mlag port 31 peer "HQ-690" id 1
enable mlag port 47 peer "HQ-690" id 4
enable mlag port 48 peer "HQ-690" id 3


Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb

Posted 5 months ago

  • 0
  • 1
Photo of Frank

Frank

  • 3,836 Points 3k badge 2x thumb
I assume that the workstation from which you telnet to the two 690s is on a different switch than the 690s?
If that's the case, could you copy the "sharing / grouping" part of the "access-switch" real quick, please?
Photo of Carsten Buchenau

Carsten Buchenau

  • 956 Points 500 badge 2x thumb
Can you also add the vlan and port sharing configuration from both switches?
Specifically I am interested in:- Ports used for the ISC (VLAN 2000), and how they are configured (as sharing group, with LACP?)- Are all VLANs + the ISC VLAN added as tagged to the ISC port(s)?- Is the ISC port NOT configured as MLAG port?- Can you confirm that the ISC VLAN is ONLY on the ISC ports?
- Sharing and LACP configuration for MLAG ports 11, 12, 22, 23, 31, 47, 48 - and, as Frank already asked, are the switches on the other side configured the same way? (link aggregation yes/no, LACP yes/no, which algorithm....)
Also, a simple diagram showing all ISC, MLAG and upstream router connections as well as port numbers would help...
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb


Topology is like on a picture
(Edited)
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
My workstation is on TP-Link switch.

Port configuration on HQ-690:
#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-72
configure vr VR-Default add ports 1-72
configure vlan default delete ports 1-72
configure vlan untagged-ports auto-move off
create qosprofile "QP2"
create qosprofile "QP3"
create qosprofile "QP4"
create vlan "border_to_junuser"
configure vlan border_to_junuser tag 20
create vlan "CIC"
configure vlan CIC tag 1093
create vlan "control_eaps1"
configure vlan control_eaps1 tag 1090
create vlan "LifeMigration"
configure vlan LifeMigration tag 1091
create vlan "MLAG_CONTROL"
configure vlan MLAG_CONTROL tag 2000
create vlan "SMB"
configure vlan SMB tag 1092
create vlan "VLAN_0091"
configure vlan VLAN_0091 tag 91
create vlan "VLAN_0095"
configure vlan VLAN_0095 description "LuftGansa Systems Vlan" 
configure vlan VLAN_0095 tag 95
create vlan "VLAN_0098"
configure vlan VLAN_0098 description "backup" 
configure vlan VLAN_0098 tag 98
create vlan "VLAN_0099"
configure vlan VLAN_0099 tag 99
create vlan "VLAN_0100"
configure vlan VLAN_0100 tag 100
create vlan "VLAN_0101"
configure vlan VLAN_0101 description "HQ_101_102-SubNet" 
configure vlan VLAN_0101 tag 101
create vlan "VLAN_0103"
configure vlan VLAN_0103 tag 103
create vlan "VLAN_0105"
configure vlan VLAN_0105 tag 105
create vlan "VLAN_0106"
configure vlan VLAN_0106 description "Block B" 
configure vlan VLAN_0106 tag 106
create vlan "VLAN_0107"
configure vlan VLAN_0107 tag 107
create vlan "VLAN_0111"
configure vlan VLAN_0111 description "Management Vlan Wi-Fi" 
configure vlan VLAN_0111 tag 111
create vlan "VLAN_0112"
configure vlan VLAN_0112 tag 112
create vlan "VLAN_0114"
configure vlan VLAN_0114 tag 114
create vlan "VLAN_0154"
configure vlan VLAN_0154 description "Wi-Fi_net_U6" 
configure vlan VLAN_0154 tag 154
create vlan "VLAN_0210"
configure vlan VLAN_0210 tag 210
create vlan "VLAN_0250"
configure vlan VLAN_0250 tag 250
create vlan "VLAN_0254"
configure vlan VLAN_0254 tag 254
configure ports 1 auto on speed 1000 
configure ports 2 auto on speed 1000 
configure ports 3 auto on speed 1000 
configure ports 4 auto on speed 1000 
configure ports 5 auto on speed 1000 
configure ports 6 auto on speed 1000 
configure ports 7 auto on speed 1000 
configure ports 8 auto on speed 1000 
configure ports 9 auto on speed 1000 
configure ports 10 auto on speed 1000 
configure ports 11 auto off speed 1000 duplex full 
configure ports 12 auto off speed 1000 duplex full 
configure ports 13 auto off speed 10000 duplex full 
configure ports 14 auto off speed 10000 duplex full 
configure ports 15 auto off speed 10000 duplex full 
configure ports 16 auto off speed 10000 duplex full 
configure ports 17 auto on speed 1000 
configure ports 18 auto off speed 10000 duplex full 
configure ports 19 auto on speed 1000 
configure ports 20 auto off speed 1000 duplex full 
configure ports 21 auto off speed 1000 duplex full 
configure ports 22 auto off speed 10000 duplex full 
configure ports 23 auto off speed 10000 duplex full 
configure ports 24 auto off speed 10000 duplex full 
configure ports 25 auto off speed 10000 duplex full 
configure ports 26 auto off speed 10000 duplex full 
configure ports 27 auto off speed 10000 duplex full 
configure ports 28 auto off speed 10000 duplex full 
configure ports 29 auto off speed 10000 duplex full 
configure ports 30 auto off speed 10000 duplex full 
configure ports 31 auto off speed 1000 duplex full 
configure ports 32 auto off speed 1000 duplex full 
configure ports 33 auto off speed 10000 duplex full 
configure ports 34 auto off speed 10000 duplex full 
configure ports 35 auto off speed 10000 duplex full 
configure ports 36 auto off speed 10000 duplex full 
configure ports 37 auto off speed 10000 duplex full 
configure ports 38 auto off speed 10000 duplex full 
configure ports 39 auto off speed 10000 duplex full 
configure ports 40 auto off speed 10000 duplex full 
configure ports 41 auto off speed 10000 duplex full 
configure ports 42 auto off speed 10000 duplex full 
configure ports 43 auto off speed 10000 duplex full 
configure ports 44 auto off speed 10000 duplex full 
configure ports 45 auto off speed 10000 duplex full 
configure ports 46 auto off speed 10000 duplex full 
configure ports 47 auto off speed 10000 duplex full 
configure ports 48 auto off speed 10000 duplex full 
configure ports 50 auto off speed 10000 duplex full 
configure ports 51 auto off speed 10000 duplex full 
configure ports 52 auto off speed 10000 duplex full 
configure ports 54 auto off speed 10000 duplex full 
configure ports 55 auto off speed 10000 duplex full 
configure ports 56 auto off speed 10000 duplex full 
enable flow-control rx-pause qosprofile qp4 port 61
enable flow-control tx-pause priority 3 port 61
enable flow-control rx-pause qosprofile qp4 port 65
enable flow-control tx-pause priority 3 port 65
enable flow-control rx-pause qosprofile qp4 port 69
enable flow-control tx-pause priority 3 port 69
configure vlan CIC add ports 61,65,69 tagged  
configure vlan control_eaps1 add ports 61,69 tagged  
configure vlan LifeMigration add ports 61,65,69 tagged  
configure vlan MLAG_CONTROL add ports 69 tagged  
configure vlan SMB add ports 61,65,69 tagged  
configure vlan VLAN_0091 add ports 1-3,7,11-12,14,17,20,47-48,69 tagged  
configure vlan VLAN_0095 add ports 1-3,5,7,11-12,14,16-17,69 tagged  
configure vlan VLAN_0098 add ports 1,3,11-12,69 tagged  
configure vlan VLAN_0099 add ports 1-3,7,11-12,14,17,47-48,69 tagged  
configure vlan VLAN_0100 add ports 1-3,6-7,10-12,17,20-23,31,69 tagged  
configure vlan VLAN_0101 add ports 17,22,69 tagged  
configure vlan VLAN_0103 add ports 10,23,69 tagged  
configure vlan VLAN_0105 add ports 10,69 tagged  
configure vlan VLAN_0106 add ports 6,17,22,69 tagged  
configure vlan VLAN_0107 add ports 7,69 tagged  
configure vlan VLAN_0111 add ports 1,3,6-7,10,17,20,22-23,69 tagged  
configure vlan VLAN_0112 add ports 7,69 tagged  
configure vlan VLAN_0112 add ports 8 untagged  
configure vlan VLAN_0114 add ports 69 tagged  
configure vlan VLAN_0114 add ports 13 untagged  
configure vlan VLAN_0154 add ports 6-7,10,17,20,23,69 tagged  
configure vlan VLAN_0210 add ports 1-3,7,10-12,14,17,22,69 tagged  
configure vlan VLAN_0210 add ports 4-5,9,20 untagged  
configure vlan VLAN_0250 add ports 1,6-7,10,17,20,22-23,69 tagged  
configure vlan VLAN_0254 add ports 1-2,6-7,17,20,69 tagged  
configure vlan Mgmt ipaddress 192.168.100.253 255.255.255.0
configure vlan VLAN_0099 ipaddress 192.168.99.253 255.255.255.0
enable ipforwarding vlan VLAN_0099
configure vlan border_to_junuser ipaddress 10.130.1.10 255.255.255.252
enable ipforwarding vlan border_to_junuser
configure vlan VLAN_0095 ipaddress 192.168.95.253 255.255.255.0
enable ipforwarding vlan VLAN_0095
configure vlan VLAN_0100 ipaddress 192.168.100.253 255.255.255.0
enable ipforwarding vlan VLAN_0100
configure vlan VLAN_0101 ipaddress 192.168.101.253 255.255.255.0
enable ipforwarding vlan VLAN_0101
configure vlan VLAN_0101 add secondary-ipaddress 192.168.102.253 255.255.255.0
configure vlan VLAN_0103 ipaddress 192.168.103.253 255.255.255.0
enable ipforwarding vlan VLAN_0103
configure vlan VLAN_0103 add secondary-ipaddress 192.168.104.253 255.255.255.0
configure vlan VLAN_0105 ipaddress 192.168.105.253 255.255.255.0
enable ipforwarding vlan VLAN_0105
configure vlan VLAN_0106 ipaddress 192.168.106.253 255.255.255.0
enable ipforwarding vlan VLAN_0106
configure vlan VLAN_0210 ipaddress 192.168.210.253 255.255.255.0
enable ipforwarding vlan VLAN_0210
configure vlan MLAG_CONTROL ipaddress 172.16.0.1 255.255.255.252
configure vlan VLAN_0114 ipaddress 192.168.114.253 255.255.255.0
enable ipforwarding vlan VLAN_0114
Port configuration on TR-690:
#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-72
configure vr VR-Default add ports 1-72
configure vlan default delete ports 1-72
configure vlan untagged-ports auto-move off
create qosprofile "QP2"
create qosprofile "QP3"
create qosprofile "QP4"
create vlan "CIC"
configure vlan CIC tag 1093
create vlan "control_eaps1"
configure vlan control_eaps1 tag 1090
create vlan "LifeMigration"
configure vlan LifeMigration tag 1091
create vlan "MLAG_CONTROL"
configure vlan MLAG_CONTROL tag 2000
create vlan "SMB"
configure vlan SMB tag 1092
create vlan "VLAN_0091"
configure vlan VLAN_0091 tag 91
create vlan "VLAN_0095"
configure vlan VLAN_0095 tag 95
create vlan "VLAN_0098"
configure vlan VLAN_0098 description "backup" 
configure vlan VLAN_0098 tag 98
create vlan "VLAN_0099"
configure vlan VLAN_0099 tag 99
create vlan "VLAN_0100"
configure vlan VLAN_0100 tag 100
create vlan "VLAN_0101"
configure vlan VLAN_0101 tag 101
create vlan "VLAN_0103"
configure vlan VLAN_0103 tag 103
create vlan "VLAN_0105"
configure vlan VLAN_0105 tag 105
create vlan "VLAN_0106"
configure vlan VLAN_0106 tag 106
create vlan "VLAN_0107"
configure vlan VLAN_0107 tag 107
create vlan "VLAN_0111"
configure vlan VLAN_0111 description "Management Vlan Wi-Fi" 
configure vlan VLAN_0111 tag 111
create vlan "VLAN_0112"
configure vlan VLAN_0112 tag 112
create vlan "VLAN_0114"
configure vlan VLAN_0114 tag 114
create vlan "VLAN_0154"
configure vlan VLAN_0154 description "Wi-Fi_net_U6" 
configure vlan VLAN_0154 tag 154
create vlan "VLAN_0210"
configure vlan VLAN_0210 tag 210
create vlan "VLAN_0250"
configure vlan VLAN_0250 tag 250
create vlan "VLAN_0254"
configure vlan VLAN_0254 tag 254
configure ports 1 auto off speed 10000 duplex full 
configure ports 2 auto off speed 10000 duplex full 
configure ports 3 auto off speed 10000 duplex full 
configure ports 4 auto off speed 10000 duplex full 
configure ports 5 auto off speed 10000 duplex full 
configure ports 6 auto off speed 10000 duplex full 
configure ports 7 auto off speed 10000 duplex full 
configure ports 8 auto off speed 10000 duplex full 
configure ports 9 auto off speed 10000 duplex full 
configure ports 10 auto off speed 10000 duplex full 
configure ports 11 auto off speed 10000 duplex full 
configure ports 12 auto off speed 10000 duplex full 
configure ports 13 auto off speed 10000 duplex full 
configure ports 14 auto off speed 1000 duplex full 
configure ports 15 auto off speed 10000 duplex full 
configure ports 16 auto off speed 10000 duplex full 
configure ports 17 auto off speed 10000 duplex full 
configure ports 18 auto off speed 10000 duplex full 
configure ports 19 auto off speed 10000 duplex full 
configure ports 20 auto off speed 10000 duplex full 
configure ports 21 auto off speed 10000 duplex full 
configure ports 22 auto off speed 10000 duplex full 
configure ports 23 auto off speed 10000 duplex full 
configure ports 24 auto off speed 10000 duplex full 
configure ports 25 auto off speed 10000 duplex full 
configure ports 26 auto off speed 10000 duplex full 
configure ports 27 auto off speed 10000 duplex full 
configure ports 28 auto off speed 10000 duplex full 
configure ports 29 auto off speed 10000 duplex full 
configure ports 30 auto off speed 10000 duplex full 
configure ports 31 auto off speed 1000 duplex full 
configure ports 32 auto off speed 10000 duplex full 
configure ports 33 auto off speed 10000 duplex full 
configure ports 34 auto off speed 10000 duplex full 
configure ports 35 auto off speed 10000 duplex full 
configure ports 36 auto off speed 10000 duplex full 
configure ports 37 auto off speed 10000 duplex full 
configure ports 38 auto off speed 10000 duplex full 
configure ports 39 auto off speed 10000 duplex full 
configure ports 40 auto off speed 10000 duplex full 
configure ports 41 auto off speed 10000 duplex full 
configure ports 42 auto off speed 10000 duplex full 
configure ports 43 auto off speed 10000 duplex full 
configure ports 44 auto off speed 10000 duplex full 
configure ports 45 auto off speed 10000 duplex full 
configure ports 46 auto off speed 10000 duplex full 
configure ports 47 auto off speed 10000 duplex full 
configure ports 48 auto off speed 10000 duplex full 
configure ports 50 auto off speed 10000 duplex full 
configure ports 51 auto off speed 10000 duplex full 
configure ports 52 auto off speed 10000 duplex full 
configure ports 54 auto off speed 10000 duplex full 
configure ports 55 auto off speed 10000 duplex full 
configure ports 56 auto off speed 10000 duplex full 
enable flow-control rx-pause qosprofile qp4 port 61
enable flow-control tx-pause priority 3 port 61
enable flow-control rx-pause qosprofile qp4 port 65
enable flow-control tx-pause priority 3 port 65
enable flow-control rx-pause qosprofile qp4 port 69
enable flow-control tx-pause priority 3 port 69
configure vlan CIC add ports 61,65,69 tagged  
configure vlan control_eaps1 add ports 61,69 tagged  
configure vlan LifeMigration add ports 61,65,69 tagged  
configure vlan MLAG_CONTROL add ports 69 tagged  
configure vlan SMB add ports 61,65,69 tagged  
configure vlan VLAN_0091 add ports 11-12,14,47-48,61,69 tagged  
configure vlan VLAN_0095 add ports 11-12,14,69 tagged  
configure vlan VLAN_0098 add ports 11-12,69 tagged  
configure vlan VLAN_0099 add ports 11-12,14,47-48,61,69 tagged  
configure vlan VLAN_0100 add ports 11-12,22-23,31,69 tagged  
configure vlan VLAN_0101 add ports 22,69 tagged  
configure vlan VLAN_0103 add ports 23,69 tagged  
configure vlan VLAN_0105 add ports 69 tagged  
configure vlan VLAN_0106 add ports 22,69 tagged  
configure vlan VLAN_0107 add ports 69 tagged  
configure vlan VLAN_0111 add ports 22-23,69 tagged  
configure vlan VLAN_0112 add ports 69 tagged  
configure vlan VLAN_0114 add ports 69 tagged  
configure vlan VLAN_0114 add ports 5 untagged  
configure vlan VLAN_0154 add ports 23,69 tagged  
configure vlan VLAN_0210 add ports 11-12,14,22,69 tagged  
configure vlan VLAN_0250 add ports 22-23,69 tagged  
configure vlan VLAN_0254 add ports 69 tagged  
configure vlan Mgmt ipaddress 192.168.100.252 255.255.255.0
configure vlan VLAN_0099 ipaddress 192.168.99.252 255.255.255.0
enable ipforwarding vlan VLAN_0099
configure vlan MLAG_CONTROL ipaddress 172.16.0.2 255.255.255.252
configure vlan VLAN_0095 ipaddress 192.168.95.252 255.255.255.0
enable ipforwarding vlan VLAN_0095
configure vlan VLAN_0100 ipaddress 192.168.100.252 255.255.255.0
enable ipforwarding vlan VLAN_0100
configure vlan VLAN_0101 ipaddress 192.168.101.252 255.255.255.0
enable ipforwarding vlan VLAN_0101
configure vlan VLAN_0101 add secondary-ipaddress 192.168.102.252 255.255.255.0
configure vlan VLAN_0103 ipaddress 192.168.103.252 255.255.255.0
enable ipforwarding vlan VLAN_0103
configure vlan VLAN_0103 add secondary-ipaddress 192.168.104.252 255.255.255.0
configure vlan VLAN_0105 ipaddress 192.168.105.252 255.255.255.0
enable ipforwarding vlan VLAN_0105
configure vlan VLAN_0106 ipaddress 192.168.106.252 255.255.255.0
enable ipforwarding vlan VLAN_0106
configure vlan VLAN_0210 ipaddress 192.168.210.252 255.255.255.0
enable ipforwarding vlan VLAN_0210
configure vlan VLAN_0254 ipaddress 192.168.254.242 255.255.255.0
enable ipforwarding vlan VLAN_0254
configure vlan VLAN_0114 ipaddress 192.168.114.252 255.255.255.0
enable ipforwarding vlan VLAN_0114
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
HP-5130 configuration:
<1159/1160_HP-5130-24G-SFP_HQ-R132-S1-U35/36>show current-configuration
#
 version 7.1.070, Release 3208P03
#
 sysname 1159/1160_HP-5130-24G-SFP_HQ-R132-S1-U35/36
#
 clock timezone Ekaterinburg add 05:00:00
 clock protocol ntp
#
 telnet server enable
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
 irf member 1 priority 32
 irf member 2 priority 1
#
 ip unreachables enable
 ip ttl-expires enable
#
 dhcp snooping enable
#
 password-recovery enable
#
vlan 1
#
vlan 95
 description LSY
#
vlan 100
 name Control
 description Control
#
vlan 101
 description net_101
#
vlan 102
 description net_102
#
vlan 106
 description net_106
#
vlan 111
 description Control_Wi-Fi
#
vlan 154
 description Wi-Fi_VIP
#
vlan 210
 description net_210
#
vlan 250
 description Wi-Fi_Guest
#
vlan 500
 description border_to_dhcp
#
vlan 3102
#
irf-port 1/1
 port group interface Ten-GigabitEthernet1/0/25
 port group interface Ten-GigabitEthernet1/0/26
#
irf-port 2/2
 port group interface Ten-GigabitEthernet2/0/27
 port group interface Ten-GigabitEthernet2/0/28
#
 stp global enable
#
interface Bridge-Aggregation1
 description LAG_to_Extreme
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 95 100 to 101 106 111 154 210 250 500 3101 to 3102
 undo stp enable
 dhcp snooping trust
#
interface Bridge-Aggregation2
 description LAG_to_1209
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 95 100 to 101 106 111 154 210 250 500 3101 to 3102
 undo stp enable
 dhcp snooping trust
#
interface Bridge-Aggregation3
 description LAG_to_1210
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 undo stp enable
#
interface Bridge-Aggregation4
 description LAG_to_1208
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 undo stp enable
#
interface Bridge-Aggregation5
 description LAG_to_1211
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 undo stp enable
#
interface Bridge-Aggregation6
 description LAG_to_1201
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 undo stp enable
#
interface Bridge-Aggregation7
 description LAG_to_1236
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
 undo stp enable
#
interface Bridge-Aggregation8
 description LAG_to_1199_HQ-k219
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
 undo stp enable
#
interface NULL0
#
interface Vlan-interface100
 ip address 192.168.100.65 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 95 100 to 101 106 111 154 210 250 500 3101 to 3102
 port link-aggregation group 2
#
interface GigabitEthernet1/0/2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 3
#
interface GigabitEthernet1/0/3
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 4
#
interface GigabitEthernet1/0/4
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 5
#
interface GigabitEthernet1/0/5
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 6
#
interface GigabitEthernet1/0/6
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
 port link-aggregation group 7
#
interface GigabitEthernet1/0/7
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
#
interface GigabitEthernet1/0/8
#
interface GigabitEthernet1/0/9
#
interface GigabitEthernet1/0/10
#
interface GigabitEthernet1/0/11
#
interface GigabitEthernet1/0/12
#
interface GigabitEthernet1/0/13
#

Сергей Землянский, [26.06.18 13:26]
interface GigabitEthernet1/0/14
#
interface GigabitEthernet1/0/15
#
interface GigabitEthernet1/0/16
#
interface GigabitEthernet1/0/17
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
 combo enable copper
 port link-aggregation group 8
#
interface GigabitEthernet1/0/18
 port access vlan 100
 combo enable copper
#
interface GigabitEthernet1/0/19
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 91 99 to 101 111 154 250
 combo enable copper
#
interface GigabitEthernet1/0/20
 combo enable copper
#
interface GigabitEthernet1/0/21
 combo enable copper
#
interface GigabitEthernet1/0/22
 combo enable copper
#
interface GigabitEthernet1/0/23
 combo enable copper
#
interface GigabitEthernet1/0/24
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100
 combo enable fiber
#
interface GigabitEthernet2/0/1
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 95 100 to 101 106 111 154 210 250 500 3101 to 3102
 port link-aggregation group 2
#
interface GigabitEthernet2/0/2
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 3
#
interface GigabitEthernet2/0/3
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 4
#
interface GigabitEthernet2/0/4
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 5
#
interface GigabitEthernet2/0/5
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101 106 111 154 210 250 254
 port link-aggregation group 6
#
interface GigabitEthernet2/0/6
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
 port link-aggregation group 7
#
interface GigabitEthernet2/0/7
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
#
interface GigabitEthernet2/0/8
#
interface GigabitEthernet2/0/9
#
interface GigabitEthernet2/0/10
#
interface GigabitEthernet2/0/11
#
interface GigabitEthernet2/0/12
#
interface GigabitEthernet2/0/13
#
interface GigabitEthernet2/0/14
#
interface GigabitEthernet2/0/15
#
interface GigabitEthernet2/0/16
#
interface GigabitEthernet2/0/17
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100 to 101
 combo enable copper
 port link-aggregation group 8
#
interface GigabitEthernet2/0/18
 combo enable copper
#
interface GigabitEthernet2/0/19
 combo enable copper
#
interface GigabitEthernet2/0/20
 combo enable copper
#
interface GigabitEthernet2/0/21
 combo enable copper
#
interface GigabitEthernet2/0/22
 combo enable copper
#
interface GigabitEthernet2/0/23
 combo enable copper
#
interface GigabitEthernet2/0/24
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 100
 combo enable fiber
#
interface Ten-GigabitEthernet1/0/27
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 95 100 to 101 106 111 154 210 250 500 3101 to 3102
 speed 1000
 port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/28
#
interface Ten-GigabitEthernet2/0/25
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 95 100 to 101 106 111 154 210 250 500 3101 to 3102
 speed 1000
 port link-aggregation group 1
#
interface Ten-GigabitEthernet2/0/26
#
interface Ten-GigabitEthernet1/0/25
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet2/0/27
#
interface Ten-GigabitEthernet2/0/28
#
 scheduler logfile size 16
#
line class aux
 user-role network-admin
#
line class vty
 user-role network-operator
#
line aux 0 1
 user-role network-admin
#
line vty 0 15
 authentication-mode scheme
 user-role network-admin
 user-role network-operator
 protocol inbound ssh
 idle-timeout 0 0
#
line vty 16
 authentication-mode scheme
 user-role network-admin
 user-role network-operator
 protocol inbound telnet
 idle-timeout 0 0
#
line vty 17 63

Сергей Землянский, [26.06.18 13:26]
authentication-mode scheme
 user-role network-admin
 user-role network-operator
 protocol inbound telnet
#
 ip route-static 192.168.100.0 24 192.168.100.254
 ip route-static 192.168.210.0 24 192.168.100.254
#
 snmp-agent
 snmp-agent local-engineid 800063A2802C233A3C7FBF00000001
 snmp-agent community read public
 snmp-agent sys-info contact ost@u6.ru
 snmp-agent sys-info location HQ-R132-S1-U36/35
 snmp-agent sys-info version all
#
 ssh server enable
#
 ntp-service enable
 ntp-service unicast-server 192.168.210.222
#
radius scheme system
 user-name-format without-domain
#
domain system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
local-user admin class manage
 password hash $h$6$tlm9B/4vbo80MImC$v1MiGwbgkmHLCKZeAyjScgwvmGqpATJ168y/tN0CyMNXzRGtmRue3e/Uv02lhe6Gnti8bPVRlwMA/9kLFZEs4w==
 service-type telnet http https pad ssh terminal
 authorization-attribute user-role network-admin
 authorization-attribute user-role network-operator
#
local-user backup class manage
 password hash $h$6$awUXBjDKKcqvVYuy$RXh/xeGaZEEiKkhFaMX+GoLBMSnEpmhnlwkOtzwuhifIvkFlofrh2lL8oS/d5jz7n6donUxpRp95xgRPNsehAA==
 service-type telnet ssh
 authorization-attribute user-role network-admin
 authorization-attribute user-role network-operator
#
 ip http enable
 ip https enable
#
return
Photo of Frank

Frank

  • 3,836 Points 3k badge 2x thumb
Thanks!
Now, on the 690s, do you have an entry like "enable sharing port 22 grouping 22" (assuming that port 22 is the uplink port to the HP switch(es) ?

You may need to do something like
- enable sharing 22 grouping 22 lacp

and maybe even (I had to do that for our attached Ciscos, as they don't negotiate priorities well):
- configure sharing 22 lacp system-priority 32768
But I'd first try without that line.
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
As I know, if on first side lacp is enabled, but on second is not, trafic will not be transmitted at all.
Here we can see packet delays and losses, but it works.

All this switches are in production, so we can't change anything that can cause service to stop.
(Edited)
Photo of Frank

Frank

  • 3,836 Points 3k badge 2x thumb
But if I understand correctly, when you group ports on HP switches (or basically anything non-Extreme), you're running LACP.
If I see this right, then there's no LACP configured on the Extreme 690s at all.
I would think it "works" because it's not properly configured on the Extreme side and basically you're only using one link (the one where telnet works), the other link gives issues because it would want to play LACP but can't.

But I have to admit that at this point (why does it work?), I'm mostly guessing. Maybe someone with deeper understanding on the interactions of HP and Extreme will pop up in the thread with a better explanation. As it's all in production and everything works right now, I'd wait for a guru to put in his/her two cents. Especially with tips on how to fix things properly while everything's running...

If nobody shows up, you might have to open a case - those guys would know for sure!
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
Turned on LACP on HP's and enabled sharing on extreme's. 
No changes...
(Edited)
Photo of Carsten Buchenau

Carsten Buchenau

  • 956 Points 500 badge 2x thumb
First thoughts that come to my mind:

It looks like you are running and EAPS ring as well. The EAPS master switch with blocking port cannot be an MLAG peer as well, see also this thread: https://community.extremenetworks.com/extreme/topics/eaps_and_mlag
Your ISC should always be redundant, so ideally a sharing group over 2 ports with LACP enabled. Not relevant for your issue, but important for your overall design.
What are HV0 and HV1 (servers?), and how are they connected with the "brown" link to the x690 (port 65) and the x870? Is this supposed to be another LAG / MLAG??
Where is your upstream connectivity connected to, and how?

Overall... I don't get your design with the 2 x870 and the 2 x690, what their roles are and how they are connected and why. What exactly do you want to achieve? At the moment it looks like you have added several redundancy concepts just because, adding way too much complexity. 
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
Main idea of double X870 is to transport lossless traffic between servers HV01 and HV02. They connected to X870 with 100G DAC-cables. This way has 3 VLANs for HV01 and HV02. Another link from HV01 and HV02 to 65 ports is 100G DAC-cables too. This is alternative way in situation of link failure between X870 switches. I am using EAPS only for those 3 VLANs, in EAPS ring link between X690 and X870 in HQ is blocked, so link between X690 switches is always up. Another links from HV01 and HV02 to X690 (47,48 ports) are in MLAG and used for user access to VMs on servers.

HQ and TR is different buildings, so it a little expensive to have 2 ports in LAG between X690 switches.
(Edited)
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb


Picture for EAPS Domen
Photo of Carsten Buchenau

Carsten Buchenau

  • 946 Points 500 badge 2x thumb
What I remember is that the EAPS Master cannot / must not be a Switch with MLAG enabled:

"MLAG ports cannot be configured to be EAPS ring ports. Configuration of the ISC port as an EAPS blocked port is disallowed."

https://documentation.extremenetworks.com/exos_22.2/exos_21_1/slots_and_ports/r_limitations-and-requ...


Hence one of your x870 should be the EAPS Master with blocking port, not the x690 - assuming that you have no MLAG configuration on the x870s?

See also this thread:
https://community.extremenetworks.com/extreme/topics/eaps_and_mlag

I don't have enough experience with EAPS to tell if this could be the source of your issues, but it should be worth to get it sorted anyway.
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
Hence one of your x870 should be the EAPS Master with blocking port, not the x690 - assuming that you have no MLAG configuration on the x870s?
Yes, i have no MLAG configuration on X870 switches at all.
I will try to divide EAPS and MLAG in different physical links.
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb


Picture for MLAG connetions
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
It seems to be that I have to get 2 new 10Gb links between X690 in addition to one 100Gb link. And then divide EAPS and MLAG like EAPS in 100G for server traffic redundancy, and MLAG in new 10G link for MLAG and VRRP redundancy. Is this solution good enough?
Photo of Lexus92008

Lexus92008

  • 240 Points 100 badge 2x thumb
The official answear is that there is a bug of EXOS. So next EXOS version must be with patch, that fixes this bug.
Thanks to everyone for answers.