MPLS Kernel error

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hello,

After a link failure between a path of MPLS the l2vpn are stopping to work.
Then some logs are show:

<Erro:Kern.MPLS.Error> MPLS: bcm_mpls_port_add failed for unit = 0 vpn = 0x7025, port = 0x8000006 vp = 0x18000e86, rv = -14 (No resources for operation)
 <Erro:Kern.MPLS.Error> MPLS bcm_mpls_port_del failed for unit = 0 vpn = 0x7025, vp = 0x18000e6e rv = -7 (Entry not found)
<Erro:Kern.MPLS.Error> extreme_custom_mpls_port_del_async_rtn: MPLS port delete: vp: 0xe6e  l3Intf = 0x9c2 map entry not found in btree rv = -7 (Entry not found)
<Erro:Kern.MPLS.Error> extreme_mpls_del_vp_nh_xref: MPLS ECMP NH vp : 0xe6e l3intf = 0x9c2 map entry not found in btree rv = -7 (Entry not found)


disabling the l2vpn the tunnel return to work.

the version of both NE are ExtremeXOS version 15.6.3.1 v1563b1-patch1-5 by release-manager



Any suggestions?
Photo of Julian Eble

Julian Eble

  • 1,394 Points 1k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Alexandr P

Alexandr P, Embassador

  • 12,192 Points 10k badge 2x thumb
Hello, Julian!

I think you have to investigate in direction of switch resources distribution:
<Erro:Kern.MPLS.Error> MPLS: bcm_mpls_port_add failed for unit = 0 vpn = 0x7025, port = 0x8000006 vp = 0x18000e86, rv = -14 (No resources for operation)

Thank you!
Photo of Julian Eble

Julian Eble

  • 1,394 Points 1k badge 2x thumb
After an updated to version  summitX-15.7.3.1.xos, a similar behavior is seen:

01/23/2016 12:50:47.64 <Erro:Kern.MPLS.Error> MPLS _bcm_tr_mpls_broadcast_replication_list_add failed for unit = 0 vpn = 0x7012, port = 0x8000006 vp = 0x18000830, nh = 0x61ae5, rv = -18 (Invalid port)01/23/2016 13:35:59.57 <Erro:Kern.MPLS.Error> Unable to destroy L3 egress forwarding object for unit 0, l3intf = 0xd, egress obj = 0x18706, returnCode = Entry not found
Photo of Alexandr P

Alexandr P, Embassador

  • 12,192 Points 10k badge 2x thumb
I think you have to open case in TAC.

Thank you!
(Edited)
Photo of Brunno Lopes

Brunno Lopes

  • 218 Points 100 badge 2x thumb
Hello Julian, 

We had a similar issue with IPv4, L3 VPN and L2 VPN (VPLS and VPWS) on our BD8K. According to TAC it is caused by ECMP. The issue is being investigated by TAC, and we've been sugested to disable ECMP (L3 load balance) to avoid this issue. 

Best regards, 
Photo of Julian Eble

Julian Eble

  • 1,394 Points 1k badge 2x thumb
Well after some issues this weekend, a new kernel error shows up

Kern.IPv4FIB: vrId 2: Invalid parameter: could not add DEFIP entry 0xAC1FFE00:24 nhop 0x00000000

This happened after  some other kernel error

Kern.MPLS: MPLS: bcm_mpls_port_add failed for unit = 0 vpn = 0x7045, port = 0xc000001 vp = 0x1800047d, rv = -14 (No resources for operation)

The impact was huge...