Multicast at 1000 Mbits/s works, but 100 Mbts/s don't.

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)

Hello community, I have a
problem while I'm uploading an image with my fog server: multicast works well with my X440 switches (1000 Mbits/s) but with my x250 (100 Mbits/s) it stops after ~5min. It resumes when I restart all my ports concerned by my deployment: (my fog server and PCs).

When it stops, my PC unsubscribe to the udpcast group and resuscribe when I restart my ports.

I have the same issue when i configure my X440 PC ports at 100Mbits/s.

There is nothing in my logs that says that's my ports are blocked or somethings...

What do you suggest me to check ? 


Thanks!

Best regards,
Adrien, from France.

Photo of Paris

Paris

  • 130 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
It looks to me the multicast stream times out on the switch. take a look at igmp snooping on the X250 switch. Packet handling is not handled differently between 1 gb port or a 100 Mb port, internal it is all handled the same. However the table sizes of older and newer switches differ and multicast table size could play a role here. 
Photo of Paris

Paris

  • 130 Points 100 badge 2x thumb
Thank you for your answer, it works (1000Mb or 100Mb) when i disable igmp snooping in the concerned Vlan but only if my Fog server and my PC (to deploy) are on the same switch.
it doesn't when i go trought my network.
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
Hi,igmp snooping on other switches play a role also. Disabling igmp snooping is a temporary solution, better is to investigate why the snooping entry times out or if a table is full (that would be logged).
Photo of Paris

Paris

  • 130 Points 100 badge 2x thumb
Yes it can be a temporary solution, the table is not full but is there a solution to check the snooping entry times ? is it "the age" ? 
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
yes, show igmp snooping <vlan> you will see senders and subscribers and the timers/age.
Photo of Paris

Paris

  • 130 Points 100 badge 2x thumb
Actually it is the age of the hosts that causes the exclusion of groups (when it's higher than 260 seconds)
I do not know the risks of increasing this timeout accross of my network, what is the way for my hosts to "re-subscribe" in order to make reset this timer/age ? Is it on the switch or on my deployment server in your opinion?
Thank you for your help.
(Edited)
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
The client should subscribe to the streams and keep that subsciption alive by sending a report when a switch is asking (query) for it. The switch should do a query before removing a port from the stream, you could do a capture to see if you get that igmp query and if the client responds to it.
Photo of Kawawa

Kawawa, GTAC

  • 3,292 Points 3k badge 2x thumb
Out of curiosity, does the VLAN where the receiver is have an IP?  IGMP snooping requires at least one querier to be present in the VLAN and the querier should have an IP.  The querier will poll subscribed hosts to see if they are still interested in a stream.  And if the querier doesn't receive any responses it ages the host.  The default host timeout is 260 seconds (around 4 minutes).  Here's an example:

# show igmp snooping v70Router Timeout                :    260 secHost Timeout                  :    260 secIgmp Snooping Fast Leave Time :   1000 msVLAN v70              (70) Snooping=Enabled      Group           Sender          Age      239.0.0.10      70.0.0.2        15       1 Incoming multicast streams     Port   Host            Subscribed        Age    Group-Limit        21     70.0.0.3        239.255.255.250   253    0 
Once the 260 seconds elapses, the host is disconnected from the stream:
# show igmp snooping v70Router Timeout                :    260 sec
Host Timeout                  :    260 sec
Igmp Snooping Fast Leave Time :   1000 ms
VLAN v70              (70) Snooping=Enabled  
    Group           Sender          Age  
    239.0.0.10      70.0.0.2        5    
    1 Incoming multicast streams 
Then I disable and re-enable the host port and the stream is back:
# disable ports 20# enable ports 20
# show igmp snooping v70
Router Timeout                :    260 sec
Host Timeout                  :    260 sec
Igmp Snooping Fast Leave Time :   1000 ms
VLAN v70              (70) Snooping=Enabled  
    Group           Sender          Age  
    239.0.0.10      70.0.0.2        5    
    1 Incoming multicast streams 
(Edited)
Photo of Erik Auerswald

Erik Auerswald, Embassador

  • 13,772 Points 10k badge 2x thumb
Hi,

the problem description hints at a missing IGMP querier.

On EXOS, the querier is configured on a VLAN that has an IP address using the following command:
enable igmp vlan VLAN_NAME IGMP_VERSION
This enables IGMP queries in this VLAN, allowing IP multicast to work correctly inside this VLAN.

IGMP snooping, enabled by default, requires either bidirectional multicast traffic or regular IGMP messages to keep the cache entries current. The relevant messages are created when an end system joins the group, thus multicast initially works, but this time out if there is no querier in the VLAN to trigger recurring group membership messages from the end systems.

To transport multicast from one VLAN to another needs additional mechanisms, e.g. multicast routing using PIM.

Thanks,
Erik
Photo of Paris

Paris

  • 130 Points 100 badge 2x thumb
Thanks for your help, it is actually a problem of IGMP snooping, i will fix this problem.

Best regards,
Adrien, from France.